Results 1 to 10 of 10

Thread: OpenOffice from Factory missing Math catalog

  1. #1
    novelgazer NNTP User

    Default OpenOffice from Factory missing Math catalog


    Just upgraded to OO.o 3.0.0.9-1.6 using the factory repository to clear
    up some other issues I was having. Everything seems to be working,
    except when I try to make a math formula, the catolog seems to have lost
    almost all of its math and greek symbols. Same problem if I try to
    enter them in the %pi format in the equation editor as well.

    I can't seem to figure out the issue or find a similar problem in the
    forums. Anyone else have this weirdness or can make a suggestion?


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  2. #2
    ram88 NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    novelgazer;1905598 Wrote:
    > Just upgraded to OO.o 3.0.0.9-1.6 using the factory repository to clear
    > up some other issues I was having. Everything seems to be working,
    > except when I try to make a math formula, the catolog seems to have lost
    > almost all of its math and greek symbols. Same problem if I try to
    > enter them in the %pi format in the equation editor as well.
    >
    > I can't seem to figure out the issue or find a similar problem in the
    > forums. Anyone else have this weirdness or can make a suggestion?


    I can use the pi sign, example

    Code:
    --------------------

    %pi approx 22 over 7

    --------------------

    renders without any problem.
    I can't use the permutation sign.


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  3. #3
    novelgazer NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    I get a blank for the %pi. I also noticed that I get odd symbols in
    place of normal characters like parentheses and the plus sign. I
    imagine I can go through the catalog and redefine every available
    symbol, but it seems like there should be a better solution.


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  4. #4
    novelgazer NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    CORRECTION: The OpenOffice.org Math version is 3.0.0.9-2.3 (1.6 is
    Writer, I guess.)


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  5. #5
    novelgazer NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    So I don't know if this information helps -- I can go into the catalog
    editor and fill in the Greek characters one by one. That's a pain in
    the neck, but if that's what has to happen, I'm cool with it.

    But, I'm noticing that almost all the mathematical operators, like
    plus, circle, , times, etc. give me entirely wrong characters. Plus
    gives me a little c that's two characters out of place, for example.
    Plus minus gives me a circle with the number 6 in it. These characters
    are apparently not changeable using the catalog editor?

    Still don't know what the deal is.


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  6. #6
    ram88 NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    novelgazer;1905608 Wrote:
    > CORRECTION: The OpenOffice.org Math version is 3.0.0.9-2.3 (1.6 is
    > Writer, I guess.)

    Where you get this package? In the OpenOffice repository the latest
    version is 3.0.0.3.6-1.1.


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  7. #7
    novelgazer NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    From openSUSE-ftp 11.1-0 repository:
    'Index of /factory/repo/oss'
    (http://download.opensuse.org/factory/repo/oss)

    Package is dated November 30, 2008.


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  8. #8
    ram88 NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    novelgazer;1905991 Wrote:
    > From openSUSE-ftp 11.1-0 repository:
    > 'Index of /factory/repo/oss'
    > (http://download.opensuse.org/factory/repo/oss)
    >
    > Package is dated November 30, 2008.


    My OOo is from this repo:
    'Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0'
    (http://tinyurl.com/6mwpsr). Try to change your version.


    --
    http://yami.googlecode.com/
    http://akoskm.blogspot.com/
    ------------------------------------------------------------------------
    ram88's Profile: http://forums.opensuse.org/member.php?userid=1058
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  9. #9
    novelgazer NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    Although your suggestion has the benefit of good sense and a high
    likelyhood of working, I can't help but be disappointed that I can't
    figure this out. =)

    I'll downgrade when I return home this evening and report back the
    results for posterity. Thanks for the suggestion.


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


  10. #10
    novelgazer NNTP User

    Default Re: OpenOffice from Factory missing Math catalog


    Okay... too many tangled dependencies to downgrade satisfactorally, so I
    did some more digging -- found this link where someone was having a
    similar problem.

    '[WONTFIX] Formula only shows small squares instead of glyphs (View
    topic) • OpenOffice.org Community Forum'
    (http://tinyurl.com/5rjsdj)

    So, I fired up kcmfontinst (the KDE3 Font Installer) and added
    /usr/share/ooo3/basis3.0/share/fonts/truetype/opens___.ttf as a system
    font and that seemed to do the trick. I guess somewhere along the way,
    that font wasn't registered and OOo was defaulting to some lesser
    variation.

    I'm noticing some other, similar issues with galleries and whatnot, so
    I'm probably going to start the whole system fresh when OpenSuse 11.1
    comes out next week. Nice that it coincides with winter/Christmas break
    so well.


    --
    novelgazer
    ------------------------------------------------------------------------
    novelgazer's Profile: http://forums.opensuse.org/member.php?userid=16746
    View this thread: http://forums.opensuse.org/showthread.php?t=401326


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •