Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: yast2 shot dead

  1. #11
    caf4926 NNTP User

    Default Re: yast2 shot dead


    well Yast is installed but maybe it needs re-installing, but can't
    understand that last error, were you su?

    anyway

    try this

    Ctrl-Alt-F1 (or reboot and start in level 3 and login as user, then go
    su)

    go su and type

    yast2

    does this start yast


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  2. #12
    Magic31 NNTP User

    Default Re: yast2 shot dead


    also curious. What happens if you force zypper to do a cache refresh?

    zypper ref -f

    and then retry the 'zypper install yast2*'.


    --
    Have allot of fun! *WJM*
    ------------------------------------------------------------------------
    Magic31's Profile: http://forums.opensuse.org/member.php?userid=289
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  3. #13
    topitz NNTP User

    Default Re: yast2 shot dead


    okay ... ctl+alt+f1ed it, and here is the output:

    linux-sne5# yast
    /sbin/yast:line 421:10909 segmentation fault $ybindir/y2base
    $module "$@" "selected_gui
    author: Marco Skambraks
    linux-sne5#

    and yast did not launch ... theo


    --
    topitz
    ------------------------------------------------------------------------
    topitz's Profile: http://forums.opensuse.org/member.php?userid=5467
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  4. #14
    caf4926 NNTP User

    Default Re: yast2 shot dead


    Yikes!!

    you could pick the yast2 base rpm's up from the repo's and install from
    a terminal with the force option.

    I would stick with zypper first though

    try:

    sudo rpmdb --rebuilddb

    zypper refresh

    then go su in the terminal

    zypper in -f yast2*


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.82) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.82 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  5. #15
    topitz NNTP User

    Default Re: yast2 shot dead


    here is what
    sudo rpmdb --rebuilddb
    zypper refresh
    then go su in the terminal
    zypper in -f yast2*
    produced ...

    fenris@linux-sne5:~> sudo rpmdb --rebuilddb
    root's password:
    zypper refresh
    fenris@linux-sne5:~> zypper refresh
    Zum Aktualisieren der System-Repositories werden Root-Rechte bentigt.
    fenris@linux-sne5:~> su
    Passwort:
    linux-sne5:/home/fenris # cd
    linux-sne5:~ # zypper refresh
    Repository '20081124-214811' ist aktuell.
    Repository 'KDE4 Qt' ist aktuell.
    Repository 'KDE4 Qt44' ist aktuell.
    Repository 'Packman RPMs' ist aktuell.
    Repository 'NVIDIA Repository' ist aktuell.
    Repository 'Haupt-Repository (NON-OSS)' ist aktuell.
    Repository 'Haupt-Repository (OSS)' ist aktuell.
    Repository
    'http://download.opensuse.org/distribution/11.0/repo/oss/suse' ist
    aktuell.
    Repository 'openSUSE BuildService - Wine CVS-Pakete' ist aktuell.
    Metadaten von Repository 'openSUSE BuildService - GNOME:Community'
    werden abgeruMetadaten von Repository 'openSUSE BuildService -
    GNOME:Community' werden abgeruMetadaten von Repository 'openSUSE
    BuildService - GNOME:Community' werden abgeruMetadaten von Repository
    'openSUSE BuildService - GNOME:Community' werden abgeruMetadaten von
    Repository 'openSUSE BuildService - GNOME:Community' werden abgerufen
    [fertig]
    Zwischenspeicher fr Repository 'openSUSE BuildService -
    GNOME:Community' wird eZwischenspeicher fr Repository 'openSUSE
    BuildService - GNOME:Community' wird eZwischenspeicher fr Repository
    'openSUSE BuildService - GNOME:Community' wird eZwischenspeicher fr
    Repository 'openSUSE BuildService - GNOME:Community' wird
    eZwischenspeicher fr Repository 'openSUSE BuildService -
    GNOME:Community' wird erzeugt [fertig]
    Repository 'openSUSE BuildService - GNOME:STABLE' ist aktuell.
    Repository 'openSUSE BuildService - KDE:Backports' ist aktuell.
    Repository 'openSUSE BuildService - KDE:Community' ist aktuell.
    Repository 'openSUSE BuildService - KDE4:Factoryesktop' ist aktuell.
    Repository 'openSUSE BuildService - Mono:Community' ist aktuell.
    Repository 'openSUSE BuildService - OpenOffice.org' ist aktuell.
    Repository 'openSUSE BuildService - Virtualisierung (QEMU)' ist
    aktuell.
    Repository 'openSUSE BuildService - Virtualisierung (VirtualBox)' ist
    aktuell.
    Repository 'openSUSE BuildService - X11GL' ist aktuell.
    Repository 'openSUSE BuildService - XFCE' ist aktuell.
    Repository 'openSUSE BuildService - Treiber fr Web-Cams' ist aktuell.
    Repository
    'http://download.opensuse.org/repositories/home:/jsmeix/openSUSE_11.0'
    ist aktuell.
    Repository
    'http://download.opensuse.org/repositories/home:/pikerhog:/utils/openSUSE_11.0'
    ist aktuell.
    Repository 'openSUSE BuildService - Mozilla' ist aktuell.
    Repository 'openSUSE BuildService - Datenbank' ist aktuell.
    Repository 'openSUSE BuildService - Mail Server' ist aktuell.
    Repository 'openSUSE BuildService - PHP' ist aktuell.
    Repository 'Hauptaktualisierungs-Repository' ist aktuell.
    Repository 'VideoLan Repository' ist aktuell.
    Repository 'Packman Repository' ist aktuell.
    Repository 'http://packman.iu-bremen.de/suse/11.0' ist aktuell.
    Repository 'openSUSE Education' ist aktuell.
    Repository 'ATI Repository' ist aktuell.
    Repository 'openSUSE-11.0-Updates' ist aktuell.
    Alle Repositories wurden aktualisiert.
    linux-sne5:~ # zypper in -f yast2*
    Daten des Repositorys laden...
    Installierte Pakete lesen...
    'yast2*' nicht gefunden
    Paketabhngigkeiten auflsen...
    Keine auszufhrenden Aktionen.
    linux-sne5:~ #

    theo


    --
    topitz
    ------------------------------------------------------------------------
    topitz's Profile: http://forums.opensuse.org/member.php?userid=5467
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  6. #16
    caf4926 NNTP User

    Default Re: yast2 shot dead


    an option is to install smart
    and then use that to force a repair of yast packages

    zypper in smart
    zypper in smart-gui

    start from the menu and let it add the oss, update, non-oss, repo's

    then use it to force a re-install of all yast packages


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.82) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.82 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  7. #17
    didencool NNTP User

    Default Re: yast2 shot dead


    caf4926;1905454 Wrote:
    > well Yast is installed but maybe it needs re-installing, but can't
    > understand that last error, were you su?
    >
    > anyway
    >
    > try this
    >
    > Ctrl-Alt-F1 (or reboot and start in level 3 and login as user, then go
    > su)
    >
    > go su and type
    >
    > yast2
    >
    > does this start yast


    I am sorry but did you mean yast not yast2? AFAIK yast2 is gui but if
    you run in runlevel3 you have no X started...
    PS: when I have such issue i have reinstalled system. But this is
    interesting howto try to fix this.


    --
    Linux 2.6.25.16-0.1-pae openSUSE 11 i386
    #1KM400|Athlon|RAM2GB|FX5200
    #2 nforce2|Athlon|Radeon9200|RAM1GB
    #3 laptop ASUS x51r|Xpress1100|512MB
    ------------------------------------------------------------------------
    didencool's Profile: http://forums.opensuse.org/member.php?userid=4743
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  8. #18
    caf4926 NNTP User

    Default Re: yast2 shot dead


    didencool;1905705 Wrote:
    > I am sorry but did you mean yast not yast2? AFAIK yast2 is gui but if
    > you run in runlevel3 you have no X started...
    > PS: when I have such issue i have reinstalled system. But this is
    > interesting howto try to fix this.


    No, I did mean yast2.
    The OP tried running out of the x server and it still failed.

    I suggest smart at this point for ease of use for the OP. I install it
    by default, always have since 10.0 - but actually now, with zypper I
    never need it, but I like to play safe.
    The other option is to use the install DVD but users seem to run in to
    all kind of problems that way, but it can be done.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.82) "3.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.82 "release 3.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  9. #19
    catelee2u NNTP User

    Default Re: yast2 shot dead


    I have the same problem. yast2 will not start. It prompts me for
    privileged password but then nothing happens.
    I have tried re-installing yast2.
    I DID notice that yast2 works correctly under KDE4 with no problems at
    all. It refuses to work in Gnome which is what I usually use. I recently
    upgraded to 11.1 openSUSE (from 10.3) which is when this started. I
    tried reinstalling everything with gnome and everything with yast in the
    name but nothing has worked so far.


    --
    catelee2u
    ------------------------------------------------------------------------
    catelee2u's Profile: http://forums.opensuse.org/member.php?userid=21811
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


  10. #20
    Jonathan R NNTP User

    Default Re: yast2 shot dead


    What is the error you get when running YaST from the command line?

    Have you checked your ncurses and qt dependencies?


    --
    My web site 'The Complete Computer Resource'
    (http://thecompletecomputerresource.com/) and 'Smart Package Manager
    Forums' (http://smart.thecompletecomputerresource.com/index.php)
    ------------------------------------------------------------------------
    Jonathan_R's Profile: http://forums.opensuse.org/member.php?userid=170
    View this thread: http://forums.opensuse.org/showthread.php?t=401260


Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •