Results 1 to 5 of 5

Thread: Problem with Virtualbox on openSUSE 11 x86_64

  1. #1
    Dixie17 NNTP User

    Default Problem with Virtualbox on openSUSE 11 x86_64


    I am fairly new to openSUSE and I wanted to set up a virtual machine to
    run Windows XP. As I had used VirtualBox on Windows and was familiar
    with it, I decided to give it a try.

    I am running openSUSE 11 x86_64 KDE 4, so I downloaded the appropriate
    rpm (VirtualBox-2.0.6_39765_openSUSE11-1.x86_64.rpm) from the VirtualBox
    website and installed it with no problem.

    I started it up and created a virtual machine and again had no
    problems. Then when I went to run the virtual machine I got the two
    following error messages:

    [image: http://www.dixie17.me.uk/os-images/vb-error-1.png]

    [image: http://www.dixie17.me.uk/os-images/vb-error-2.png]

    I then did as suggested and tried to re-setup the kernel by executing
    the command displayed in the above error message and got the following
    results:

    [image: http://www.dixie17.me.uk/os-images/vb-error-3.png]

    So I then went and viewed the log as instructed which contained the
    following:

    /usr/share/virtualbox/src/build_in_tmp: line 99: make: command not
    found

    I have no idea what this means and have searched for a while to find an
    answer but I am completely stuck. I appreciate any help that can be
    given.

    Many Thanks


    --
    Dixie17
    ------------------------------------------------------------------------
    Dixie17's Profile: http://forums.opensuse.org/member.php?userid=15452
    View this thread: http://forums.opensuse.org/showthread.php?t=401228


  2. #2
    caf4926 NNTP User

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64


    check the steps here:
    'VirtualBox Installation - openSUSE'
    (http://en.opensuse.org/VirtualBox_Installation)


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401228


  3. #3
    ken yap NNTP User

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64


    When using the PUEL version from the VirtualBox download site, you need
    to compile the vboxdrv module. This requires extra packages to be
    installed, and these are:

    make, gcc, kernel-source, pam-devel

    I think that's the list. Anyway if something is missing the log file
    will tell you what else is needed. The kernel-source package must match
    in version with the running kernel. So you should have the updates
    repository enabled and install using YaST.

    I believe there's a howto on the OpenSUSE wiki about this.


    --
    ken_yap
    ------------------------------------------------------------------------
    ken_yap's Profile: http://forums.opensuse.org/member.php?userid=221
    View this thread: http://forums.opensuse.org/showthread.php?t=401228


  4. #4
    Dixie17 NNTP User

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64


    Thanks for the help, that resolved the problem.

    However I cannot set my resolution on the guest machine higher than
    1024x768. My resolution on the host is 1400x900 as I have a widescreen
    monitor. I have installed the guest additions, but I only have two
    options 800x600 and 1024x768. Does any know if it is possible to have a
    resolution of 1400x900 on a Windows XP guest machine.


    --
    Dixie17
    ------------------------------------------------------------------------
    Dixie17's Profile: http://forums.opensuse.org/member.php?userid=15452
    View this thread: http://forums.opensuse.org/showthread.php?t=401228


  5. #5
    caf4926 NNTP User

    Default Re: Problem with Virtualbox on openSUSE 11 x86_64


    Yes to 1400x900 it works fine.
    Here is a screen of mine
    'Imagep guest in VBox Seamless Mode.jpeg - openSUSE'
    (http://en.opensuse.org/Image:Xp_gues...less_Mode.jpeg)

    I have trouble getting it to work sometimes in Linux guests.

    What happens when you select seemless?

    Try the tabs across the top of the main GUI, the first one I think,
    there are screen options, choose 'adjust window size' - now hit the
    maximize button top right of the GUI. It gives me XP over the whole
    window.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401228


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •