Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: "Available" Update Never Installs

  1. #1
    freefiber NNTP User

    Default "Available" Update Never Installs


    openSUSE 11.0 Updater keeps telling me that the following patch is
    available:

    java-1_4_2-sun: 2008 Brazil DST start date change, SLE 10, Sun Java

    However, when I select 'install', the updater immediately goes to
    "checking for updates". It never installs anything.

    Even worse, when there are multiple patches available, they won't
    install unless I deselect that java patch.

    I'm far from an expert on the admin tools, so forgive my ignorance, but
    how can I find out why this patch is being presented, and why the
    install is failing?

    Thanks -- Allen


    --
    freefiber
    ------------------------------------------------------------------------
    freefiber's Profile: http://forums.opensuse.org/member.php?userid=16606
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  2. #2
    PurpleMonkey NNTP User

    Default Re: "Available" Update Never Installs


    I've had this problem with a number of updates from time to time. I
    usually find that using zypper to install the updates resolves the
    problem.

    If you wish to try it enter the following in a terminal

    Code:
    --------------------

    sudo zypper up

    --------------------


    Enter your root password and away you go. More on Zypper here:-
    'Zypper Usage' (http://en.opensuse.org/Zypper/Usage)

    N.B: I've also read that sometimes just waiting a few days can sort out
    the problem.


    --
    Linux using monkey
    ------------------------------------------------------------------------
    PurpleMonkey's Profile: http://forums.opensuse.org/member.php?userid=304
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  3. #3
    Thomas7343 NNTP User

    Default Re: "Available" Update Never Installs


    Hello Freefiber;

    Using 10.3 and was chasing something like this around like a mouse in a
    maze.

    The last thing was a reboot that solved it. No mention was ever
    present that explained the need to reboot so kept right on chasing.

    Good luck
    tom


    --
    SuSe 10.3/Dual Boot-XP Laptop
    ------------------------------------------------------------------------
    Thomas7343's Profile: http://forums.opensuse.org/member.php?userid=16094
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  4. #4
    jraglin NNTP User

    Default Re: "Available" Update Never Installs


    PurpleMonkey,

    I want to thank you for your sound advise on this topic, As I had a few
    Kernel Updates that would not install as well.

    I forgot out the zypper command. I ran it and it fixed my kernel
    problem


    --
    jraglin
    ------------------------------------------------------------------------
    jraglin's Profile: http://forums.opensuse.org/member.php?userid=16634
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  5. #5
    freefiber NNTP User

    Default Re: "Available" Update Never Installs


    To my surprise, the problem has disappeared without a reboot or other
    action on my part (except posting this question). Regardless, I
    appreciate your help in case this problem recurs.


    --
    freefiber
    ------------------------------------------------------------------------
    freefiber's Profile: http://forums.opensuse.org/member.php?userid=16606
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  6. #6
    amarjan NNTP User

    Default Re: "Available" Update Never Installs


    I have the exact same problem as freefiber, except that the
    -java-1_4_2-sun- package was never installed.

    So why is the updater flagging this as a required update? There's a bug
    somewhere.

    Also it keeps insisting that I need to patch
    -kdenetwork3-InstantMessenger- even though it's uninstalled.

    This has been going on for a while now -- a few weeks I think.

    Is there a way to make the packager manager regain sanity, so to speak?


    --
    amarjan
    ------------------------------------------------------------------------
    amarjan's Profile: http://forums.opensuse.org/member.php?userid=11727
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  7. #7
    mtgucs NNTP User

    Default Re: "Available" Update Never Installs


    I have the same Brazil update problem as freefiber and amarjam, with the
    following modifications:

    (1) The Brazil update is the only one failing. My other updates
    succeed even with Brazil selected. Sometimes I have to wait for the
    repositories to update, but that self-resolves over time with only the
    Brazil DST update remaining as the annoyance.

    (2) I ran zypper up with the following results:

    linux-xion:/home/mtgucs # zypper up
    Reading installed packages...

    Problem: patch:java-1_4_2-sun-299.noarch conflicts with
    java-1_5_0-sun-plugin.i586 < 1.5.0_update16-1.3 provided by
    java-1_5_0-sun-plugin-1.5.0_update16-1.1.i586

    Solution 1: do not keep java-1_5_0-sun-plugin-1.5.0_update16-1.1.i586
    installed
    Solution 2: do not install patch:java-1_4_2-sun-299.noarch

    Choose from above solutions by number or cancel [1/2/C]: 2
    Resolving dependencies...
    Nothing to do.

    (3) Whaddya mean, nothing to do?

    (4) I probably, but can't be sure, tried to install java-1_4_2 in
    order to get Java on my browsers (still not working btw, different
    complaint - different thread). So somewhere in the technosludge of my
    hard drive is a reference to java-1_4 that openSUSE update is seeing,
    but which no longer exists.

    (5) Here is my update-alternatives output:

    linux-xion:/home/mtgucs # update-alternatives --config java

    There are 3 programs which provide `java'.

    Selection Command
    -----------------------------------------------
    * 1 /usr/lib64/jvm/jre-1.6.0-sun/bin/java
    2 /usr/lib/jvm/jre-1.5.0-sun/bin/java
    + 3 /usr/lib64/jvm/jre-1.6.0-openjdk/bin/java

    Enter to keep the default , or type selection number:*
    linux-xion:/home/mtgucs #

    (6) Suggestions? Purge Java completely, and will that get rid of the
    lingering reference to Java-1_4? Edit the package manager reference to
    Java-1_4? Cancel my ticket to Rio?

    mtgucs


    --
    mtgucs
    ------------------------------------------------------------------------
    mtgucs's Profile: http://forums.opensuse.org/member.php?userid=17136
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  8. #8
    tsu2 NNTP User

    Default Re: "Available" Update Never Installs


    First in reply to the OP,

    I've found that when the YOU (Yast Online Update) stalls, I can resolve
    by opening up Yast, then running the Update manually selecting maybe a
    dozen or so updates at a time. I suspect that contention is related to
    the number of updates downloaded or installed at once and maybe could be
    resolved by either throttling or better thread control.

    As for the Java issue, I do recommend uninstalling any version of Java
    you don't need (In my experience if installed from the SuSE repos Java
    packages uninstall completely and properly). I can't imagine patching a
    version of Java that's not currently used can be good, and I doubt that
    ordinarily there should be any good reason to be running Java 1.4 any
    more.

    In fact, I wonder about your Java 1.4. Since it doesn't show up in your
    update-alternatives I suspect you may not have installed it from the
    SuSE repos. When using update-alternatives it only works with Java
    installed in the bin directory, when you install Java from the Sun
    website, it installs in a different directory and is manually installed
    (BTW - Uninstalling can require manually removing those manual
    configurations wherever they are... eg Profile).


    --
    tsu2
    ------------------------------------------------------------------------
    tsu2's Profile: http://forums.opensuse.org/member.php?userid=2578
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  9. #9
    Prexy NNTP User

    Default Re: "Available" Update Never Installs


    The never updating update for me is fileshareset.

    I'm hoping I can make it go away tomorrow by installing 11.1


    --
    If your gecko is broken, you have a reptile dysfunction.
    ------------------------------------------------------------------------
    Prexy's Profile: http://forums.opensuse.org/member.php?userid=233
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


  10. #10
    swamp yankee NNTP User

    Default Re: "Available" Update Never Installs


    Online update keeps notifying me that there are two updates available:
    fileshareset
    kdenetwork3-InstantMessenger

    Neither application is installed, according to YAST.

    The updates will not install. Rather the update notifier simply opens a
    new notice that the same two updates are available.

    I've tried rebooting, logging out/in, &
    as su:
    rpmdb --rebuilddb
    zypper refresh
    zypper up

    the last command only shows:

    Reading installed packages...

    The following NEW patches are going to be installed:
    fileshareset kdenetwork3-InstantMessenger


    No additional space will be used or freed after the operation.
    Continue? [YES/no]:

    No matter what I enter ("YES" "yes" "y" "Y"), I am simply dumped back
    to the command line. Reissuing "zypper up" shows the same update needs
    to be installed.

    Has anyone had any luck with this?


    --
    swamp_yankee
    ------------------------------------------------------------------------
    swamp_yankee's Profile: http://forums.opensuse.org/member.php?userid=9321
    View this thread: http://forums.opensuse.org/showthread.php?t=401191


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •