Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Unable to turn on desktop effects in KDE 4.1.3

  1. #1
    6tr6tr NNTP User

    Default Unable to turn on desktop effects in KDE 4.1.3


    I just installed KDE 4.1.3 and went to "Configure Desktop" and tried to
    turn on desktop effects but I got the error:

    > Failed to activate desktop effects using the given configuration
    > options. Settings will be reverted to their previous values.
    >
    > Check your X configuration. You may also consider changing advanced
    > options, especially changing the compositing type.


    How do I fix this? Where do I change the configuration setting that is
    not allowing this?


    --
    6tr6tr
    ------------------------------------------------------------------------
    6tr6tr's Profile: http://forums.opensuse.org/member.php?userid=12994
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  2. #2
    caf4926 NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    In a terminal type

    glxgears

    what happens


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  3. #3
    6tr6tr NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    I see a window with three gears turning (very slowly) and it prints:

    >
    > 339 frames in 5.2 seconds = 64.703 FPS
    >



    --
    6tr6tr
    ------------------------------------------------------------------------
    6tr6tr's Profile: http://forums.opensuse.org/member.php?userid=12994
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  4. #4
    Wrath5000 NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    A couple of questions: What video card do you have, and have you
    properly installed the drivers? Did you have the effects working
    properly in a previous KDE 4.x desktop?


    --
    If I lose the light of the sun, I will write by candlelight, moonlight,
    no light. If I lose paper and ink, I will write in blood on forgotten
    walls. I will write always. I will capture nights all over the world and
    bring them to you. --Henry Rollins
    ------------------------------------------------------------------------
    Wrath5000's Profile: http://forums.opensuse.org/member.php?userid=324
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  5. #5
    caf4926 NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    You could try either

    1. Create a completely new user and see what happens

    or

    2. Try a re-name of the hidden .kde4 folder (.kde4old) and re-login
    (Ctrl-Alt-Backspace)

    see what happens

    you will have lost all your settings, it will be like a totally new
    kde4 session.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  6. #6
    6tr6tr NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    Wrath5000;1903638 Wrote:
    > A couple of questions: What video card do you have, and have you
    > properly installed the drivers? Did you have the effects working
    > properly in a previous KDE 4.x desktop?


    Video Card: ATI Technologies Inc. Mach64 GR
    Driver: ati

    I've never tried effects before, so unfortunately, i'm not sure if it
    worked before.


    --
    6tr6tr
    ------------------------------------------------------------------------
    6tr6tr's Profile: http://forums.opensuse.org/member.php?userid=12994
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  7. #7
    caf4926 NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    You could post the content of

    /etc/X11/xorg.conf


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  8. #8
    6tr6tr NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    caf4926;1903656 Wrote:
    > You could post the content of
    >
    > /etc/X11/xorg.conf


    I removed the fonts to make it shorter.

    >
    > Section "Files"
    > ...all fonts were here...
    > InputDevices "/dev/gpmdata"
    > InputDevices "/dev/input/mice"
    > EndSection
    >
    > Section "ServerFlags"
    > Option "AllowMouseOpenFail" "on"
    > Option "ZapWarning" "on"
    > EndSection
    >
    > Section "Module"
    > Load "glx"
    > Load "type1"
    > Load "extmod"
    > Load "dbe"
    > Load "freetype"
    > EndSection
    >
    > Section "InputDevice"
    > Driver "kbd"
    > Identifier "Keyboard[0]"
    > Option "Protocol" "Standard"
    > Option "XkbLayout" "us"
    > Option "XkbModel" "microsoftpro"
    > Option "XkbRules" "xfree86"
    > EndSection
    >
    >
    > Section "InputDevice"
    > Driver "mouse"
    > Identifier "Mouse[1]"
    > Option "Buttons" "9"
    > Option "Device" "/dev/input/mice"
    > Option "Name" "ImExPS/2 Generic Explorer Mouse"
    > Option "Protocol" "explorerps/2"
    > Option "Vendor" "Sysp"
    > Option "ZAxisMapping" "4 5"
    > EndSection
    >
    >
    > Section "Monitor"
    > DisplaySize 304 228
    > HorizSync 30-60
    > Identifier "Monitor[0]"
    > ModelName "HP HP F50"
    > Option "DPMS"
    > Option "PreferredMode" "1024x768"
    > VendorName "HWP"
    > VertRefresh 43-75
    > UseModes "Modes[0]"
    > EndSection
    >
    >
    > Section "Modes"
    > Identifier "Modes[0]"
    > EndSection
    >
    >
    > Section "Screen"
    > DefaultDepth 24
    > SubSection "Display"
    > Depth 15
    > Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    > EndSubSection
    > SubSection "Display"
    > Depth 16
    > Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    > EndSubSection
    > SubSection "Display"
    > Depth 24
    > Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    > EndSubSection
    > SubSection "Display"
    > Depth 8
    > Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
    > EndSubSection
    > Device "Device[0]"
    > Identifier "Screen[0]"
    > Monitor "Monitor[0]"
    > EndSection
    >
    >
    > Section "Device"
    > BoardName "Mach64 GR"
    > BusID "0:14:0"
    > Driver "ati"
    > Identifier "Device[0]"
    > Option "XaaNoPixmapCache" "on"
    > Screen 0
    > VendorName "ATI"
    > EndSection
    >
    >
    >
    > Section "ServerLayout"
    > Identifier "Layout[all]"
    > InputDevice "Keyboard[0]" "CoreKeyboard"
    > InputDevice "Mouse[1]" "CorePointer"
    > Option "Clone" "off"
    > Option "Xinerama" "off"
    > Screen "Screen[0]"
    > EndSection
    >
    >
    > Section "DRI"
    > Group "video"
    > Mode 0660
    > EndSection
    >
    > Section "Extensions"
    > EndSection
    >



    --
    6tr6tr
    ------------------------------------------------------------------------
    6tr6tr's Profile: http://forums.opensuse.org/member.php?userid=12994
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  9. #9
    deano ferrari NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    Add this to 'Extensions' section:

    > Section "Extensions"
    > Option "Composite" "on"
    > EndSection



    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


  10. #10
    6tr6tr NNTP User

    Default Re: Unable to turn on desktop effects in KDE 4.1.3


    deano_ferrari;1903674 Wrote:
    > Add this to 'Extensions' section:


    I get the same error.

    (This was after making the change and then logging out and logging back
    in)


    --
    6tr6tr
    ------------------------------------------------------------------------
    6tr6tr's Profile: http://forums.opensuse.org/member.php?userid=12994
    View this thread: http://forums.opensuse.org/showthread.php?t=401036


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •