Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?

Hybrid View

  1. #1
    ClaireM NNTP User

    Default How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    I have been using OpenSUSE 11.0 x86_64 with KDE4 since I installed it on
    this new Thinkpad in August, and have been delighted: KDE4.0 is young
    but promising, and very stable.

    Unfortunately I decided to try out the new Amarok 1.9, using one-click
    install, and it didn't run; I then discovered that I had lost my
    suspend-to-disk and suspend-to-RAM options, and the system tray in
    plasma had also gone blank.

    When I did
    Code:
    --------------------
    rpm -qa --last | less
    --------------------
    I discovered that Amarok had dragged in with it several chunks of KDE
    4.1.3, so I reinstalled a previous version of Amarok.

    That dragged in a few older versions of various libraries and brought
    back my suspend-to-RAM/disk options, but in some ways created an even
    worse mess, with no sound and various error messages about io_slaves
    being unavailable, and no Yast.

    My system is still usable, but I really miss the sound, so what I would
    like to do is to revert to KDE 4.0.4 ... but I can't figure out how to
    do that. Zypper and yast2 both appear to be working fine, so can anyone
    help me to use them to undo this?

    Here's some data on my setup:

    First, the packages which got modified or added when I upgraded Amarok,
    but weren't removed with it


    Code:
    --------------------
    kdebase4-libkonq-4.1.3-55.5 Fri 28 Nov 2008 16:01:33 GMT
    kdelibs4-4.1.3-63.3 Fri 28 Nov 2008 16:01:30 GMT
    kdelibs4-core-4.1.3-63.3 Fri 28 Nov 2008 16:01:13 GMT
    libkcddb4-4.1.3-35.4 Fri 28 Nov 2008 16:01:11 GMT
    libkonq5-4.1.3-55.5 Fri 28 Nov 2008 16:01:08 GMT
    libkcompactdisc4-4.1.3-35.4 Fri 28 Nov 2008 16:01:06 GMT
    phonon-4.2.1-54.1 Fri 28 Nov 2008 16:01:05 GMT
    libkipi5-4.1.3-54.4 Fri 28 Nov 2008 16:01:01 GMT
    libplasma1-4.0.4-24.113 Fri 28 Nov 2008 16:00:59 GMT
    libkde4-4.1.3-63.3 Fri 28 Nov 2008 16:00:56 GMT
    phonon-backend-gstreamer-0_10-4.2.1-54.1 Fri 28 Nov 2008 16:00:47 GMT
    libphonon4-4.2.1-54.1 Fri 28 Nov 2008 16:00:46 GMT
    libQtWebKit4-4.4.3-25.1 Fri 28 Nov 2008 16:00:45 GMT
    libqt4-x11-4.4.3-23.1 Fri 28 Nov 2008 16:00:37 GMT
    libqt4-qt3support-4.4.3-23.1 Fri 28 Nov 2008 16:00:25 GMT
    libqt4-sql-mysql-4.4.3-25.1 Fri 28 Nov 2008 16:00:22 GMT
    soprano-2.1.1-31.9 Fri 28 Nov 2008 16:00:21 GMT
    soprano-backend-redland-2.1.1-31.9 Fri 28 Nov 2008 16:00:20 GMT
    kdegames4-carddecks-other-4.1.3-26.3 Fri 28 Nov 2008 16:00:18 GMT
    libqt4-sql-4.4.3-23.1 Fri 28 Nov 2008 16:00:10 GMT
    kdebase4-workspace-ksysguardd-4.1.3-148.3 Fri 28 Nov 2008 16:00:09 GMT
    libkdecore4-4.1.3-63.3 Fri 28 Nov 2008 16:00:07 GMT
    libsoprano4-2.1.1-31.9 Fri 28 Nov 2008 16:00:05 GMT
    libakonadiprotocolinternals1-1.0.0-39.12 Fri 28 Nov 2008 16:00:04 GMT
    libstrigi0-0.5.11-54.5 Fri 28 Nov 2008 16:00:03 GMT
    libotr2-3.1.0-1.1 Fri 28 Nov 2008 16:00:01 GMT
    libspectre1-0.2.0-2.1 Fri 28 Nov 2008 16:00:00 GMT
    kdegames4-carddecks-default-4.1.3-26.3 Fri 28 Nov 2008 15:59:56 GMT
    oxygen-icon-theme-4.1.3-70.1 Fri 28 Nov 2008 15:59:46 GMT
    kde4-filesystem-4.1.3-26.1 Fri 28 Nov 2008 15:59:24 GMT
    kde4-kdm-branding-upstream-4.1.3-148.3 Fri 28 Nov 2008 15:59:19 GMT
    libmtp8-0.3.4-2.1 Fri 28 Nov 2008 15:59:17 GMT
    libqt4-4.4.3-23.1 Fri 28 Nov 2008 15:59:16 GMT
    kdebase4-workspace-branding-upstream-4.1.3-148.3 Fri 28 Nov 2008 15:59:11 GMT
    ktorrent-lang-3.1.5-14.12 Fri 28 Nov 2008 15:59:09 GMT
    libmysqlclient_r15-5.0.51a-27.1 Fri 28 Nov 2008 15:59:07 GMT
    libsensors4-3.0.2-4.1 Fri 28 Nov 2008 15:59:05 GMT
    loudmouth-1.2.3-16.1 Fri 28 Nov 2008 15:59:03 GMT
    gpg-pubkey-2e1efa87-4796560b Fri 28 Nov 2008 15:58:56 GMT

    --------------------


    Next, my repositories, which are a bit of a mess:


    Code:
    --------------------
    zypper lr -u
    # | Alias | Name | Enabled | Refresh | URI
    ---+------------------------------------------------------------------------+------------------------------------------------------------------------+---------+---------+-------------------------------------------------------------------------------------------
    1 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes | http://download.opensuse.org/update/11.0/
    2 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - Mozilla | Yes | Yes | http://download.opensuse.org/reposit...openSUSE_11.0/
    3 | 20081128-155835 | 20081128-155835 | Yes | Yes | http://download.opensuse.org/reposit...openSUSE_11.0/
    4 | repo-non-oss | openSUSE-11.0-Non-Oss | No | No | http://download.opensuse.org/distrib.../repo/non-oss/
    5 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No | cd:///?devices=/dev/sr0
    6 | repo-debug | openSUSE-11.0-Debug | No | No | http://download.opensuse.org/distrib....0/repo/debug/
    7 | KDE:KDE4:Factoryesktop | KDE:KDE4:Factoryesktop | Yes | Yes | http://download.opensuse.org/reposit...openSUSE_11.0/
    8 | http://ftp.skynet.be/pub/packman/suse/11.0/_1 | Packman Repository | Yes | Yes | http://ftp.skynet.be/pub/packman/suse/11.0/
    9 | openSUSE:11.0 | openSUSE:11.0 | Yes | Yes | http://download.opensuse.org/distrib...11.0/repo/oss/
    10 | http://download.opensuse.org/reposit.../openSUSE_11.0 | http://download.opensuse.org/reposit.../openSUSE_11.0 | No | Yes | http://download.opensuse.org/reposit.../openSUSE_11.0

    --------------------


    I'd be really grateful for any help on how to get out of this mess
    without having to reinstall the system. Thanks!


    --
    ClaireM
    ------------------------------------------------------------------------
    ClaireM's Profile: http://forums.opensuse.org/member.php?userid=8152
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  2. #2
    caf4926 NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    This needs disabling -BUT
    7 | KDE:KDE4:Factory Desktop
    | KDE:KDE4:Factory Desktop

    However. I think you would be better sticking with kde4.1.3

    Your suspend problem is more likely down to a kernel update. Roll the
    kernel back one in Software Management.
    I had to with my ThinPad
    And I'm using kde4.2 beta and it's great - Previously I was 4.1.3 and
    it was way better than 4.0.4

    These are the repo's for 4.1.3

    KDE4 Factory:

    Desktop:
    'Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0'
    (http://tinyurl.com/5mxwaf)

    Extra:
    'Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.0'
    (http://tinyurl.com/5t7aof)

    Community:
    'Index of
    /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop'
    (http://tinyurl.com/65tbsr)

    You already have the Desktop one
    =======================================================

    You should add them and then do update all Unconditionally in Software
    management. See this video: 'Yast - Software Management -Update
    All_HowTo - openSUSE Forums' (http://tinyurl.com/6l798k)

    You should use Amarok from Packman!!
    Do an update all in Packman too.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  3. #3
    ClaireM NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    caf4926;1903178 Wrote:
    > This needs disabling -BUT
    > 7 | KDE:KDE4:Factory Desktop
    > | KDE:KDE4:Factory Desktop
    >
    > However. I think you would be better sticking with kde4.1.3
    >


    Thanks caf4926, for all that detailed help, but I really would prefer
    just to stick with KDE 4.0.4

    I'm sure you are right that KDE4.1.3 is good stuff, but I like a simple
    life and would prefer not to live on the bleeding edge of the factory --
    I'm happy to wait for it until OpenSuse 11.1 is released and everything
    is there in a stable format.

    Can anyone help me to go back to 4.0.4?


    --
    ClaireM
    ------------------------------------------------------------------------
    ClaireM's Profile: http://forums.opensuse.org/member.php?userid=8152
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  4. #4
    caf4926 NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    Remove that repo Factory desktop repo I mentioned earlier

    You will need to add these:

    'Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0'
    (http://tinyurl.com/3ttxs3)

    'Index of /repositories/KDE:/KDE4:/STABLE:/Extra-Apps'
    (http://tinyurl.com/6jk9sl)

    'Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0'
    (http://tinyurl.com/6ckdup)

    Check out the howto video of doing update all unconditionally.
    mentioned earlier..

    You will probably have to remove some packages by dependency. If the
    errors are just too confusing post here, use the expert button to save
    the error to file.

    But try unchecking the dependency check box and doing the update all
    uncond' in each of the kde4 repo's and maybe some red packages in OSS
    repo - then check dependencies.

    see how you get on.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  5. #5
    ClaireM NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    caf4926;1903300 Wrote:
    > Remove that repo Factory desktop repo I mentioned earlier
    >
    > You will need to add these:
    >
    > 'Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0'
    > (http://tinyurl.com/3ttxs3)
    >
    > 'Index of /repositories/KDE:/KDE4:/STABLE:/Extra-Apps'
    > (http://tinyurl.com/6jk9sl)
    >
    > 'Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0'
    > (http://tinyurl.com/6ckdup)
    >
    > Check out the howto video of doing update all unconditionally.
    > mentioned earlier..
    >


    Thanks again for your help; I have done all that. No dependency errors
    left, and to make sure I went to safe mode and moved .kde4 to .kde4-old
    before rebooting

    But still no sound, no system tray, and when I start KDE I get the
    following error msg in a box labelled "Plasma workspace": "Could not
    start process Unable to create io-slave: klauncher said: Error loading
    'kio_trash'." When I try to start Yast from the kickoff menu, KDEsudo
    refuses to recognise my password, so I can only launch Yast from a
    terminal window.

    I have no idea what else to try, so I'm inclined to think that this
    would be a good point to do what I have thinking of for a while:
    reinstall, using the 32-bit version to avoid all the hassles with the
    32-bit non-OSS software.

    I had been hoping to wait a little longer before doing that, until the
    launch of 11.1, but I don't want to wait another 2 weeks with no sound
    (I rely on Skype for my phone calls), and bugzilla still lists rather a
    lot of hasslesome bugs in 11.1RC1, so I guess it's a case of going back
    to 11.0


    --
    ClaireM
    ------------------------------------------------------------------------
    ClaireM's Profile: http://forums.opensuse.org/member.php?userid=8152
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  6. #6
    caf4926 NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    Try re-naming the .kde4 folder in your hidden user
    section/home/user*/.kde4

    call it .kde4old

    login using icewm from the login

    from a terminal or the CLI do this

    mv /home/uernme/.kde4 .kde4old

    or manually do it from a file browser

    login again to a kde4 session


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  7. #7
    ClaireM NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    caf4926;1903465 Wrote:
    > Try re-naming the .kde4 folder in your hidden user
    > section/home/user*/.kde4


    I tried that before, but I'll give it another go.

    Thanks again.


    --
    ClaireM
    ------------------------------------------------------------------------
    ClaireM's Profile: http://forums.opensuse.org/member.php?userid=8152
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  8. #8
    ClaireM NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    ClaireM;1903480 Wrote:
    > I tried that before, but I'll give it another go.


    Done it again, but things are no better.

    Since I seem to have exhausted nearly every other possibility except
    reinstallation, I'm going to try your first suggestion, of going to
    KDE4.13


    --
    ClaireM
    ------------------------------------------------------------------------
    ClaireM's Profile: http://forums.opensuse.org/member.php?userid=8152
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  9. #9
    caf4926 NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    try from a su terminal

    rpmdb --rebuilddb

    then

    zypper dup


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.81) "1.1" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.81 "release 1.1" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


  10. #10
    Prexy NNTP User

    Default Re: How can I restore KDE 4.0.4 after adding some KDE 4.13 bits?


    I may never get this stuff right . I had a problem updating an old,
    low-spec machine. I ended up using a mini-iso (something I had never
    done before) that was for 11.2 Alpha0 - YIKES!

    Anyway, this is pretty much only a test machine, so I decided to keep
    the Alpha0 and move up to kde 4.2 for a look. I installed the UNSTABLE
    repos, but updates brought me a bunch of kde 4.13 stuff. I want to get
    rid of 4.13 but I want to go forward, not back

    BTW, I would never go back to 4.04 because it was a real pain compared
    to 4.13.


    --
    If your gecko is broken, you have a reptile dysfunction.
    ------------------------------------------------------------------------
    Prexy's Profile: http://forums.opensuse.org/member.php?userid=233
    View this thread: http://forums.opensuse.org/showthread.php?t=400970


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •