I had this problem with vim in OpenSuse:
when in "Insert" mode the backspace insert "^?", and I want to it to
remove characters to the left

Solved such way:

I made file "~/.vimrc" in my user directory.
The file ".vimrc" contain:

" copy from here start of .vimrc
" comment: <press CTRL+V><press backspace> mean you must to press these
keys in that order

set t_kb=<press CTRL+V><press backspace>
fixdel

" to have mouse enabled in normal mode
set mouse=n

" copy to here end of .vimrc


--
gvitalie
------------------------------------------------------------------------
gvitalie's Profile: http://forums.opensuse.org/member.php?userid=16355
View this thread: http://forums.opensuse.org/showthread.php?t=400922