Results 1 to 4 of 4

Thread: Zypper problem:says to update packages that are up-to-date

  1. #1
    cybertaz NNTP User

    Default Zypper problem:says to update packages that are up-to-date


    My updater applet in the tray tells me two updates are available. I go
    to update and nothing happens, it just refreshes and says there are two
    updates.

    I have run into this before with 10.2 and 10.3 so I deleted the local
    cache and forced a refresh. Still had the same thing.

    I ran "zypper up" from CLI and got this:

    Code:
    --------------------
    2 Problems:
    Problem: patch:kdenetwork3-InstantMessenger-235.noarch conflicts with kdenetwork3-InstantMessenger.x86_64 < 3.5.9-39.2 provided by kde4-kopete-4.1.3-43.5.x86_64
    Problem: patch:fileshareset-124.noarch conflicts with kdebase3-session.x86_64 < 3.5.9-65.2provided by kdebase4-session-4.1.3-23.2.x86_64

    Problem: patch:kdenetwork3-InstantMessenger-235.noarch conflicts with kdenetwork3-InstantMessenger.x86_64 < 3.5.9-39.2 provided by kde4-kopete-4.1.3-43.5.x86_64
    Solution 1: deinstallation of kde4-kopete-4.1.3-43.4.x86_64
    Solution 2: do not install patch:kdenetwork3-InstantMessenger-235.noarch

    Problem: patch:fileshareset-124.noarch conflicts with kdebase3-session.x86_64 < 3.5.9-65.2 provided by kdebase4-session-4.1.3-23.2.x86_64
    --------------------


    It then wants me to uninstall KDE4.1.3 and then install the updates.
    How do I fix this? has anyone else seen this?

    running opensuse 11 with KDE 4.1.3 "Release 63.3"


    --
    '' (http://userbars.org)AMD64-X2 4200+, NVIDIA 8500GTx2 (twinview mode),
    2 GB Ram
    ------------------------------------------------------------------------
    cybertaz's Profile: http://forums.opensuse.org/member.php?userid=123
    View this thread: http://forums.opensuse.org/showthread.php?t=400682


  2. #2
    deano ferrari NNTP User

    Default Re: Zypper problem:says to update packages that are up-to-date


    I think this is a recent known problem. For now use the yast software
    manager to update.

    http://tinyurl.com/62vts7


    --
    deano_ferrari
    ------------------------------------------------------------------------
    deano_ferrari's Profile: http://forums.opensuse.org/member.php?userid=122
    View this thread: http://forums.opensuse.org/showthread.php?t=400682


  3. #3
    cybertaz NNTP User

    Default Re: Zypper problem:says to update packages that are up-to-date


    Thanks, I must have just missed that when searching. Exactly what I'm
    having problems with.


    --
    '' (http://userbars.org)AMD64-X2 4200+, NVIDIA 8500GTx2 (twinview mode),
    2 GB Ram
    ------------------------------------------------------------------------
    cybertaz's Profile: http://forums.opensuse.org/member.php?userid=123
    View this thread: http://forums.opensuse.org/showthread.php?t=400682


  4. #4
    caf4926 NNTP User

    Default Re: Zypper problem:says to update packages that are up-to-date


    The suse updater reports those updates/patches. Just ignore them.
    Personally I don't use the updater anyway. I switch it off.

    If you use *software management* you can apply updates in there as
    deano said. And it is not affected by the bug.
    A fix may be on the way.


    --
    Box: Linux 2.6.25.18-0.2 x86_64 | OS 11.0 | (KDE4.1.3) "63.3" | M2N4-SLI
    | AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
    Lap: OS 11.0 | Celeron 550 | (KDE 4.1.80 "release 7.3" | Intel 965 GM |
    Lenovo R61e | 1GB RAM
    ------------------------------------------------------------------------
    caf4926's Profile: http://forums.opensuse.org/member.php?userid=204
    View this thread: http://forums.opensuse.org/showthread.php?t=400682


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •