Results 1 to 2 of 2

Thread: Devilspie Error On Workspace

Hybrid View

  1. #1
    MrStatic NNTP User

    Default Devilspie Error On Workspace


    So I installed devilspie to launch a few windows into workspace 4.
    I am running Gnome and have this in a file

    Code:
    --------------------
    (if
    (is (application_name) "xterm")
    (begin
    (set_workspace 4)
    (maximize)
    )
    )

    --------------------

    Now when I launch xterm it maximizes but doesn't goto another
    workspace. So I launched in debug mode and it shows this.

    > joe@lappy:~/.devilspie> devilspie -d ~/.devilspie/xterm.ds
    > Devil's Pie 0.18 starting...
    > Loading /home/joe/.devilspie/xterm.ds
    >
    > ** (devilspie:8621): WARNING **: Workspace number 4 does not exist
    >
    > (devilspie:8621): Wnck-CRITICAL **: wnck_window_move_to_workspace:
    > assertion `WNCK_IS_WORKSPACE (space)' failed
    > Changing workspace to 4
    > Maximising
    >


    Any ideas?


    --
    MrStatic
    ------------------------------------------------------------------------
    MrStatic's Profile: http://forums.opensuse.org/member.php?userid=16004
    View this thread: http://forums.opensuse.org/showthread.php?t=400423


  2. #2
    MrStatic NNTP User

    Default Re: Devilspie Error On Workspace


    Wont let me edit it but I fixed it for anyone else, I changed workspace
    to viewport now to figure out how to work the geometry portion


    --
    MrStatic
    ------------------------------------------------------------------------
    MrStatic's Profile: http://forums.opensuse.org/member.php?userid=16004
    View this thread: http://forums.opensuse.org/showthread.php?t=400423


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •