Results 1 to 4 of 4

Thread: problems with umlauts in emacs and latex

  1. #1
    vok33 NNTP User

    Default problems with umlauts in emacs and latex


    Hi,

    I used to type umlauts and other keys (,,.,,, etc) directly from
    the keybord into emacs, and latex never complained about these letter,
    as long as I used \usepackage{isolatin1}.

    Today, I discovered that this does not work anymore, neither on my
    laptop, nor on my workstation.

    I absolutely have no clue where to look for the parameter that might
    have changed. Perhaps someone has an idea?

    thanks a lot in advance!!!

    Volker


    --
    vok33
    ------------------------------------------------------------------------
    vok33's Profile: http://forums.opensuse.org/member.php?userid=14408
    View this thread: http://forums.opensuse.org/showthread.php?t=400358


  2. #2
    roidemai NNTP User

    Default Re: problems with umlauts in emacs and latex


    Hi Volker.

    Check this out:
    'Linux.com :: Everything Linux and Open Source'
    (http://tinyurl.com/6cza58)

    I just a similar problem not too long ago.
    It's suggested that one of these might do the trick:

    Code:
    --------------------
    export LC_CTYPE=iso_8859_1
    export LC_CTYPE=iso-8859-1
    --------------------

    (if that resolves it, I think you put this in .bashrc, maybe someone
    else can confirm, or they'll spell it out in one of those links)

    Otherwise, I had luck finding if there were any problems with my locale
    settings--you'll receive errors if there are faulty settings-- with the
    following command:


    Code:
    --------------------
    perl -e ""
    --------------------


    Here's another site that looks useful (and mentions emacs specifically)
    'The Linux keyboard and console HOWTO: How to make other programs work
    with non-ASCII chars'
    (http://tldp.org/HOWTO/Keyboard-and-C...-HOWTO-12.html)

    I just googled "emacs accents" and "emacs non-ASCII characters"


    --
    SuSE-11.0, Thinkpad T61, Intel Core 2 Duo T7250, 1024MB DDR2, Intel
    GM965/GL960
    ------------------------------------------------------------------------
    roidemai's Profile: http://forums.opensuse.org/member.php?userid=2236
    View this thread: http://forums.opensuse.org/showthread.php?t=400358


  3. #3
    john hudson NNTP User

    Default Re: problems with umlauts in emacs and latex


    According to CTAN isolatin1 has been obsolete since 2006; so you need to
    change your package.Have you tried latin1?


    --
    john_hudson
    ------------------------------------------------------------------------
    john_hudson's Profile: http://forums.opensuse.org/member.php?userid=1134
    View this thread: http://forums.opensuse.org/showthread.php?t=400358


  4. #4
    roidemai NNTP User

    Default Re: problems with umlauts in emacs and latex


    I made a mistake, Volker. I misread your post thinking you couldn't
    produce the accents any longer. Not sure if any of that will prove
    helpful now.


    --
    SuSE-11.0, Thinkpad T61, Intel Core 2 Duo T7250, 1024MB DDR2, Intel
    GM965/GL960
    ------------------------------------------------------------------------
    roidemai's Profile: http://forums.opensuse.org/member.php?userid=2236
    View this thread: http://forums.opensuse.org/showthread.php?t=400358


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •