Results 1 to 4 of 4

Thread: Installing Software: upgrades not showing up [O]

  1. #1
    sekinto NNTP User

    Default Installing Software: upgrades not showing up [O]


    When I go to Install Software in the Computer menu (openSUSE 11 [Gnome])
    nothing appears under the Upgrades tab. However, if I go to the
    Installed tab and search for some software that I know can be upgraded
    (ex. OpenOffice.org), it shows that it can be upgraded. So why isn't
    software that can be upgraded appearing under the Upgrades tab? I have
    the OpenOffice.org repository's priority set to 40 and the main
    repository's priorities set to 30. Somebody on the IRC channel told me
    that repositories with a higher priority are looked at first, is this
    true?


    --
    sekinto
    ------------------------------------------------------------------------
    sekinto's Profile: http://forums.opensuse.org/member.php?userid=3933
    View this thread: http://forums.opensuse.org/showthread.php?t=400270


  2. #2
    Malcolm NNTP User

    Default Re: Installing Software: upgrades not showing up [O]

    Quote Originally Posted by sekinto
    When I go to Install Software in the Computer menu (openSUSE 11 [Gnome])
    nothing appears under the Upgrades tab. However, if I go to the
    Installed tab and search for some software that I know can be upgraded
    (ex. OpenOffice.org), it shows that it can be upgraded. So why isn't
    software that can be upgraded appearing under the Upgrades tab? I have
    the OpenOffice.org repository's priority set to 40 and the main
    repository's priorities set to 30. Somebody on the IRC channel told me
    that repositories with a higher priority are looked at first, is this
    true?
    Hi
    Try it from the CLI then (gnome-terminal/konsole);
    Code:
    sudo zypper ref
    sudo zypper lu
    sudo zypper up
    The first command refreshes the repositories, the second lists any
    updates, the third will apply the updates.

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.2-default
    up 0:12, 1 user, load average: 0.33, 0.35, 0.34
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82


  3. #3
    sekinto NNTP User

    Default Installing Software: upgrades not showing up [O]


    I guess I should have mentioned in the original post that I already
    tried that...


    # zypper ref

    Code:
    --------------------
    Repository 'Main Update Repository' is up to date.
    Repository 'NVIDIA Repository' is up to date.
    Repository 'Main Repository (NON-OSS)' is up to date.
    Repository 'openSUSE BuildService - OpenOffice.org' is up to date.
    Repository 'Main Repository (OSS)' is up to date.
    Repository 'VideoLan Repository' is up to date.
    Repository 'openSUSE BuildService - GNOME:STABLE' is up to date.
    Repository 'openSUSE BuildService - Mozilla' is up to date.
    Repository 'openSUSE BuildService - Virtualization (VirtualBox)' is up to date.
    Repository 'openSUSE BuildService - Wine CVS Builds' is up to date.
    Repository 'Packman Repository' is up to date.
    Repository 'openSUSE BuildService - PHP' is up to date.
    All repositories have been refreshed.
    --------------------


    # zypper lu

    Code:
    --------------------
    Reading installed packages...
    Patches

    No updates found.
    --------------------


    # zypper up

    Code:
    --------------------
    Reading installed packages...
    Nothing to do.
    --------------------


    # zypper lr

    Code:
    --------------------
    # | Alias | Name | Enabled | Refresh
    ---+-------------------------------------------------------------------------------------+-----------------------------------------------------+---------+--------
    1 | http://download.opensuse.org/update/11.0/ | Main Update Repository | Yes | Yes
    2 | http://download.nvidia.com/opensuse/11.0 | NVIDIA Repository | Yes | Yes
    3 | http://download.opensuse.org/distrib.../repo/non-oss/ | Main Repository (NON-OSS) | Yes | Yes
    4 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - OpenOffice.org | Yes | Yes
    5 | http://download.opensuse.org/distrib...11.0/repo/oss/ | Main Repository (OSS) | Yes | Yes
    6 | http://download.videolan.org/pub/vid...vlc/SuSE/11.0/ | VideoLan Repository | Yes | Yes
    7 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - GNOME:STABLE | Yes | Yes
    8 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - Mozilla | Yes | Yes
    9 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes
    10 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - Wine CVS Builds | Yes | Yes
    11 | http://ftp.skynet.be/pub/packman/suse/11.0/ | Packman Repository | Yes | Yes
    12 | http://download.opensuse.org/reposit...openSUSE_11.0/ | openSUSE BuildService - PHP | Yes | Yes
    --------------------


    --
    sekinto
    ------------------------------------------------------------------------
    sekinto's Profile: http://forums.opensuse.org/member.php?userid=3933
    View this thread: http://forums.opensuse.org/showthread.php?t=400270


  4. #4
    sekinto NNTP User

    Default Installing Software: upgrades not showing up [O]


    Thanks for the help guys. I figured out the problem.
    The guy on the IRC channel told me wrong, lower # = higher priority,
    not the other way around.


    --
    sekinto
    ------------------------------------------------------------------------
    sekinto's Profile: http://forums.opensuse.org/member.php?userid=3933
    View this thread: http://forums.opensuse.org/showthread.php?t=400270


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •