Results 1 to 4 of 4

Thread: System Event Notifications reset audio volume to 100%

  1. #1

    Question System Event Notifications reset audio volume to 100%

    Ever since I added MP3 support and used Amarok to see if it was just Clementine that could not play MP3s, Event Notifications (such as software update notifications) reset my audio volume to 100% every time. And every time, I just about jump out of my own skin.

    Then, after I set it back to my preference, the audio level seems much less than it should be. Other apps do not do that.

    I blame Amarok for messing up my audio settings, because adjusting the volume in Amarok caused my system audio volume to also change seemingly erratically (and because I cannot stand Amarok due to it's UI and how it seems to want to mess with things). But, it may just be coincidental with me adding MP3 support following the instructions at: http://opensuse-guide.org/codecs.php

    I did not install the k3b-codecs due to version inconsistencies between the openSUSE and Packman repos for k3b, and "libdvdcss2" is not available. And, I still do not understand why the instructions say to uninstall phonon-backend-gstreamer and phonon4qt5-backend-gstreamer, but I did as instructed.

    In YaST Control Center -> Hardware -> Sound, it said that my "SBx00 Azalia (Intel HDA)" was not configured. So, I configured it with Quick Automatic Setup. After I had done that, sound quit working. So, I deleted that configuration and got sound back.

    Alsamixer gives me a choice of two sound cards "default" and "HDA ATI SB". When set to "default", there is only one channel, "Master", at 63%. When set to "HDA ATI SB", there are many more channels with PCM, Front, Surround, Center, and LFE (whatever that is) all set to 100%, and Master at 56%.

    In System Settings -> Multimedia -> Audio and Video, the Device Preference for Audio Playback is "Built-in Audio Analog Stereo". If I highlight that and click "Test", the audio volume is again reset to 100%. And, subsequent clicks on "Test" give an error, "Failed to set the selected audio output device".

    In the Backend tab, there is only one backend listed, Phonon VLC.

    Do I perhaps need another backend installed? Or is there something else I can do to fix what I choose to blame on Amarok ()?


    Lee

  2. #2

    Default Re: System Event Notifications reset audio volume to 100%

    Quote Originally Posted by tleedavidson View Post
    In the Backend tab, there is only one backend listed, Phonon VLC.

    Do I perhaps need another backend installed?
    Yes. Install phonon4qt5-backend-gstreamer and remove phonon4qt5-backend-vlc.

    This is caused by a limitation in vlc 2.2.

    https://bugs.kde.org/show_bug.cgi?id=345651
    Or is there something else I can do to fix what I choose to blame on Amarok ()?
    It is not Amarok's fault, and unrelated to Amarok actually.

    With PulseAudio's default setting, *every* application can (and will) raise the master volume and therefore affect other applications as well.
    Set "flat-volumes = no" in /etc/pulse/daemon.conf to prevent that.

    You can also change the volume of notifications. While a notification is played, a volume slider should appear in the "Volume Control Settings", in kmis and in pavucontrol. If you change that slider, that volume should also be used for notfications afterwards.
    But note that the specific "Event Sounds" volume control is not used for notifications by phonon-backend-vlc, because vlc does not support that.

    The "Test" button does use 100% volume as well, that's unrelated. And it seems to be on purpose, originally at least.
    https://bugs.kde.org/show_bug.cgi?id=346614
    And it will also raise the master volume to 100% because of PulseAudio's flat-volumes (mis)feature.
    Last edited by wolfi323; 22-Mar-2016 at 07:13. Reason: added bug reference

  3. #3

    Default Re: System Event Notifications reset audio volume to 100%

    Okay, installed phonon4qt5-backend-gstreamer, removed phonon4qt5-backend-vlc, and set "flat-volumes = no" in /etc/pulse/daemon.conf.

    All issues resolved; even with the "Test" button. And no more auto-reflex to exit my own skin on Event Notifications

    Thank you very much!


    P.S. Do we mark threads as [RESOLVED] by editing the title of the original post? I don't see that convention in use here but thought I'd ask just to be sure.

  4. #4

    Default Re: System Event Notifications reset audio volume to 100%

    Quote Originally Posted by tleedavidson View Post
    Okay, installed phonon4qt5-backend-gstreamer, removed phonon4qt5-backend-vlc, and set "flat-volumes = no" in /etc/pulse/daemon.conf.
    With "flat-volumes = no", even the vlc backend should be bearable.
    But gstreamer has more features anyway, e.g. the analyzer in Amarok only works with this one.

    Btw, Amarok is a KDE4 application and uses phonon-backend-xxx, phonon4qt5-backend-xxx.

    P.S. Do we mark threads as [RESOLVED] by editing the title of the original post? I don't see that convention in use here but thought I'd ask just to be sure.
    You can if you want to, but it's not mandatory.

    And you can't edit the title of the original post (after 10 minutes), you have to do that in a new post/reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •