Page 1 of 8 123 ... LastLast
Results 1 to 10 of 74

Thread: Slow boot: 33s waiting for wicked interfaces to start

  1. #1

    Question Slow boot: 33s waiting for wicked interfaces to start

    A few days ago I ran a system update through 'zypper up' and I noticed that systemd and wicked were updated.

    Since then every time my system boots slowly because of this:

    Code:
    A start job is running for wicked managed network interfaces (33s / no limit)[  OK  ]
    I haven't changed any network settings whatsoever.

    Before the update my system used to boot in about 15 seconds and I never had to wait for anything like that. Now the boot is x3 slower which is quite annoying as I am using a dual boot.

    What might be the problem/solution?

  2. #2

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    I've had the exact same problem since the last updates. Boot time has increased by a consistent 24-25 seconds:

    Code:
    /var/log/boot.log
    A start job is running for wicked managed network interfaces (13s / no limit)
      ...
    A start job is running for wicked managed network interfaces (37s / no limit)
    I've disabled all of the following with no effect:

    Code:
    systemctl disable NetworkManager-dispatcher.service
    systemctl disable YaST2-Second-Stage.service
    systemctl disable wickedd-dhcp6.service
    systemctl disable iscsi.service
    systemctl disable iscsid.socket
    systemctl disable avahi-daemon.service
    systemctl disable avahi-daemon.socket
    I also put the following in /etc/wicked/nanny-local.xml but it didn't help:
    Code:
    <config>
    
      <!-- nanny>
        <disable class="modem"/>
        <disable link-layer="wireless" />
      </nanny -->
    </config>

  3. #3

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    So it's not only me.

    Hopefully someone can help. I don't know if this is a bug to be reported.

  4. #4

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    I have also noted slowing boot times with 42.1.

    The top-10 from

    Code:
    systemd-analyze blame
    are

    Code:
    38.843s ModemManager.service
    38.671s avahi-daemon.service
    38.597s SuSEfirewall2_init.service
    18.163s wicked.service
    8.242s hddtemp.service
    3.232s systemd-tmpfiles-setup.service
    3.076s dev-sda2.device
    2.012s plymouth-read-write.service
    1.860s vboxdrv.service
    1.523s home.mount
    I don't know what "ModemManager.service" is or why I need it. I don't have any mobile phone or modem connected to my computer.

    For comparison sake, I am running a desktop with an i7-4790K CPU and HDD storage.

  5. #5

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    With all the services listed in my first post disabled (don't want or need for my desktop), wicked sticks out like a sore thumb in my top 4:

    Code:
    systemd-analyze blame
    
             30.105s wicked.service
              3.310s dev-sda8.device
              1.057s systemd-tmpfiles-setup-dev.service
              1.026s systemd-journald.service

  6. #6

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    Quote Originally Posted by dhnels View Post
    With all the services listed in my first post disabled (don't want or need for my desktop), wicked sticks out like a sore thumb in my top 4:

    Code:
    systemd-analyze blame
    
             30.105s wicked.service
              3.310s dev-sda8.device
              1.057s systemd-tmpfiles-setup-dev.service
              1.026s systemd-journald.service
    Hi,

    Mine too is extremely slow. I noticed this since updating to Leap 42.1 but I see there is another troublesome one in my list:

    Code:
            31.290s ntpd.service
             29.955s wicked.service
              4.068s mysql.service
              3.607s dev-sda2.device
              2.321s apache2.service
              2.042s fglrxrebuild.service
               789ms apparmor.service
    While we figure out why wicked is so slow... Is ntpd really needed? Can I simply uninstall it or disable it somehow?

    Thanks!
    - Itai
    http://www.cybernium.net

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,580

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    ntpd is what connects to the time server it is probably waiting on wicked to connect. Perhaps try NetworkManager

  8. #8

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    Quote Originally Posted by gogalthorp View Post
    ntpd is what connects to the time server it is probably waiting on wicked to connect. Perhaps try NetworkManager
    I understand the logic of this but the stronger logic is: it has always worked with wicked so far without any problem. So it makes no sense for one to reconfigure the system and switch software just because of an update.

    BTW I have reported this to bugzilla:

    https://bugzilla.suse.com/show_bug.cgi?id=972471

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,580

    Default Re: Slow boot: 33s waiting for wicked interfaces to start

    Wicked has never worked here I use NM. If you set NM to allow all users it is loaded at boot also

  10. #10

    Question Re: Slow boot: 33s waiting for wicked interfaces to start

    Quote Originally Posted by gogalthorp View Post
    ntpd is what connects to the time server it is probably waiting on wicked to connect. Perhaps try NetworkManager
    Hi,

    What is the difference between those two? Intuitively it sounds like Network Manager is much broader.
    Does it replace just wicked? Or other services too? Would NTPD will be needed?

    Thanks!
    - Itai
    http://www.cybernium.net

Page 1 of 8 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •