Firefox v44.0.2 will not start today. It worked fine yesterday. (I am using Opera at the moment.)

One thing I looked at yesterday was adding firefox to AppArmor. I could not figure out how it worked and thought that I had canceled my efforts; perhaps not.

$ firefox &
[1] 7112
jmoe:/home/jmoe> /usr/bin/firefox: line 52: /usr/bin/basename: Permission denied
/usr/bin/firefox: line 73: /usr/bin/file: Permission denied
/usr/bin/firefox: line 75: /usr/bin/grep: Permission denied
/usr/bin/firefox: line 139: /usr/lib64/firefox/firefox: Permission denied
/usr/bin/firefox: line 139: /usr/lib64/firefox/firefox: Success
[1]+  Exit 126                firefox
What permission is needed?
Line 52 is:
cmdname=`basename $0`
The other "Permission denied" lines are similar.

There is no problem using these utilities from the command line. For instance:
$  /usr/bin/basename /usr/bin/firefox

$ ll /usr/bin/firefox*
lrwxrwxrwx 1 root root 27 Feb 19 04:35 /usr/bin/firefox -> ../lib64/firefox/*
$ ll /usr/lib64/firefox/
-rwxr-xr-x 1 root root 4.2K Feb 16 11:35 /usr/lib64/firefox/*
I can start firefox directly:

$ /usr/lib64/firefox/firefox &
[1] 7769
(firefox:7769): Gtk-WARNING **: Theme directory  of theme oxygen has no size field
AlarmService: init()
AlarmService: _restoreAlarmsFromDb()
AlarmService: add(Wed Mar 16 2016 12:19:50 GMT-0700 (MST))
AlarmService: Callback after getting alarms from database: []
AlarmService: Current alarm: null
AlarmService: Alarm queue: []
AlarmService: Callback after adding alarm in database.
AlarmService: Current alarm: {"date":"2016-03-16T19:19:50.605Z","ignoreTimezone":true,"timezoneOffset":420,"id":1619}
AlarmService: Alarm queue: []