Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Configure desktop ISO date YYYY-MM-DD no longer available?

  1. #11
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    The problem is not with the Digital Clock plasmoid, that (at least now) has the ability to display the date in ISO 8601 format.

    What is wanted is the ability to set the Date/Time to use ISO 8601 format everywhere else, independently of the locale setting.

    For example, I want to use en_GB formats generally, but ISO 8601 as the date/time format.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #12

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Quote Originally Posted by hcvv View Post
    And worse using ../../.. which can be a real mystery.

    In fact the world learned nothing from the Y2K problem.
    That's true. And it's even worse in the US. Here we buy soda by the liter and milk by the gallon. I'm like, cut it out, pick a date a year from now and say everything is going to be metric.

  3. #13
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Quote Originally Posted by LouBryan View Post
    ... and milk by the gallon.
    ... and of course, if I bought a gallon of milk here in the UK... I'd have a different quantity to you

    We've been "going metric" since the early 70's and still haven't fully made it.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  4. #14
    Join Date
    Jan 2012
    Location
    Russia :: Moscow
    Posts
    47

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Perhaps the solution would be to create custom locales, like en_SE, finely tuned to personal tastes. However I did not find an easy way for this, as /usr/lib/locale only contains binary (compiled) files.

    PS. By the way, is anybody able to configure the Digital clock widget to display seconds as well? All other options (Show date, Use 24-hour clock, Show local time zone) seem to work, but no seconds shown regardless of "Show seconds" and "Date format" preferences.

  5. #15
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Quote Originally Posted by SamsonovAnton View Post
    Perhaps the solution would be to create custom locales, like en_SE, finely tuned to personal tastes. However I did not find an easy way for this, as /usr/lib/locale only contains binary (compiled) files.
    Yes, I think that had been put forward as a possible interim solution over on the bug report.

    PS. By the way, is anybody able to configure the Digital clock widget to display seconds as well? All other options (Show date, Use 24-hour clock, Show local time zone) seem to work, but no seconds shown regardless of "Show seconds" and "Date format" preferences.
    Displays seconds OK using KF 5.19.0 and Plasma 5.5.5

    http://paste.opensuse.org/view/raw/f2815017
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  6. #16
    Join Date
    Jan 2012
    Location
    Russia :: Moscow
    Posts
    47

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Quote Originally Posted by tannington View Post
    Quote Originally Posted by SamsonovAnton View Post
    Is anybody able to configure the Digital clock widget to display seconds as well?
    Displays seconds OK using KF 5.19.0 and Plasma 5.5.5
    Looks like it depends on locale settings: with "No change" or "Default (C)" (either inherited from global locale setting or overridden specifically for time formatting), no seconds are ever displayed, regardless of user preference; when any other locale is chosen, seconds are displayed as expected. What a nonsense!

  7. #17

    Angry Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Looks like the digital clock implemented their own thing to customize the format... KDE though is still dragging their feet. This is ridiculous.

  8. #18

    Default Re: Configure desktop ISO date YYYY-MM-DD no longer available?

    Quote Originally Posted by SamsonovAnton View Post
    Looks like it depends on locale settings: with "No change" or "Default (C)" (either inherited from global locale setting or overridden specifically for time formatting), no seconds are ever displayed, regardless of user preference; when any other locale is chosen, seconds are displayed as expected. What a nonsense!
    This bug was introduced when the 12/24 hrs option was added.

    I fixed it nearly a month ago, it should work in Plasma 5.6.4 now (or in openSUSE since 5.6.3 already):
    https://quickgit.kde.org/?p=plasma-w...0fc22e4cd7cc43

    Not sure if we will do an update for Leap 42.1 (probably not for this alone, there hasn't even been a bug report, neither in openSUSE's nor KDE's bugzilla...), but you can apply the patch yourself. The corresponding file (/usr//share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/DigitalClock.qml) is just a text file.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •