Results 1 to 7 of 7

Thread: All my dependencies are screwed up

  1. #1

    Default All my dependencies are screwed up

    I am running Leap 42.1. Somehow I got all my dependencies all screwed up. When I run zypper patch, I get hundreds of unmet dependencies, and zypper want to uninstall just about everything to meet them. How can I recover from this? Lots of things seem to want perl 20, which is not available.
    Code:
     # zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    13 Problems:
    Problem: gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
    Problem: nothing provides libexiv2.so.13()(64bit) needed by kfilemetadata-4.14.3-4.4.x86_64
    Problem: nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    Problem: nothing provides perl = 5.20.1 needed by subversion-perl-1.8.11-2.11.1.x86_64
    Problem: nothing provides perl(:MODULE_COMPAT_5.20.1) needed by perl-YAML-LibYAML-0.59-2.4.1.x86_64
    Problem: nothing provides perl(:MODULE_COMPAT_5.20.1) needed by perl-IO-Socket-SSL-1.997-2.3.1.noarch
    Problem: nothing provides libicuuc.so.53.1()(64bit) needed by libwebkitgtk-3_0-0-2.4.9-10.1.x86_64
    Problem: nothing provides perl(:MODULE_COMPAT_5.20.1) needed by perl-XML-LibXML-2.0121-2.3.1.x86_64
    Problem: nothing provides libicuuc.so.53.1()(64bit) needed by libreoffice-writer-5.0.4.2-28.1.x86_64
    Problem: nothing provides perl = 5.20.1 needed by subversion-perl-1.8.11-2.11.1.x86_64
    Problem: cron-4.2-57.5.x86_64 requires cronie = 1.4.11-57.5, but this requirement cannot be provided
    Problem: nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    Problem: kdevelop4-4.7.1-4.1.x86_64 requires libkasten2controllers.so.2()(64bit), but this requirement cannot be provided
    
    Problem: gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
      uninstallable providers: gpg2-2.0.26-2.3.1.i586[http-download.opensuse.org-a045c629]
                       gpg2-2.0.26-2.3.1.x86_64[http-download.opensuse.org-a045c629]
     Solution 1: Following actions will be done:
      deinstallation of gpg2-lang-2.0.24-5.1.noarch
      deinstallation of gpg2-2.0.24-5.1.x86_64
      deinstallation of yast2-3.1.155-1.1.x86_64
      deinstallation of openSUSE-build-key-1.0-32.2.noarch
      deinstallation of libzypp-15.21.1-3.2.x86_64
      deinstallation of libqca2-2.0.3-18.2.x86_64
      deinstallation of libqca-qt5-2.1.1-1.1.x86_64
      deinstallation of libgpgme11-1.6.0-9.1.x86_64
      deinstallation of duplicity-0.7.05-1.1.x86_64
      deinstallation of yast2-vm-3.1.24-3.2.x86_64
      deinstallation of yast2-users-3.1.40-1.2.x86_64
      deinstallation of yast2-tune-3.1.7-3.2.x86_64
      deinstallation of yast2-sysconfig-3.1.3-5.2.noarch
      deinstallation of yast2-sudo-3.1.2-5.2.noarch
      deinstallation of yast2-storage-3.1.71-2.1.x86_64
      deinstallation of yast2-sound-3.1.7-6.6.x86_64
      deinstallation of yast2-snapper-3.1.9-3.2.x86_64
      deinstallation of yast2-slp-3.1.7-5.3.x86_64
      deinstallation of yast2-services-manager-3.1.40-12.1.noarch
      deinstallation of yast2-security-3.1.12-1.6.noarch
      deinstallation of yast2-scanner-3.1.2-2.2.x86_64
      deinstallation of yast2-samba-server-3.1.12-10.2.noarch
      deinstallation of yast2-samba-client-3.1.15-10.2.noarch
      deinstallation of yast2-proxy-3.1.6-3.2.noarch
      deinstallation of yast2-printer-3.1.2-1.1.x86_64
      deinstallation of yast2-pam-3.1.1-3.2.noarch
      deinstallation of yast2-packager-3.1.84.1-3.1.x86_64
      deinstallation of yast2-online-update-3.1.11-5.2.noarch
      deinstallation of yast2-ntp-client-3.1.20-1.1.noarch
      deinstallation of yast2-nis-client-3.1.12-5.3.x86_64
      deinstallation of yast2-nfs-server-3.1.8-5.2.noarch
      deinstallation of yast2-nfs-client-3.1.16-5.2.noarch
      deinstallation of yast2-metapackage-handler-3.1.4-6.2.noarch
      deinstallation of yast2-mail-3.1.5-5.6.noarch
      deinstallation of yast2-ldap-3.1.13-5.4.x86_64
      deinstallation of yast2-iscsi-client-3.1.23-3.2.noarch
      deinstallation of yast2-inetd-3.1.11-3.2.noarch
      deinstallation of yast2-fonts-3.1.16-1.1.x86_64
      deinstallation of yast2-firewall-3.1.3-5.2.noarch
      ...
      deinstallation of patterns-openSUSE-imaging_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-non_oss-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-sw_management_gnome-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-sw_management_kde-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_web-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_C_C++-20150918-12.1.x86_64
      deinstallation of gnome-software-lang-3.16.6-4.1.noarch
      deinstallation of libkfbapi-lang-1.0-6.1.x86_64
      deinstallation of nautilus-extension-dropbox-2.10.0-3.2.x86_64
      deinstallation of PackageKit-branding-openSUSE-42.1-1.1.noarch
      deinstallation of PackageKit-lang-1.0.7-3.5.noarch
      deinstallation of skanlite-lang-1.1-3.2.noarch
      deinstallation of skanlite-doc-1.1-3.2.x86_64
      deinstallation of kwebkitpart-lang-1.3.3-4.2.noarch
      deinstallation of kdm-branding-openSUSE-42.1-6.1.noarch
      deinstallation of kdevplatform-lang-1.7.1-1.3.noarch
      deinstallation of k3b-lang-2.0.3-3.2.noarch
      downgrade of kwalletd5-lang-5.19.0-6.2.noarch to kwalletd5-lang-5.16.0-3.1.noarch
      deinstallation of patterns-openSUSE-non_oss_opt-20150918-12.1.x86_64
      architecture change of baloo-core-4.14.3-2.4.x86_64 to baloo-core-4.14.3-4.2.i586
      architecture change of libbalooqueryparser4-4.14.3-2.4.x86_64 to libbalooqueryparser4-4.14.3-4.2.i586
      install libbalooqueryparser4-4.14.3-4.2.i586 despite the inferior architecture
     Solution 2: do not install patch:openSUSE-2015-840-1.noarch
     Solution 3: break gpg2-lang-2.0.26-2.3.1.noarch by ignoring some of its dependencies

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,987
    Blog Entries
    14

    Default Re: All my dependencies are screwed up

    To update your system, please use
    Code:
    sudo zypper up
    instead of ...patch.

    And post output of
    Code:
    zypper lr -d
    Furthermore, I see that you have a lot of non-default patterns installed, that kdm is installed instead of sddm, in short this is not the result of a default install. Please elaborate on what you have done.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: All my dependencies are screwed up

    I have been updating versions since 13.1. I did not pick kdm consciously. This all started after I installed puddletag and easytag to be able to retag my ripped music files.

    Code:
     # zypper lr -d#  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                           | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------------+--------
     1 | http-download.opensuse.org-1d909d93 | multimedia:libs                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_42.1/                |        
     2 | http-download.opensuse.org-50052532 | home:stefjakobs:citadel-testing         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/stefjakobs:/citadel-testing/openSUSE_Factory/ |        
     3 | http-download.opensuse.org-a045c629 | openSUSE:13.2:Update                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                     |        
     4 | http-download.opensuse.org-c57284af | multimedia:apps                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_42.1/                |        
     5 | openSUSE-42.1-0                     | openSUSE-42.1-0                         | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH40F_73763A757573                         |        
     6 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/                           |        
     7 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/                       |        
     8 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                                       |        
     9 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                                  |        
    10 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                             |        
    11 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                                 |        
    12 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/                          |        
    13 | repo-update                         | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                                            |        
    14 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                                        |        
    jarfx:~ #
    Today's conflicts:
    Code:
    # zypper patchLoading repository data...
    Reading installed packages...
    Resolving package dependencies...
    5 Problems:
    Problem: gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
    Problem: nothing provides libexiv2.so.13()(64bit) needed by kfilemetadata-4.14.3-4.4.x86_64
    Problem: nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    Problem: nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    Problem: kdevelop4-4.7.1-4.1.x86_64 requires libkasten2controllers.so.2()(64bit), but this requirement cannot be provided
    
    
    Problem: gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
      uninstallable providers: gpg2-2.0.26-2.3.1.i586[http-download.opensuse.org-a045c629]
                       gpg2-2.0.26-2.3.1.x86_64[http-download.opensuse.org-a045c629]
     Solution 1: Following actions will be done:
      deinstallation of gpg2-lang-2.0.24-5.1.noarch
      deinstallation of gpg2-2.0.24-5.1.x86_64
      deinstallation of yast2-3.1.155-1.1.x86_64
      deinstallation of openSUSE-build-key-1.0-32.2.noarch
      deinstallation of libzypp-15.21.1-3.2.x86_64
      deinstallation of libqca2-2.0.3-18.2.x86_64
      deinstallation of libqca-qt5-2.1.1-1.1.x86_64
      deinstallation of libgpgme11-1.6.0-9.1.x86_64
      deinstallation of duplicity-0.7.05-1.1.x86_64
      deinstallation of yast2-vm-3.1.24-3.2.x86_64
      deinstallation of yast2-users-3.1.40-1.2.x86_64
      deinstallation of yast2-sysconfig-3.1.3-5.2.noarch
      deinstallation of yast2-sudo-3.1.2-5.2.noarch
       
      deinstallation of yast2-services-manager-3.1.40-12.1.noarch
       . . .
      deinstallation of yast2-metapackage-handler-3.1.4-6.2.noarch
       . . .
      deinstallation of nautilus-extension-seahorse-3.11.92-3.1.x86_64
      downgrade of seahorse-3.16.0-2.6.x86_64 to seahorse-3.14.1-4.1.i586
      architecture change of seahorse-3.16.0-2.6.x86_64 to seahorse-3.14.1-4.1.i586
      install seahorse-3.14.1-4.1.i586 despite the inferior architecture
      deinstallation of seahorse-daemon-3.12.2-3.1.x86_64
      deinstallation of python-gpgme-0.1-121.2.x86_64
      downgrade of libkwalletbackend5-5-5.19.0-6.2.x86_64 to libkwalletbackend5-5-5.16.0-3.1.x86_64
      deinstallation of libyui-ncurses-pkg7-2.48.2-1.1.x86_64
      deinstallation of libyui-qt-pkg7-2.45.5-1.2.x86_64
      deinstallation of PackageKit-backend-zypp-1.0.7-3.5.x86_64
      deinstallation of btrfsmaintenance-0.1.1-10.2.noarch
      deinstallation of kvkbd-0.7.2-2.1.4.x86_64
      downgrade of libkde4-4.14.17-7.1.x86_64 to libkde4-4.14.9-27.1.i586
      architecture change of libkde4-4.14.17-7.1.x86_64 to libkde4-4.14.9-27.1.i586
      install libkde4-4.14.9-27.1.i586 despite the inferior architecture
      deinstallation of kdepim4-4.14.10-3.10.x86_64
      deinstallation of kdebase4-runtime-15.12.2-12.2.x86_64
      deinstallation of gpgmepp5-15.12.2-12.1.x86_64
      deinstallation of gpgme-1.6.0-9.1.x86_64
      deinstallation of deja-dup-34.0-2.9.x86_64
      deinstallation of yast2-online-update-frontend-3.1.11-5.2.noarch
      deinstallation of yast2-inetd-doc-3.1.11-3.2.noarch
      deinstallation of yast2-control-center-qt-3.1.5-2.5.x86_64
      deinstallation of yast2-control-center-gnome-3.1.10-4.2.x86_64
      deinstallation of libksuseinstall1-4.14.17-7.1.x86_64
      deinstallation of patterns-openSUSE-apparmor-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-apparmor_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-x11_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-x11-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-lamp_server-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-kde_plasma-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_basis_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_basis-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_admin-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-enhanced_base-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_basis-20150918-12.1.x86_64
      downgrade of zypper-aptitude-1.12.31-3.1.noarch to zypper-aptitude-1.11.50-34.1.noarch
      deinstallation of gnome-software-3.16.6-4.1.x86_64
      deinstallation of patterns-openSUSE-sw_management-20150918-12.1.x86_64
      downgrade of plasma-nm5-lang-5.5.4-6.3.noarch to plasma-nm5-lang-5.4.3-3.2.noarch
      downgrade of plasma-nm5-openconnect-5.5.4-6.3.x86_64 to plasma-nm5-openconnect-5.4.3-3.2.x86_64
      downgrade of plasma-nm5-openvpn-5.5.4-6.3.x86_64 to plasma-nm5-openvpn-5.4.3-3.2.x86_64
      downgrade of plasma-nm5-pptp-5.5.4-6.3.x86_64 to plasma-nm5-pptp-5.4.3-3.2.x86_64
      downgrade of plasma-nm5-vpnc-5.5.4-6.3.x86_64 to plasma-nm5-vpnc-5.4.3-3.2.x86_64
      downgrade of plasma5-session-5.5.4-6.1.noarch to plasma5-session-5.3.2-10.1.noarch
      deinstallation of libkdepim4-4.14.10-3.10.x86_64
      downgrade of libakonadi4-4.14.10-3.7.x86_64 to libakonadi4-4.14.9-24.1.i586
      architecture change of libakonadi4-4.14.10-3.7.x86_64 to libakonadi4-4.14.9-24.1.i586
      deinstallation of korganizer-4.14.10-3.10.x86_64
      deinstallation of kontact-4.14.10-3.10.x86_64
      deinstallation of knotes-4.14.10-3.10.x86_64
      deinstallation of kmail-4.14.10-3.10.x86_64
      downgrade of kdepimlibs4-4.14.10-3.7.x86_64 to kdepimlibs4-4.14.9-24.1.i586
      architecture change of kdepimlibs4-4.14.10-3.7.x86_64 to kdepimlibs4-4.14.9-24.1.i586
      deinstallation of kdepim4-runtime-4.14.10-3.4.x86_64
      deinstallation of kdebase4-workspace-libs-4.11.22-1.7.x86_64
      deinstallation of kaddressbook-4.14.10-3.10.x86_64
      deinstallation of akregator-4.14.10-3.10.x86_64
      deinstallation of akonadi-4.14.10-3.10.x86_64
      install libakonadi4-4.14.9-24.1.i586 despite the inferior architecture
      install kdepimlibs4-4.14.9-24.1.i586 despite the inferior architecture
      deinstallation of dropbox-2.10.0-3.2.x86_64
      deinstallation of libkfbapi1-1.0-6.1.x86_64
      deinstallation of libkgapi2-2-2.2.0-3.1.x86_64
      deinstallation of libkolab0-0.6.0-2.6.x86_64
      downgrade of seahorse-lang-3.16.0-2.6.noarch to seahorse-lang-3.14.1-4.1.noarch
      deinstallation of patterns-openSUSE-gnome_yast-20150918-12.1.x86_64
      deinstallation of PackageKit-1.0.7-3.5.x86_64
      deinstallation of libkdevplatform8-1.7.1-4.1.x86_64
      deinstallation of mozilla-kde4-integration-0.6.4-7.2.x86_64
      deinstallation of skanlite-1.1-3.2.x86_64
      downgrade of libkonq5-15.12.2-13.3.x86_64 to libkonq5-15.04.1-20.6.i586
      architecture change of libkonq5-15.12.2-13.3.x86_64 to libkonq5-15.04.1-20.6.i586
      install libkonq5-15.04.1-20.6.i586 despite the inferior architecture
      downgrade of mobipocket-15.12.2-14.1.x86_64 to mobipocket-14.12.3-16.1.i586
      architecture change of mobipocket-15.12.2-14.1.x86_64 to mobipocket-14.12.3-16.1.i586
      install mobipocket-14.12.3-16.1.i586 despite the inferior architecture
      downgrade of kdelibs4-4.14.17-7.1.x86_64 to kdelibs4-4.14.9-27.1.i586
      architecture change of kdelibs4-4.14.17-7.1.x86_64 to kdelibs4-4.14.9-27.1.i586
      install kdelibs4-4.14.9-27.1.i586 despite the inferior architecture
      deinstallation of libkcddb4-15.12.2-14.1.x86_64
      deinstallation of libkatepartinterfaces4-4.14.3-2.3.x86_64
      deinstallation of libbaloowidgets4-4.14.3-4.2.x86_64
      architecture change of libbaloofiles4-4.14.3-4.2.x86_64 to libbaloofiles4-4.14.3-4.2.i586
      install libbaloofiles4-4.14.3-4.2.i586 despite the inferior architecture
      install baloo-core-4.14.3-4.2.i586 despite the inferior architecture
      deinstallation of kwebkitpart-1.3.3-4.2.x86_64
      deinstallation of konsole4-part-4.14.3-1.2.x86_64
      deinstallation of konqueror-plugins-15.12.2-13.3.x86_64
      deinstallation of konqueror-15.12.2-13.3.x86_64
      deinstallation of kfind-15.12.2-13.3.x86_64
      deinstallation of keditbookmarks-15.12.2-13.3.x86_64
      deinstallation of kdm-4.11.22-1.7.x86_64
      deinstallation of kdialog-15.12.2-13.3.x86_64
      deinstallation of kdevplatform-1.7.1-4.1.x86_64
      deinstallation of kdevelop4-plugin-cppsupport-4.7.1-4.1.x86_64
      deinstallation of kdepasswd-15.12.2-13.3.x86_64
      downgrade of kdelibs4-core-4.14.17-7.1.x86_64 to kdelibs4-core-4.14.9-27.1.i586
      architecture change of kdelibs4-core-4.14.17-7.1.x86_64 to kdelibs4-core-4.14.9-27.1.i586
      install kdelibs4-core-4.14.9-27.1.i586 despite the inferior architecture
      deinstallation of kdebase4-workspace-branding-openSUSE-42.1-1.10.x86_64
      deinstallation of kdebase4-nsplugin-15.12.2-13.3.x86_64
      deinstallation of kdebase4-libkonq-15.12.2-13.3.x86_64
      deinstallation of kde4-kgreeter-plugins-4.11.22-1.7.x86_64
      deinstallation of kate4-parts-4.14.3-2.3.x86_64
      deinstallation of k3b-2.0.3-3.2.x86_64
      deinstallation of digikam-libs-4.14.0-11.1.x86_64
      downgrade of breeze4-style-5.5.4-7.1.x86_64 to breeze4-style-5.3.2-21.1.i586
      architecture change of breeze4-style-5.5.4-7.1.x86_64 to breeze4-style-5.3.2-21.1.i586
      install breeze4-style-5.3.2-21.1.i586 despite the inferior architecture
      architecture change of baloo-kioslaves-4.14.3-4.2.x86_64 to baloo-kioslaves-4.14.3-4.2.i586
      install baloo-kioslaves-4.14.3-4.2.i586 despite the inferior architecture
      deinstallation of kdebase4-runtime-branding-openSUSE-42.1-1.10.x86_64
      downgrade of kwalletd5-5.19.0-6.2.x86_64 to kwalletd5-5.16.0-3.1.x86_64
      deinstallation of deja-dup-lang-34.0-2.9.noarch
      deinstallation of nautilus-deja-dup-34.0-2.9.x86_64
      deinstallation of patterns-openSUSE-gnome_utilities-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_office_opt-20150918-12.1.x86_64
       . . .
      deinstallation of patterns-openSUSE-gnome-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_C_C++-20150918-12.1.x86_64
      deinstallation of gnome-software-lang-3.16.6-4.1.noarch
      deinstallation of libkfbapi-lang-1.0-6.1.x86_64
      deinstallation of nautilus-extension-dropbox-2.10.0-3.2.x86_64
      deinstallation of PackageKit-branding-openSUSE-42.1-1.1.noarch
      deinstallation of PackageKit-lang-1.0.7-3.5.noarch
      deinstallation of skanlite-lang-1.1-3.2.noarch
      deinstallation of skanlite-doc-1.1-3.2.x86_64
      deinstallation of kwebkitpart-lang-1.3.3-4.2.noarch
      deinstallation of kdm-branding-openSUSE-42.1-6.1.noarch
      deinstallation of kdevplatform-lang-1.7.1-4.1.noarch
      deinstallation of k3b-lang-2.0.3-3.2.noarch
      downgrade of kwalletd5-lang-5.19.0-6.2.noarch to kwalletd5-lang-5.16.0-3.1.noarch
      deinstallation of patterns-openSUSE-non_oss_opt-20150918-12.1.x86_64
      architecture change of baloo-core-4.14.3-4.2.x86_64 to baloo-core-4.14.3-4.2.i586
      architecture change of libbalooqueryparser4-4.14.3-4.2.x86_64 to libbalooqueryparser4-4.14.3-4.2.i586
      install libbalooqueryparser4-4.14.3-4.2.i586 despite the inferior architecture
     Solution 2: do not install patch:openSUSE-2015-840-1.noarch
     Solution 3: break gpg2-lang-2.0.26-2.3.1.noarch by ignoring some of its dependencies

  4. #4

    Default Re: All my dependencies are screwed up

    sddm is installed. I ran zypper update, updated everything, and uninstalled kdm. Now I get:
    Code:
    zypper patchLoading repository data...
    Reading installed packages...
    Resolving package dependencies...
    5 Problems:
    Problem: gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
    Problem: nothing provides libexiv2.so.13()(64bit) needed by kfilemetadata-4.14.3-4.4.x86_64
    Problem: nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    Problem: nothing provides libgpg-error.so.0(GPG_ERROR_1.0)(64bit) needed by libksba8-1.3.1-4.1.x86_64
    Problem: kdevelop4-4.7.1-4.1.x86_64 requires libkasten2controllers.so.2()(64bit), but this requirement cannot be provided
    
    
    Problem: gpg2-lang-2.0.26-2.3.1.noarch requires gpg2 = 2.0.26, but this requirement cannot be provided
      uninstallable providers: gpg2-2.0.26-2.3.1.i586[http-download.opensuse.org-a045c629]
                       gpg2-2.0.26-2.3.1.x86_64[http-download.opensuse.org-a045c629]
     Solution 1: Following actions will be done:
      deinstallation of gpg2-lang-2.0.24-5.1.noarch
      deinstallation of gpg2-2.0.24-5.1.x86_64
      deinstallation of yast2-3.1.155-1.1.x86_64
      deinstallation of openSUSE-build-key-1.0-32.2.noarch
      deinstallation of libzypp-15.21.1-3.2.x86_64
      deinstallation of libqca2-2.0.3-18.2.x86_64
      deinstallation of libqca-qt5-2.1.1-1.1.x86_64
      deinstallation of libgpgme11-1.6.0-9.1.x86_64
      deinstallation of duplicity-0.7.05-1.1.x86_64
      deinstallation of yast2-vm-3.1.24-3.2.x86_64
      deinstallation of yast2-users-3.1.40-1.2.x86_64
      deinstallation of yast2-sysconfig-3.1.3-5.2.noarch
      deinstallation of yast2-sudo-3.1.2-5.2.noarch
      deinstallation of yast2-storage-3.1.71-2.1.x86_64
      deinstallation of yast2-sound-3.1.7-6.6.x86_64
      deinstallation of yast2-snapper-3.1.9-3.2.x86_64
      deinstallation of yast2-slp-3.1.7-5.3.x86_64
      deinstallation of yast2-services-manager-3.1.40-12.1.noarch
      deinstallation of yast2-security-3.1.12-1.6.noarch
      deinstallation of yast2-scanner-3.1.2-2.2.x86_64
      deinstallation of yast2-proxy-3.1.6-3.2.noarch
      deinstallation of yast2-printer-3.1.2-1.1.x86_64
      deinstallation of yast2-pam-3.1.1-3.2.noarch
      deinstallation of yast2-packager-3.1.84.1-3.1.x86_64
      deinstallation of yast2-online-update-3.1.11-5.2.noarch
      deinstallation of yast2-ntp-client-3.1.20-1.1.noarch
      deinstallation of yast2-nis-client-3.1.12-5.3.x86_64
      deinstallation of yast2-nfs-server-3.1.8-5.2.noarch
      deinstallation of yast2-nfs-client-3.1.16-5.2.noarch
      deinstallation of yast2-metapackage-handler-3.1.4-6.2.noarch
      deinstallation of yast2-mail-3.1.5-5.6.noarch
      deinstallation of yast2-ldap-3.1.13-5.4.x86_64
      deinstallation of yast2-iscsi-client-3.1.23-3.2.noarch
      deinstallation of yast2-inetd-3.1.11-3.2.noarch
      deinstallation of yast2-fonts-3.1.16-1.1.x86_64
      deinstallation of yast2-firewall-3.1.3-5.2.noarch
      deinstallation of yast2-country-3.1.22.1-1.1.x86_64
      deinstallation of yast2-control-center-3.1.5-2.5.x86_64
      deinstallation of yast2-auth-client-3.3.5-1.1.noarch
      deinstallation of yast2-http-server-3.1.6-5.7.noarch
      deinstallation of yast2-journal-3.1.2-4.2.noarch
      deinstallation of yast2-network-3.1.134-3.1.x86_64
      deinstallation of patterns-openSUSE-base-20150918-12.1.x86_64
      deinstallation of zypper-1.12.31-3.1.x86_64
      deinstallation of libzypp-plugin-appdata-1.0.1-11.2.noarch
      deinstallation of snapper-zypp-plugin-0.2.9.1-3.1.noarch
      deinstallation of yast2-pkg-bindings-3.1.31-1.2.x86_64
      deinstallation of libqoauth1-1.0.1-22.1.x86_64
      deinstallation of libqca-qt5-plugins-2.1.1-1.1.x86_64
      downgrade of plasma-nm5-5.5.4-6.3.x86_64 to plasma-nm5-5.4.3-3.2.x86_64
      downgrade of libkdepimlibs4-4.14.10-3.7.x86_64 to libkdepimlibs4-4.14.9-24.1.i586
      architecture change of libkdepimlibs4-4.14.10-3.7.x86_64 to libkdepimlibs4-4.14.9-24.1.i586
      install libkdepimlibs4-4.14.9-24.1.i586 despite the inferior architecture
      deinstallation of nautilus-extension-seahorse-3.11.92-3.1.x86_64
      downgrade of seahorse-3.16.0-2.6.x86_64 to seahorse-3.14.1-4.1.i586
      architecture change of seahorse-3.16.0-2.6.x86_64 to seahorse-3.14.1-4.1.i586
      install seahorse-3.14.1-4.1.i586 despite the inferior architecture
      deinstallation of seahorse-daemon-3.12.2-3.1.x86_64
      deinstallation of python-gpgme-0.1-121.2.x86_64
      downgrade of libkwalletbackend5-5-5.19.0-6.2.x86_64 to libkwalletbackend5-5-5.16.0-3.1.x86_64
      deinstallation of libyui-ncurses-pkg7-2.48.2-1.1.x86_64
      deinstallation of libyui-qt-pkg7-2.45.5-1.2.x86_64
      deinstallation of PackageKit-backend-zypp-1.0.7-3.5.x86_64
      deinstallation of btrfsmaintenance-0.1.1-10.2.noarch
      deinstallation of kvkbd-0.7.2-2.1.4.x86_64
      downgrade of libkde4-4.14.17-7.1.x86_64 to libkde4-4.14.9-27.1.i586
      architecture change of libkde4-4.14.17-7.1.x86_64 to libkde4-4.14.9-27.1.i586
      install libkde4-4.14.9-27.1.i586 despite the inferior architecture
      deinstallation of kdepim4-4.14.10-3.10.x86_64
      deinstallation of kdebase4-runtime-15.12.2-12.2.x86_64
      deinstallation of gpgmepp5-15.12.2-12.1.x86_64
      deinstallation of gpgme-1.6.0-9.1.x86_64
      deinstallation of deja-dup-34.0-2.9.x86_64
      deinstallation of yast2-online-update-frontend-3.1.11-5.2.noarch
      deinstallation of yast2-inetd-doc-3.1.11-3.2.noarch
      deinstallation of yast2-control-center-qt-3.1.5-2.5.x86_64
      deinstallation of yast2-control-center-gnome-3.1.10-4.2.x86_64
      deinstallation of libksuseinstall1-4.14.17-7.1.x86_64
      deinstallation of patterns-openSUSE-apparmor-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-apparmor_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-x11_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-x11-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-lamp_server-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-kde_plasma-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_basis_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_basis-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_admin-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-enhanced_base-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_basis-20150918-12.1.x86_64
      downgrade of zypper-aptitude-1.12.31-3.1.noarch to zypper-aptitude-1.11.50-34.1.noarch
      deinstallation of gnome-software-3.16.6-4.1.x86_64
      deinstallation of patterns-openSUSE-sw_management-20150918-12.1.x86_64
      downgrade of plasma-nm5-lang-5.5.4-6.3.noarch to plasma-nm5-lang-5.4.3-3.2.noarch
      downgrade of plasma-nm5-openconnect-5.5.4-6.3.x86_64 to plasma-nm5-openconnect-5.4.3-3.2.x86_64
      downgrade of plasma-nm5-openvpn-5.5.4-6.3.x86_64 to plasma-nm5-openvpn-5.4.3-3.2.x86_64
      downgrade of plasma-nm5-pptp-5.5.4-6.3.x86_64 to plasma-nm5-pptp-5.4.3-3.2.x86_64
      downgrade of plasma-nm5-vpnc-5.5.4-6.3.x86_64 to plasma-nm5-vpnc-5.4.3-3.2.x86_64
      downgrade of plasma5-session-5.5.4-6.1.noarch to plasma5-session-5.3.2-10.1.noarch
      deinstallation of libkdepim4-4.14.10-3.10.x86_64
      downgrade of libakonadi4-4.14.10-3.7.x86_64 to libakonadi4-4.14.9-24.1.i586
      architecture change of libakonadi4-4.14.10-3.7.x86_64 to libakonadi4-4.14.9-24.1.i586
      deinstallation of korganizer-4.14.10-3.10.x86_64
      deinstallation of kontact-4.14.10-3.10.x86_64
      deinstallation of knotes-4.14.10-3.10.x86_64
      deinstallation of kmail-4.14.10-3.10.x86_64
      downgrade of kdepimlibs4-4.14.10-3.7.x86_64 to kdepimlibs4-4.14.9-24.1.i586
      architecture change of kdepimlibs4-4.14.10-3.7.x86_64 to kdepimlibs4-4.14.9-24.1.i586
      deinstallation of kdepim4-runtime-4.14.10-3.4.x86_64
      deinstallation of kdebase4-workspace-libs-4.11.22-1.7.x86_64
      deinstallation of kaddressbook-4.14.10-3.10.x86_64
      deinstallation of akregator-4.14.10-3.10.x86_64
      deinstallation of akonadi-4.14.10-3.10.x86_64
      install libakonadi4-4.14.9-24.1.i586 despite the inferior architecture
      install kdepimlibs4-4.14.9-24.1.i586 despite the inferior architecture
      deinstallation of dropbox-2.10.0-3.2.x86_64
      deinstallation of libkfbapi1-1.0-6.1.x86_64
      deinstallation of libkgapi2-2-2.2.0-3.1.x86_64
      deinstallation of libkolab0-0.6.0-2.6.x86_64
      downgrade of seahorse-lang-3.16.0-2.6.noarch to seahorse-lang-3.14.1-4.1.noarch
      deinstallation of patterns-openSUSE-gnome_yast-20150918-12.1.x86_64
      deinstallation of PackageKit-1.0.7-3.5.x86_64
      deinstallation of libkdevplatform8-1.7.1-4.1.x86_64
      deinstallation of mozilla-kde4-integration-0.6.4-7.2.x86_64
      deinstallation of skanlite-1.1-3.2.x86_64
      downgrade of libkonq5-15.12.2-13.3.x86_64 to libkonq5-15.04.1-20.6.i586
      architecture change of libkonq5-15.12.2-13.3.x86_64 to libkonq5-15.04.1-20.6.i586
      install libkonq5-15.04.1-20.6.i586 despite the inferior architecture
      downgrade of mobipocket-15.12.2-14.1.x86_64 to mobipocket-14.12.3-16.1.i586
      architecture change of mobipocket-15.12.2-14.1.x86_64 to mobipocket-14.12.3-16.1.i586
      install mobipocket-14.12.3-16.1.i586 despite the inferior architecture
      downgrade of kdelibs4-4.14.17-7.1.x86_64 to kdelibs4-4.14.9-27.1.i586
      architecture change of kdelibs4-4.14.17-7.1.x86_64 to kdelibs4-4.14.9-27.1.i586
      install kdelibs4-4.14.9-27.1.i586 despite the inferior architecture
      deinstallation of libkcddb4-15.12.2-14.1.x86_64
      deinstallation of libkatepartinterfaces4-4.14.3-2.3.x86_64
      deinstallation of libbaloowidgets4-4.14.3-4.2.x86_64
      architecture change of libbaloofiles4-4.14.3-4.2.x86_64 to libbaloofiles4-4.14.3-4.2.i586
      install libbaloofiles4-4.14.3-4.2.i586 despite the inferior architecture
      install baloo-core-4.14.3-4.2.i586 despite the inferior architecture
      deinstallation of kwebkitpart-1.3.3-4.2.x86_64
      deinstallation of konsole4-part-4.14.3-1.2.x86_64
      deinstallation of konqueror-plugins-15.12.2-13.3.x86_64
      deinstallation of konqueror-15.12.2-13.3.x86_64
      deinstallation of kfind-15.12.2-13.3.x86_64
      deinstallation of keditbookmarks-15.12.2-13.3.x86_64
      deinstallation of kdialog-15.12.2-13.3.x86_64
      deinstallation of kdevplatform-1.7.1-4.1.x86_64
      deinstallation of kdevelop4-plugin-cppsupport-4.7.1-4.1.x86_64
      deinstallation of kdepasswd-15.12.2-13.3.x86_64
      downgrade of kdelibs4-core-4.14.17-7.1.x86_64 to kdelibs4-core-4.14.9-27.1.i586
      architecture change of kdelibs4-core-4.14.17-7.1.x86_64 to kdelibs4-core-4.14.9-27.1.i586
      install kdelibs4-core-4.14.9-27.1.i586 despite the inferior architecture
      deinstallation of kdebase4-workspace-branding-openSUSE-42.1-1.10.x86_64
      deinstallation of kdebase4-nsplugin-15.12.2-13.3.x86_64
      deinstallation of kdebase4-libkonq-15.12.2-13.3.x86_64
      deinstallation of kde4-kgreeter-plugins-4.11.22-1.7.x86_64
      deinstallation of kate4-parts-4.14.3-2.3.x86_64
      deinstallation of k3b-2.0.3-3.2.x86_64
      deinstallation of digikam-libs-4.14.0-11.1.x86_64
      downgrade of breeze4-style-5.5.4-7.1.x86_64 to breeze4-style-5.3.2-21.1.i586
      architecture change of breeze4-style-5.5.4-7.1.x86_64 to breeze4-style-5.3.2-21.1.i586
      install breeze4-style-5.3.2-21.1.i586 despite the inferior architecture
      architecture change of baloo-kioslaves-4.14.3-4.2.x86_64 to baloo-kioslaves-4.14.3-4.2.i586
      install baloo-kioslaves-4.14.3-4.2.i586 despite the inferior architecture
      deinstallation of kdebase4-runtime-branding-openSUSE-42.1-1.10.x86_64
      downgrade of kwalletd5-5.19.0-6.2.x86_64 to kwalletd5-5.16.0-3.1.x86_64
      deinstallation of deja-dup-lang-34.0-2.9.noarch
      deinstallation of nautilus-deja-dup-34.0-2.9.x86_64
      deinstallation of patterns-openSUSE-gnome_utilities-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_office_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_office-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_imaging_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome_imaging-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-games-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-imaging-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-imaging_opt-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-non_oss-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-sw_management_gnome-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-sw_management_kde-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_web-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-gnome-20150918-12.1.x86_64
      deinstallation of patterns-openSUSE-devel_C_C++-20150918-12.1.x86_64
      deinstallation of gnome-software-lang-3.16.6-4.1.noarch
      deinstallation of libkfbapi-lang-1.0-6.1.x86_64
      deinstallation of nautilus-extension-dropbox-2.10.0-3.2.x86_64
      deinstallation of PackageKit-branding-openSUSE-42.1-1.1.noarch
      deinstallation of PackageKit-lang-1.0.7-3.5.noarch
      deinstallation of skanlite-lang-1.1-3.2.noarch
      deinstallation of skanlite-doc-1.1-3.2.x86_64
      deinstallation of kwebkitpart-lang-1.3.3-4.2.noarch
      deinstallation of kdevplatform-lang-1.7.1-4.1.noarch
      deinstallation of k3b-lang-2.0.3-3.2.noarch
      downgrade of kwalletd5-lang-5.19.0-6.2.noarch to kwalletd5-lang-5.16.0-3.1.noarch
      deinstallation of patterns-openSUSE-non_oss_opt-20150918-12.1.x86_64
      architecture change of baloo-core-4.14.3-4.2.x86_64 to baloo-core-4.14.3-4.2.i586
      architecture change of libbalooqueryparser4-4.14.3-4.2.x86_64 to libbalooqueryparser4-4.14.3-4.2.i586
      install libbalooqueryparser4-4.14.3-4.2.i586 despite the inferior architecture
     Solution 2: do not install patch:openSUSE-2015-840-1.noarch
     Solution 3: break gpg2-lang-2.0.26-2.3.1.noarch by ignoring some of its dependencies

  5. #5
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    450

    Default Re: All my dependencies are screwed up

    Code:
     # zypper lr -d#  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                           | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------------+--------
     3 | http-download.opensuse.org-a045c629 | openSUSE:13.2:Update                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                                     |
    I think this may be your problem. I could be wrong, though. Hopefully someone more knowledgeable will chirp in.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: All my dependencies are screwed up

    You should never mix OS versions you have a 13.2 repo (3 in your list)

    remove it and do a zypper up (note you have a nice mess you may need a zypper dup but do the up first)

    also you have the install media set also remove it (5 in the list)

    In general you really don't need all those debug repos unless you install debug packages

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: All my dependencies are screwed up

    repo's 1 and 4 contain crippled packages remove them and use packman, as gogalthorp said you don't need the install dvd anymore so disable or remove it, and repo #3 is for 13.2. so if you want to keep the DVD but just disable it and remove the bad repo's then fix your system do
    Code:
    sudo zypper mr -d 5
    sudo zypper rr 1 3 4
    sudo zypper dup --from 10 --from 8
    sudo zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.1/ packman
    sudo zypper dup --from packman
    the above disable's the dvd
    remove's the bad repo's
    does a distribution upgrade to the update and the oss repo in case you got a 13.2 package installed, the repo numbers I used I got assuming you removed 3 repo's run zypper lr and see the update and the oss's aliases (currently they're 13 and 11)
    the last two lines add the packman repo which is the one that provides multimedia packages for opensuse you don't have to do that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •