Results 1 to 9 of 9

Thread: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

  1. #1

    Default leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    hello dear comunity,


    just installed tumbleweed with kernel 4.4.2.1 on my new HP Notebook - see the signature...

    But i recognized that the shutdown-process does not work at all. The notebook does not shut down properly. In other words - i cannot turn off the sytem ....

    it freezes all.

    by the way; this also happened with

    - openSuse Leap 42.1
    - ubuntu version 15.10


    funny: only with OpenSuse 13.2 it worked well?!

    why is this so - does this have to do with the different Kernel-Versions?


    Love to hear from you
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,052
    Blog Entries
    3

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    I had that problem with an older laptop. I think it started with opensuse 11.3. It hung/froze during shutdown. So, instead of shutdown, I would reboot. And on the grub menu of the reboot, I would power-off.

    Somewhere around opensuse 12.3, it started to shutdown properly. But it's 32-bit, so I cannot try with Leap.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    hello dear Nrickert

    many many thanks for the answer and the hints...

    Quote Originally Posted by nrickert View Post
    I had that problem with an older laptop. I think it started with opensuse 11.3. It hung/froze during shutdown. So, instead of shutdown, I would reboot. And on the grub menu of the reboot, I would power-off. Somewhere around opensuse 12.3, it started to shutdown properly. But it's 32-bit, so I cannot try with Leap.
    the notebook is this one HP Notebook hp 14 r 103ng

    Intel Pentium N3540 QuadCore, 4GB, 500GB,
    delivered with Free DOS

    see all more detailed:

    processor: Intel® Pentium™-Prozessor N3540 (4x 2,16 GHz, mit Turbo Burst bis zu 2,66 GHz, 2MB Cache)
    Graphics: Intel HD Graphics
    memorey: 4 GB DDRL3 ; 1600 MHz, max. 8 GB
    hdd: 500 GB, 5.400 U/Min, SATA, 2,5“
    DVD-: Super Multi (DVD DL±RW/CD±RW)
    Network: WLAN 802.11 b/g/n, Fast-Ethernet
    connections: VGA, HDMI, 2x USB 2.0, 1x USB 3.0, 1 RJ-45

    very interesting;

    the running BIOS
    Vendor: Insyde
    Version: F.21

    note: a newer Bios is this one F.39A - i did not change the Bios yet - this might be helpful.. i think But to change the Bios i have to do some steps.
    http://ftp.hp.com/pub/softpaq/sp71001-71500/sp71487.exe


    i had a quick view on the net - and found especially this one is helpful: http://askubuntu.com/questions/12584...r-off-computer

    I encounter a problem whenever I shutdown or restart; it kills all running processes (as far as I can tell), but once I get past the shutdown text screen and the screen goes black, my computer doesn't power off. The fans still run and the screen is still on, etc. I have to hold down the power button in order to complety shut down.

    this is exactly what i encounter - 100 %


    the answer who had others found very helpful is the following:

    Quote:

    Type in terminal:
    sudo -i (to get a root shell, sudo gedit is not recommended)
    gedit /etc/default/grub
    Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Change this to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
    Save the file and close the file.
    Finally, in terminal: update-grub
    exit (to end the root shell)

    i think i try this out.


    well i can try to re-booted and look at the messages file to see what it was doing for those 2 mins:

    cat /var/log/messages
    i will do more some investigations and come back and report all the findings...


    greetings
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,052
    Blog Entries
    3

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    The interface between the hardware power supply and the software has been evolving. And sometimes the software gets it wrong for the particular computer.

    You could try compiling your own kernel, so that you get to set the options related to this.

    I'm reminded of an older computer (long since gone to recycling heaven). It came with Win95, in 1995. And it worked pretty well. It's the first computer that I put linux on.

    A few years later, I upgraded to Win98. And on Win 98, it behaved in a very odd way. If it was left idle for a while, it wanted to turn off the monitor. But the act of turning off the monitor was enough for it to think the system was busy and turn it on again.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    hello dear Nrickert

    many many thanks for the hints



    Some ideas regarding the issue: other guys who have bought the same notebook reccomended;:

    ....to install linux in Legacy Mode -
    UEFI seems to make trouble
    .... have to add the kernelparameter "clocksource=acpi_pm"
    and the following Linux mit dem Parameter "acpi=noirq


    how to do that?
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,052
    Blog Entries
    3

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    Quote Originally Posted by dilbertone View Post
    ....to install linux in Legacy Mode -
    UEFI seems to make trouble
    I doubt that, though it could be true of some hardware.

    .... have to add the kernelparameter "clocksource=acpi_pm"
    and the following Linux mit dem Parameter "acpi=noirq
    During boot, hit 'e' as soon as the boot menu shows. Then scroll down to the line starting "linux" (or might be "linuxefi"). Hit the END key to go to the end of that line. Then type in
    Code:
     clocksource=acpi_pm acip=noirq
    and hit F10 to continue the boot. That allows you to test those changes.

    If that works, you can make the changes permanent. Edit (as root) the file "/etc/default/grub" and look for the line that begins "GRUB_CMDLINE_LINUX_DEFAULT=". Make the corresponding changes to the end of that line. Save the changes. Then run
    Code:
    # grub2-mkconfig -o /boot/grub2/grub.cfg
    .
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,671
    Blog Entries
    1

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    I have found that over the years this is usually a problem with the Desktop's shutdown code (You didn't specify which Desktop you're running).

    The advantage of using the Desktop shutdown is that usually it provides for a graceful shutdown. The problem with some processes though, are that before we migrated to systemd and if you are still running sysVinit invoked apps, you can have orphan processes (or otherwise not fully managed). The workaround has been for a system timer to count down, causing a delay which only <hopefully> would be long enough for all processes to terminate, and is totally dumb because even if processes terminated earlier, the timer would still run.

    In the past, when a Desktop had shutdown problems (for me, primarily in IceWM and sometimes LXDE, both which are currently fixed), I've simply opened a console and shutdown with the usual Linux command
    Code:
    shutdown -h now
    The above causes a certain and immediate shutdown without regard to running processes. So, for example never run that command if you're running a database app or risk data corruption.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    OP - what happens when you switch to a terminal and do:

    Code:
    sudo poweroff
    Quote Originally Posted by tsu2 View Post
    I have found that over the years this is usually a problem with the Desktop's shutdown code
    That can be the case, but really whatever the desktop is doing should translate to "poweroff".


    I've seen issues without a desktop running at all.

    My little netbook for example, is running leap as a minimal server installation. Text only, so no X server or Desktop.
    If I shut down with the AC power plugged in and switched on, and leave the lid open, it will boot back up on it's own after a few seconds. There's no wake on LAN. If I shut the lid after it powers off though it's fine. It does not turn on by itself if I open the lid, only if shutdown while plugged in and lid left open.....
    It's quite weird, but not too hard to manage.

  9. #9

    Default Re: leap 42.1 and tumbleweed : shutdown & turn off does not work at all - freezing 100 %

    hello dear all,

    sudo poweroff
    does not fix this behaviour at all - unfortunatley not...

    i am doing some steps in changing the lines in GRUB 2


    btw:
    very interesting;

    the running BIOS
    Vendor: Insyde
    Version: F.21

    note: a newer Bios is this one F.39A - i did not change the Bios yet - this might be helpful.. i think But to change the Bios i have to do some steps.
    http://ftp.hp.com/pub/softpaq/sp71001-71500/sp71487.exe


    what do you say bout the BIOS - can this old BIOS cause such behaviour?

    BTW - it is a bit tricky to upgrad to the newer BIOS - there are some steps necessary
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •