Results 1 to 2 of 2

Thread: Problems with Intel 7260 WiFi card (Solved)

  1. #1
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Problems with Intel 7260 WiFi card (Solved)

    I've been having connectivity problems with my Intel 7260 wifi card on my HP ZBook 17-G2 laptop with OpenSUSE Leap 42.1 for which I have found a solution. So, I decided to post the problem and solution here for the benefit of other folks who are having similar issues.

    I had previously observed intermittent problems connecting to NetGear and LinkSys routers. However, the problems became most pronounced after I installed a Ruckus Access Point and my PC's wifi connection began failing several times each day. I would lose the wifi connection and could not get it back by restarting NetworkManager or network services. Most of the time, I had to reboot to get my wifi connection back. I first worked around the problem by disabling 802.11N with "options iwlwifi 11n_disable=1" in /etc/modprobe.d. However, I found a permanent fix with the help of Emmanuel Grumbach at Intel after I posted the problem at linuxwifi@intel.com.

    The fix was to install the Core14 release of the firmware and driver at:

    https://wireless.wiki.kernel.org/en/...i/core_release

    Copy the firmware to /lib/firmware with:
    "cp iwlwifi-7260-17.ucode /lib/firmware/"

    Then, compile and install the driver as per these instructions:

    https://wireless.wiki.kernel.org/en/...all_the_driver

    With this fix I've now been running for five days without a problem and I'm getting "N" speeds of 300+ mbps with my Ruckus AP.

    The only problem is that I will need to reinstall the firmware and driver each time that I get a kernel update from the standard Leap 42.1 repos. Therefore, the OpenSUSE folks need to integrate this fix into Leap 42.1 so as to avoid this one drawback. In the mean time, I will manually reinstall the firmware and drivers after each kernel update. This isn't a huge inconvenience given the infrequency of kernel updates and the ease of installing the Core14 release from Intel.

    There is a similar bug report that has already been filed in bugzilla to which I have added my comments:

    https://bugzilla.opensuse.org/show_bug.cgi?id=963920

    FYI,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    233

    Default Re: Problems with Intel 7260 WiFi card (Solved)

    Many thanks for your post!

    I had low signal and because of that disconnects. Even while I was sitting next to the AP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •