Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Shared connection asks for root password on every reconnect.

  1. #1
    Join Date
    Jun 2008
    Location
    Düsseldorf/Germany
    Posts
    248

    Default Shared connection asks for root password on every reconnect.

    I have a WIFI connection to a WPA-router. When I allow that all users can connect to this network, I have to enter the root password. So far, so good. But on next connection, e.g. after a S2RAM, it asks again for the root password.
    I raised https://bugs.kde.org/show_bug.cgi?id=359842 for this, but this was rejected as 'polkit settings issue'. But that seems to be an issue in the standard....

    Does anyone have this issue as well and if not, can you share your (working) settings?

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Shared connection asks for root password on every reconnect.

    Hi DocB,

    on old installs this is not happening

    on the latest install it is, but it is not consistent

    sometimes to get a wifi connection the root password needs to be entered twice and also the wallet password,
    other times only the root password is asked for once

    all seems to depend on the settings of auto connect, and allow all users access

    wolfi123 has stated his is due to kde4 programs needing kwalletmanager and kde5 programs needing kwalletmanaager5

    today kwalletmanager was tried but without success, hence no sync between kwalletmanager and kwalletmanager5

    this is just to confirm you are not alone

    cheers

    config:-

    Code:
    2. Mär 09:53:48 CET 2016
    System:    Host: hp-17-p105ng.home Kernel: 4.1.15-8-default x86_64 (64 bit) 
               Desktop: KDE Plasma 5.5.4 Distro: openSUSE Leap 42.1
    Machine:   System: HP product: HP Notebook Mobo: HP model: 8130 v: 25.13 Bios: American Megatrends v: F.14 date: 12/08/2015
    CPU:       Quad core AMD A6-6310 APU with AMD Radeon R4 Graphics (-MCP-) cache: 8192 KB 
               clock speeds: max: 1800 MHz 1: 1400 MHz 2: 1000 MHz 3: 1800 MHz 4: 1200 MHz
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics]
               Display Server: X.Org 1.17.2 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1600x900@60.0hz
               GLX Renderer: Gallium 0.4 on AMD MULLINS (DRM 2.42.0, LLVM 3.7.0) GLX Version: 3.0 Mesa 11.0.8 Direct Rendering: Yes
    Network:   Card-1: Broadcom BCM43142 802.11b/g/n driver: wl 
               Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169

  3. #3
    Join Date
    Jun 2008
    Location
    Düsseldorf/Germany
    Posts
    248

    Default Re: Shared connection asks for root password on every reconnect.

    Hi Keellambert
    thanks for your confirmation!
    Quote Originally Posted by keellambert View Post
    wolfi123 has stated his is due to kde4 programs needing kwalletmanager and kde5 programs needing kwalletmanaager5
    the double password-entry for kwalletmanager is a known issue.

    Up to now I was consistently only asked for the root password.
    Quite strange that the maintainer states that my settings are freaked up. IMO it is a more general problem.

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Shared connection asks for root password on every reconnect.

    Hi DocB,

    Quote Originally Posted by DocB View Post
    Quite strange that the maintainer states that my settings are freaked up. IMO it is a more general problem.
    On three other laptops and a PC reliant on wifi there is not a problem so it looks hardware specific

    have you tried from a new use account? that would verify if it is your settings

    I share your opinion and feel its a more general problem

    this laptop is brand new (now 4 days old), purchased without an OS, so nothing should be messed up

    cheers

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,369
    Blog Entries
    3

    Default Re: Shared connection asks for root password on every reconnect.

    This looks like the problem that I described in a blog post Another look at NetworkManager and Tumbleweed.

    That was for Tumbleweed. But the latest updates to Leap 42.1 might have introduced that problem there.

    I describe the work-around. Basically, install "NetworkManager-gnome (which contains "nm-applet"). You can fix this with "nm-applet". In my experience, you can probably fix it with XFCE or MATE or Icewm. For Icewm, you would have to start "nm-applet" (from the command line is fine). And you would have to start a polkit deamon (using "/usr/lib64/libexec/polkit-kde-authentication-agent-1" should be fine).

    Opensuse bug 938510 is related.

    If this is the same bug, then I don't see it as a polkit bug. Rather it is a NetworkManager client bug (calling polkit with the wrong information). It is being treated as changing a shared connection, which reasonably requires root. But it should instead be treated as making a connection, which should not require root.
    openSUSE Leap 15.1; KDE Plasma 5;

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,369
    Blog Entries
    3

    Default Re: Shared connection asks for root password on every reconnect.

    Quote Originally Posted by nrickert View Post
    This looks like the problem that I described in a blog post Another look at NetworkManager and Tumbleweed.
    After further investigation -- yes, it is the identical problem.

    I see that "libKF5NetworkManagerQt6" was updated in the last couple of days. That's probably the change causing this new behavior.

    If you setup a shared connection before then, it should be fine. If you have not shared the connection with other users, it should be fine. But if you have shared a connection since that update, you will probably see the problem described in the OP.

    If you change it back to no longer a shared connection, then it will be easier to use. If you want it to be a shared connection as before this update, then I only know how to fix that using "nm-applet". If you have XFCE or LXDE or MATE installed, you can probably fix it there. Otherwise, install "NetworkManager-gnome" and run "nm-applet" in an Icewm session. You might also need to run a polkit client (not sure of that). And you will be prompted for the root password once or twice while fixing it.

    You have to edit the connection. Go to the connection security tab. Re-enter the network key. At the right of that line, you can click on a tiny icon and set it to "store the password for all users". After that it should work the way that you wanted.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,369
    Blog Entries
    3

    Default Re: Shared connection asks for root password on every reconnect.

    Quote Originally Posted by keellambert View Post
    all seems to depend on the settings of auto connect, and allow all users access
    It is particularly related to allowing all users access. If you turn that off, then it should be back to only needing the kwallet password.

    wolfi123 has stated his is due to kde4 programs needing kwalletmanager and kde5 programs needing kwalletmanaager5
    I don't think that's right, but it could complicate the issue. I do suggest using "kwalletmanager5" to set "kwallet" to stay open, so that you are only asked for the wallet password once per session.
    openSUSE Leap 15.1; KDE Plasma 5;

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,369
    Blog Entries
    3

    Default Re: Shared connection asks for root password on every reconnect.

    Quote Originally Posted by nrickert View Post
    I see that "libKF5NetworkManagerQt6" was updated in the last couple of days. That's probably the change causing this new behavior.
    Apparently, it is actually "plasma-nm5". And zypper logs show the last update of that as Feb 20 here (it might have been updated in the repos a day or two earlier). When I tested a month earlier, the problem did not exist in Leap, though it did exist in Tumbleweed.

    I added a comment to the KDE bug report.
    openSUSE Leap 15.1; KDE Plasma 5;

  9. #9
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Shared connection asks for root password on every reconnect.

    hi nrickert,

    Quote Originally Posted by nrickert View Post
    You have to edit the connection. Go to the connection security tab. Re-enter the network key. At the right of that line, you can click on a tiny icon and set it to "store the password for all users". After that it should work the way that you wanted.
    [/COLOR]
    thx, nm-applet in iceWM did as described, now back to normal

    the icon mentioned now reads "store the password only for this users" and then when selected three options are shown,
    one of which is "store the password for all users"

    cheers

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,369
    Blog Entries
    3

    Default Re: Shared connection asks for root password on every reconnect.

    Quote Originally Posted by keellambert View Post
    thx, nm-applet in iceWM did as described, now back to normal
    I'm glad you have it working.

    In my opinion, the KDE folk made a bad decision here. They need to admit their mistake and fix it. At present they are being stubborn.
    openSUSE Leap 15.1; KDE Plasma 5;

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •