Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 51

Thread: Black screen after login (Plasma 5)

  1. #21

    Default Re: Black screen after login (Plasma 5)

    PS: the Qt5 update is in the repo meanwhile. So update again to fix your problems.

  2. #22

    Default Re: Black screen after login (Plasma 5)

    Quote Originally Posted by patdec View Post
    No the QT5 repository is not enabled.
    No, but installing Qt5 from the KDE:Qt5 repo would have been another workaround.

    As I said, the packages in KDE:Frameworks5 for Leap have those session management patches still disabled, so they do not require the newer Qt5.
    Although they will be enabled shortly as well, as the Qt5 update is in the Update repo now.

  3. #23

    Default Re: Black screen after login (Plasma 5)

    Ahhhh. I had this problem as well. Not funny at all.

    Yesterday it was SD card reader. Solution was: add "filesystems" repository. This "filesystems" is in addition to >10 other repositories for subpixel, multimedia, cinepaint, obsolete libraries that my old programs need, ...

    And today this. All frozen. Hard reboot. Then I did this Qt5 update. But for instance now konsole is not working. Luckily I have Xterm.

    So tiresome. I will again revert to the old habbit of updating suse once in 2-3 month...


    konsole errors after Qt5 update:
    Code:
    QCoreApplication::arguments: Please instantiate the QApplication object first
    QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
     konsole: relocation error: /usr/lib64/libKF5KDELibs4Support.so.5: symbol _ZN15QGuiApplication35setFallbackSessionManagementEnabledEb, version Qt_5 not defined in file libQt5Gui.so.5 with link time reference

  4. #24

    Default Re: Black screen after login (Plasma 5)

    Quote Originally Posted by nekodrugi View Post
    Then I did this Qt5 update. But for instance now konsole is not working.
    You obviously did *not* do this Qt5 update, since then Konsole would be working. The error message shows exactly that you still have the older Qt5...

    Run "zypper patch" and it should be fixed.

  5. #25

    Default Re: Black screen after login (Plasma 5)

    Quote Originally Posted by wolfi323 View Post
    You obviously did *not* do this Qt5 update, since then Konsole would be working. The error message shows exactly that you still have the older Qt5...

    Run "zypper patch" and it should be fixed.
    Ufffff. I don't think that you are right:
    Code:
    su
    zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Nothing to do.
    For instance libQt5Core5 is 5.5.1-7.1.
    EDIT: KF5 libs are 5.19.0-11.2

  6. #26

    Default Re: Black screen after login (Plasma 5)

    Quote Originally Posted by nekodrugi View Post
    Ufffff. I don't think that you are right:
    Code:
    su
    zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Nothing to do.
    For instance libQt5Core5 is 5.5.1-7.1.
    Yes, and that's the old one.

    Hm, either I looked at the wrong repo before, or the Qt5 update got removed again meanwhile...

    Either add the update-test repo as mentioned before and update your system, or downgrade libKF5XmlGui5 and libKF5KDELibs4Support5 to 5.16.0 for now:
    Code:
    sudo zypper in -f  libKF5XmlGui5-5.16.0 libKF5KDELibs4Support5-5.16.0

  7. #27

    Default Re: Black screen after login (Plasma 5)

    After ~1h try I did as someone on bugzilla advised, login IceWM and downgraded:
    libKF5KDELibs4Support5
    libKF5XmlGui5
    libKF5XmlGui5-lang
    libQt5Gui5

    logout and login Plasma5
    works

  8. #28
    Join Date
    Jan 2016
    Location
    UK
    Posts
    566

    Default Re: Black screen after login (Plasma 5)

    Well wolfi that has solve my problem and I have a fully working system back. Thanks....

    Perhaps someone will get a kick in the proverbials for this situation arising

    Stuart

  9. #29

    Default Re: Black screen after login (Plasma 5)

    Quote Originally Posted by robert_d View Post
    After ~1h try I did as someone on bugzilla advised, login IceWM and downgraded:
    libKF5KDELibs4Support5
    libKF5XmlGui5
    libKF5XmlGui5-lang
    libQt5Gui5
    The first two should be enough.

  10. #30
    Join Date
    Mar 2016
    Location
    Netherlands
    Posts
    7

    Default Re: Black screen after login (Plasma 5)

    I had the same issue today. I noticed i have many components of KDE Frameworks 5.19 installed. In an ICEWM session I have started up YAST. Then went to the repository openSUSE-Update-42.1 and there looked for packages with version 5.19.xx. You can then in the versions tab switch these packages back to version 5.16.xx which is a lot of work! But it did fix the problem and I could login again. Hopefully they find a fix for this problem soon!

Page 3 of 6 FirstFirst 12345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •