Results 1 to 3 of 3

Thread: Packages for gap, gap-doc installed, but'?help' fails to show any docs

  1. #1

    Default Packages for gap, gap-doc installed, but'?help' fails to show any docs

    After a fairly recent install (as in: within the past two weeks) of openSUSE Leap 42.1, I tried installing packages gap, gap-doc, and a few other gap packages. I have done this with both zypper and yast2.

    In fact, "zypper info gap*" seems to return the right results, listing gap, gap-doc and a few others as 'installed'.

    But now here is the problem: it is a feature of the GAP language that once you start the program and wait for it to finish loading libraries and print the prompt, '?help' is supposed to display the online help. This works fine in my installation of GAP on another virtual machine under Fedora, but fails on openSUSE with the error message: Help: no matching entry found

    In fact, here is a little more of the screen, clarifying that I really did type it right, and showing the version# of GAP:

    ┌───────┐ GAP, Version 4.7.9 of 29-Nov-2015 (free software, GPL)
    │ GAP │
    └───────┘ Architecture: x86_64-suse-linux-gnu-gcc-default64
    Libs used: gmp, readline
    Loading the library and packages ...
    Packages: GAPDoc 1.5.1
    Try '?help' for help. See also '?copyright' and '?authors'
    gap> ?help
    Help: no matching entry found

    I am not sure how helpful it is, but concerning the other two commands listed above, one fails in the same way but '?copyright' fails in a different way, e.g.:

    elp: several entries match this topic - type ?2 to get match [2]

    [1] AtlasRep (not loaded): Copyright
    [2] Automata (not loaded): Copyright
    [3] GAPDoc: Copyright
    [4] GAPDoc: Copyright
    [5] GAPDoc Example: Copyright

    Now I recognize this as the form the output to a help command takes when there are several different help entries matching the topic. And in fact, we can see the word 'Copyright' did match. But if I select any of 1-5, I still get a dead end: it opens vi instead of displaying the selected item.

    Now since all these things work with the Fedora package fro GAP, it seems pretty clear that there is something wrong with GAP package in the
    openSUSE-Leap-42.1-Update-Non-Oss repository. But this is the most up-to-date repo searching reveals for GAP under openSUSE. I find it hard to believe that all other users under openSUSE are living with such a basic failure. Or could there be some peculiarity of my system that causes it to fail for me but not for others?

    The main peculiarity I can think of off the top of my head is that I am running openSUSE under Oracle's VM, VirtualBox. But again, I find it hard to believe that could explain it.

    Come to think of it, there are a couple of suspicious looking items in the zypper info output, so I am including this here, just in case this helps decipher what is going wrong:

    zypper info gap
    Loading repository data...
    Warning: Repository 'openSUSE-Leap-42.1-Update-Non-Oss' appears to be outdated. Consider using a different mirror or server.
    Reading installed packages...

    Information for package gap:
    Repository: science
    Name: gap
    Version: 4.7.9-2.1
    Arch: x86_64
    Vendor: obs://
    Installed: Yes
    Status: up-to-date
    Installed Size: 0 B
    Summary: System for Computational Discrete Algebra
    GAP is a system for computational discrete algebra, with particular
    emphasis on Computational Group Theory. GAP provides a programming
    language, a library of thousands of functions implementing algebraic
    algorithms written in the GAP language as well as large data
    libraries of algebraic objects. GAP is used in research and teaching
    for studying groups and their representations, rings, vector spaces,
    algebras, combinatorial structures, and more.

    This package is for a medium GAP installation: core, documentation
    and development. See gap-full if you want everything of the GAP

    It strikes me as particularly suspicious that Installed Size is 0. I already know to ignore the warning about the repo being 'outdated'.

    Any insight into this problem or even how to figure out more about it will be gratefully accepted.

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Packages for gap, gap-doc installed, but'?help' fails to show any docs

    I'm pretty sure this would be the same on Fedora,

    Any "docs" package has no relationship to "help"

    The standard syntax nowadays to invoke help is
    command --help
    and sometimes
    command -h
    And although you didn't ask about it, to be complete people should know that the next standard documentation is generally a MAN file
    man command 
    When you install a "doc" package, the content is typically extensive and provided by the Project backing the command or appplication. When this package is installed, the standard location for the docs would be a subdirectory of
    When I look for that kind of documentation, I don't usually try to browse for it, I usually just run "locate" which is part of the mlocate package. If you don't have it installed, I highly recommend it
    zypper in mlocate
    Followed by immediately populating its database. It updates daily, but who wants to wait a day to use locate?
    After the above, you can run something like the following to get an immediate location
    locate gap
    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Packages for gap, gap-doc installed, but'?help' fails to show any docs

    Thanks for the reply, but no, on Fedora, it works exactly as I expect it to, exactly as it has always worked: I installed by logging into the Fedora VM and entering
    dnf install gap
    And after entering gap,
    works exactly as expected. I verified this just about 3 days ago. (I am not going to verify this now since this machine really bogs down when running one VM for openSUSE and another for Fedora).

    Yes, I know it sounds horribly old fashioned, but GAP users are used to this help system and expect it; it is easy to use for people used to Gnu info. It really is much more informative than '--help' on the Linux command line. And it is handy that you don't need an Internet connection to get full GAP help.

    So there is definitely something wrong with the openSUSE package, something that is not wrong with the yum/dnf package.

    But I went ahead and tried your suggestion anyway. I got:

    >gap --help
    gap: sorry, options must not be grouped '--help'.
    usage: gap [OPTIONS] [FILES]
           run the Groups, Algorithms and Programming system, Version 4.7.9
           use '-h' option to get help.
    So then I tried
    gap -h
    to get:

    >gap --help
    gap: sorry, options must not be grouped '--help'.
    usage: gap [OPTIONS] [FILES]
           run the Groups, Algorithms and Programming system, Version 4.7.9
           use '-h' option to get help.
    As I expected, this is all strictly about how to invoke GAP. Nothing about what to do once you have invoked it, which is what is covered by GAP's own help system, the one I cannot access in the openSUSE package for GAP.

    As a workaround, I could, of course, use the HTML help on the GAP website. But this is actually somewhat cumbersome compared to the built-in help command.
    Last edited by mejohnsn; 07-Mar-2016 at 21:37. Reason: Editor handles quote marks poorly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts