Results 1 to 3 of 3

Thread: KDE does not start - ATI Radeon X1250 onboard card

  1. #1

    Question KDE does not start - ATI Radeon X1250 onboard card


    I am installing Leap on an old PC which has an asus m2a-vm card, which includes an onboard ATI Radeon X1250-based graphics (chipset: RS600/RS690/RS740).

    I was able to install it using KDE choosing no KMS video mode.
    I had to repeat the process several times because it hanged at different stages. Finally it worked without choosing to detect usb nor configuring networking before the installation started to copy files.

    Now I am not able to get KDE to work. The screen goes black after boot and plasma dialog errors appears.
    I have tried several things after reading, but still I am not able to make it work:
    - with nomodest kernel option (as default because I choose no MKS)
    - adding fglrx driver using zypper as described here
    - tried with /etc/X11/xorg.conf based on /etc/X11/xorg.conf.install
    - Xorg -configure gives different errors:
    * (EE) Server terminated with error (2). Closing log file. - when booting without nomodeset
    * (EE) Segmentation fault at address 0x0 - when booting with nomodeset

    I am attaching two files with validations on console after booting, including /var/log/Xorg.0.log and some validations: - boot normal (without nomodeset) - boot with nomodeset

    Any help is appreciated.


  2. #2

    Default Try the older OS

    You can try to boot from opensuse 13.2 Live USB.

    Also you can try to install opensuse 13.2.

  3. #3

    Red face Re: KDE does not start - ATI Radeon X1250 onboard card

    Thanks, tried with 13.2 and installed went to graphics mode out of the box.

    After that I tried a couple of things back in Leap and it finally worked.

    Summary of steps was:
    - install Leap choosing no MKS
    - do no accept any of the installer questions about to discover hardware (usb, etc.) or configure network
    - when having black screen and errors after reboot, go to console, configure network and do zypper up
    - remove fglrx driver
    - reboot and edit kernel settings removing nomodeset

    After that KDE is working.

    Thanks for the help.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts