Results 1 to 4 of 4

Thread: Persistent zypper libADM sym-link errors

  1. #1
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    147

    Default Persistent zypper libADM sym-link errors

    Running openSUSE 13.1 KDE4 with the following repo setup:
    Code:
    zypper lr#  | Alias                                | Name                                 | Enabled | Refresh
    ---+--------------------------------------+--------------------------------------+---------+--------
     1 | Apps_Geo-openSUSE_12-1               | Apps_Geo-openSUSE_13.1               | Yes     | Yes    
     2 | KDE-Current-openSUSE_13.1            | KDE-Current-openSUSE_13.1            | Yes     | Yes    
     3 | KDE:/Extra/KDE_Current_openSUSE_13.1 | KDE:/Extra/KDE_Current_openSUSE_13.1 | Yes     | Yes    
     4 | Moka-project_openSUSE_13.1           | Moka-project_openSUSE_13.1           | Yes     | Yes    
     5 | Network-openSUSE-13.1                | Network-openSUSE-13.1                | Yes     | Yes    
     6 | Razor_Qt_openSUSE_12.3               | Razor Qt openSUSE 13.1               | No      | Yes    
     7 | Utilities-openSUSE-13.1              | Utilities-openSUSE-13.1              | Yes     | Yes    
     8 | download.nvidia.com-opensuse         | nVidia Graphics Drivers              | Yes     | Yes    
     9 | download.opensuse.org-Education      | openSUSE BuildService - Education    | Yes     | Yes    
    10 | download.opensuse.org-games          | openSUSE BuildService - Games        | No      | No     
    11 | ftp.gwdg.de-suse                     | Packman Repository                   | Yes     | Yes    
    12 | google-chrome                        | google-chrome                        | Yes     | Yes    
    13 | jitsi.repo                           | jitsi.repo                           | No      | No     
    14 | local-repo                           | local-repo                           | No      | No     
    15 | opensuse-guide.org-repo              | libdvdcss repository                 | No      | No     
    16 | repo-12.3-non-oss                    | openSUSE-13.1-Non-Oss                | Yes     | Yes    
    17 | repo-12.3-oss                        | openSUSE-13.1-OSS                    | Yes     | Yes    
    18 | repo-12.3-update                     | openSUSE-13.1 Update-Oss             | Yes     | Yes    
    19 | repo-update-non-oss                  | openSUSE-13.1-Update-Non-Oss         | Yes     | Yes
    Recent zypper updates regularly display "Additional rpm output" messages relating to libADM symbolic link errors similar to this:
    Code:
    ( 12/203) Installing: glibc-2.18-4.44.1 ....................................................[done]
    Additional rpm output:
    /sbin/ldconfig: /usr/lib64/libADM_coreSocket6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioDevice6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudio6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreLibVA6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6swscale.so.3 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSqlLight3.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreJobs.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avutil.so.54 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoCodec6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_core6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSubtitle.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreScript.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreMuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avcodec.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avformat.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImage6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioFilterAPI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_audioParser6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImageLoader6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUtils6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVDPAU6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxerMpeg6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoFilter6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6postproc.so.53 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSocket6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioDevice6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudio6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreLibVA6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6swscale.so.3 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSqlLight3.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreJobs.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avutil.so.54 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoCodec6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_core6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSubtitle.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreScript.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreMuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avcodec.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avformat.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImage6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioFilterAPI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_audioParser6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImageLoader6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUtils6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVDPAU6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxerMpeg6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoFilter6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6postproc.so.53 is not a symbolic link
    When running zypper up today similar messages were issued 99 times. There is some variation in the content of each report but only libADM related files are referenced. This issue is temporarily resolved by forced re-installation of Avidemux but the messages soon reappear.

    I would be grateful for technical advice towards a better solution.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,956
    Blog Entries
    2

    Default Re: Persistent zypper libADM sym-link errors

    Quote Originally Posted by Tallowwood View Post
    Running openSUSE 13.1 KDE4 with the following repo setup:
    Code:
    zypper lr#  | Alias                                | Name                                 | Enabled | Refresh
    ---+--------------------------------------+--------------------------------------+---------+--------
     1 | Apps_Geo-openSUSE_12-1               | Apps_Geo-openSUSE_13.1               | Yes     | Yes    
     2 | KDE-Current-openSUSE_13.1            | KDE-Current-openSUSE_13.1            | Yes     | Yes    
     3 | KDE:/Extra/KDE_Current_openSUSE_13.1 | KDE:/Extra/KDE_Current_openSUSE_13.1 | Yes     | Yes    
     4 | Moka-project_openSUSE_13.1           | Moka-project_openSUSE_13.1           | Yes     | Yes    
     5 | Network-openSUSE-13.1                | Network-openSUSE-13.1                | Yes     | Yes    
     6 | Razor_Qt_openSUSE_12.3               | Razor Qt openSUSE 13.1               | No      | Yes    
     7 | Utilities-openSUSE-13.1              | Utilities-openSUSE-13.1              | Yes     | Yes    
     8 | download.nvidia.com-opensuse         | nVidia Graphics Drivers              | Yes     | Yes    
     9 | download.opensuse.org-Education      | openSUSE BuildService - Education    | Yes     | Yes    
    10 | download.opensuse.org-games          | openSUSE BuildService - Games        | No      | No     
    11 | ftp.gwdg.de-suse                     | Packman Repository                   | Yes     | Yes    
    12 | google-chrome                        | google-chrome                        | Yes     | Yes    
    13 | jitsi.repo                           | jitsi.repo                           | No      | No     
    14 | local-repo                           | local-repo                           | No      | No     
    15 | opensuse-guide.org-repo              | libdvdcss repository                 | No      | No     
    16 | repo-12.3-non-oss                    | openSUSE-13.1-Non-Oss                | Yes     | Yes    
    17 | repo-12.3-oss                        | openSUSE-13.1-OSS                    | Yes     | Yes    
    18 | repo-12.3-update                     | openSUSE-13.1 Update-Oss             | Yes     | Yes    
    19 | repo-update-non-oss                  | openSUSE-13.1-Update-Non-Oss         | Yes     | Yes
    Recent zypper updates regularly display "Additional rpm output" messages relating to libADM symbolic link errors similar to this:
    Code:
    ( 12/203) Installing: glibc-2.18-4.44.1 ....................................................[done]
    Additional rpm output:
    /sbin/ldconfig: /usr/lib64/libADM_coreSocket6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioDevice6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudio6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreLibVA6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6swscale.so.3 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSqlLight3.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreJobs.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avutil.so.54 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoCodec6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_core6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSubtitle.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreScript.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreMuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avcodec.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avformat.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImage6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioFilterAPI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_audioParser6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImageLoader6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUtils6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVDPAU6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxerMpeg6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoFilter6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6postproc.so.53 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSocket6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioDevice6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudio6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreLibVA6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6swscale.so.3 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSqlLight3.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreJobs.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avutil.so.54 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoCodec6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_core6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreSubtitle.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreScript.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreMuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avcodec.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6avformat.so.56 is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImage6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioEncoder6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreAudioFilterAPI6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_audioParser6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxer6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreImageLoader6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreUtils6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVDPAU6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreDemuxerMpeg6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM_coreVideoFilter6.so is not a symbolic link
    /sbin/ldconfig: /usr/lib64/libADM6postproc.so.53 is not a symbolic link
    When running zypper up today similar messages were issued 99 times. There is some variation in the content of each report but only libADM related files are referenced. This issue is temporarily resolved by forced re-installation of Avidemux but the messages soon reappear.

    I would be grateful for technical advice towards a better solution.
    Looks to me that there is an error in ldconfig.
    Recommend you submit a bug to https://bugzilla.opensuse.org. You might want to assign a high priority, I don't know if it's affecting your system but in the past I found ldconfig to be pretty important.

    Just post your ldconfig errors,and include the output for
    Code:
    uname -a
    You don't need to list your repos.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    147

    Default Re: Persistent zypper libADM sym-link errors

    Thanks TSU. Posted this bug report, as suggested.

    So far I have seen no other evidence of system degradation. I have avoided using Avidemux since these Idconfig error messages began appearing.

  4. #4
    Join Date
    Mar 2009
    Location
    Sydney AU
    Posts
    147

    Default Re: Persistent zypper libADM sym-link errors

    Initial response to the bug post from developer suggests the issue is not an ldconfig bug.

    Michael Matz 2016-02-29 14:47:48 UTC Well, the message of ldconfig certainly is correct. /usr/lib64/libADM_coreSocket6.so is no symlink, and normally it should indeed
    be. ldconfig suppresses this message when the library soname is the library itself. The problem is created by the .rpmsave file. That has a soname of "libADM_coreSocket6.so" itself, but that target file is no symlink (because it's taken by the library proper), so the message results.

    No idea why rpm created this .rpmsave file, it normally does only for config files, but in any case, this is the problem, not ldconfig. Either a bug in the avidemux spec file, or in our installer. Back to screening.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •