Results 1 to 10 of 10

Thread: Opera & Google SSL connection error

  1. #1

    Default Opera & Google SSL connection error

    Giving Opera a try form the repos and keep running into this SSL connection error everytime I try to use google search

    Code:
    SSL connection error
    
    Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.
    
    Any fix for it?

    Thanks
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: Opera & Google SSL connection error

    Immediately after trying to connect to Google, run the following to retrieve the last 10 system entries to see if a more descriptive error was reported
    Code:
    journalctl -n 10
    Also, have you updated your system? Run the following to ensure you're using latest SSL packages and more
    Code:
    zypper update
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Opera & Google SSL connection error

    The same problem here.

    Code:
    journalctl -n 10
    -- Logs begin at Mon 2016-01-25 12:25:29 CET, end at Wed 2016-02-24 08:01:34 CET. --
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Feb 24 08:01:34 linux-107w org.kde.KScreen[1579]: kscreen: Primary output changed from KScreen::Output(Id: 587 , Name: "DVI-I-1" ) ( "DVI-I-1
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  4. #4

    Default Re: Opera & Google SSL connection error

    Always up to date.

    Code:
    -- Logs begin at Wed 2015-12-30 14:17:16 GMT, end at Wed 2016-02-24 10:40:56 GMT. --
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    Feb 24 10:40:56 linux-8rrb org.kde.KScreen[26898]: kscreen: Primary output changed from KScreen::Output(Id: 122 , Name: "DFP3
    lines 1-11/11 (END)
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  5. #5
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: Opera & Google SSL connection error

    i just installed opera on a vm with LEAP42.1 and I don't encounter any issues. I downloaded the rpm from their site and installed with zypper install. It complained that there is no key with the rpm but I chose to ignore that for now(is just for this test) and i was able to browse with Opera.
    There were some other issues with it few weeks ago(in another thread about Chrome(but i encountered also with Opera at the same time in 13.2)) but the errors were not as the ones you are encountering now.
    More details would be needed to see what is wrong on your system. What repository did you install it from?
    Would you try to uninstall and than install it manually with zypper?
    Which version you have? I installed opera-stable_35.0.2066.82_amd64.rpm

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: Opera & Google SSL connection error

    The last 10 lines probably weren't enough to capture both the error and the event immediately prior.

    Try increasing the number of entries, eg. to 100
    Code:
    journalctl -n 100
    Also,
    As dmera suggests it might be important to know the source and version of your Opera, you can post the output of the following
    Code:
    zypper info opera
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Opera & Google SSL connection error

    About my Opera
    Code:
    rpm -qi opera
    Name        : opera
    Version     : 32.0.1948.69
    Release     : 1.1
    Architecture: x86_64
    Install Date: Wed 24 Feb 2016 04:25:27 PM CET
    Group       : Productivity/Networking/Web/Browsers
    Size        : 154793870
    License     : SUSE-NonFree
    Signature   : RSA/SHA256, Fri 23 Oct 2015 08:03:59 AM CEST, Key ID b88b2fd43dbdc284
    Source RPM  : opera-32.0.1948.69-1.1.src.rpm
    Build Date  : Fri 23 Oct 2015 07:53:35 AM CEST
    Build Host  : build11
    Relocations : (not relocatable)
    Packager    : http://bugs.opensuse.org
    Vendor      : openSUSE
    URL         : https://opera.com/
    Summary     : Proprietary web browser
    Description :
    Opera is a proprietary, fast, and user-friendly web browser.
    It includes web developer tools, news aggregation, and the ability
    to compress data via Opera Turbo on congested networks.
    Distribution: openSUSE Leap 42.1
    System always updated.

    In my case problem exists only with Google.
    Other websites via https:// work fine.
    So I guess... it's certificate?
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  8. #8

    Default Re: Opera & Google SSL connection error

    It's the official release 32.0.1948.69. I'm the same it's only with google (so far).
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  9. #9

    Default Re: Opera & Google SSL connection error

    That version update resolved it.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Opera & Google SSL connection error

    I also confirm that upgrading Opera (to 35) solves this particular problem.
    Now ssl with google works fine for me.
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •