Results 1 to 3 of 3

Thread: MATE not working

  1. #1

    Default MATE not working

    Hello,

    I just installed Leap from the NET ISO. Looking great, I see the developers fixed a ton of issues

    I decided to install the KDE desktop, but I also marked the MATE Desktop pattern to be installed. SDDM is able to detect that MATE is installed, but MATE itself doesn't work.... at all. All I get is a black screen, and then I have to reboot my system. This happened on 13.2 as well.

    It doesn't happen on Arch/Debian/Ubuntu. In fact, I can use the same /home folder in all these distros and all of them work. In addition, I erased my drive before installing openSUSE, so it was brand-new.

    Here is something interesting:
    Code:
    amarildo@linux-jyea:~> journalctl | grep mate
    Fev 22 20:35:32 linux-jyea sddm-greeter[1890]: Reading from "/usr/share/xsessions/mate.desktop"
    Fev 22 21:35:51 linux-jyea sddm-greeter[6170]: Reading from "/usr/share/xsessions/mate.desktop"
    Fev 22 21:35:59 linux-jyea sddm-greeter[6170]: Reading from "/usr/share/xsessions/mate.desktop"
    Fev 22 21:35:59 linux-jyea sddm[1680]: Reading from "/usr/share/xsessions/mate.desktop"
    Fev 22 21:35:59 linux-jyea sddm[1680]: Session "/usr/share/xsessions/mate.desktop" selected, command: "mate-session"
    Fev 22 21:35:59 linux-jyea sddm-helper[6183]: Starting: "/etc/X11/xdm/Xsession" "mate-session"
    Fev 22 21:35:59 linux-jyea mate-session[6184]: WARNING: Unable to find provider 'mate-panel' of required component 'panel'
    Fev 22 21:36:00 linux-jyea polkitd[1292]: Registered Authentication Agent for unix-session:8 (system bus name :1.105 [/usr/lib/polkit-mate/polkit-mate-authentication-agent-1], object path /org/mate/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    Fev 22 21:37:04 linux-jyea polkitd[1292]: Unregistered Authentication Agent for unix-session:8 (system bus name :1.105, object path /org/mate/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
    Fev 22 21:37:06 linux-jyea sddm-greeter[6543]: Reading from "/usr/share/xsessions/mate.desktop"
    Fev 22 21:37:07 linux-jyea sddm-greeter[6566]: Reading from "/usr/share/xsessions/mate.desktop"
    What could be causing this?

    Here's some image:


    I really need MATE working, I don't want to stay on KDE.

    BTW, if there's any command to output everything from what is installed, let me know.

    Cheers.

  2. #2

    Default Re: MATE not working

    I found my MATE problem. I'm used to block a ton of packages, and one of them is libgoa. Libgoa is a dependency if gvfs, which is a dependency of MATE So now everything is fine, I'm using openSUSE with MATE and KDE5, and everything is working beautifully. All I have to do now is create a dummy package for libgoa.



    I'm really happy with the results and I'm recommending openSUSE 42.1 to everybody.

    Mods feel free to mark the thread as [SOLVED].

    Regards,
    Amarildo

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,755
    Blog Entries
    3

    Default Re: MATE not working

    I'm glad you have it working. Enjoy opensuse Leap 42.1.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •