Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Probleme mit MP4 Videos

  1. #1

    Default Probleme mit MP4 Videos

    Hallo zusammen,
    ich bin immer noch am Aufrüsten meines neuen Notebooks mit Suse Leap 42.1, nachdem mein altes Notebook (mit 12.3) den Geist aufgegeben hat.
    Ich war der Meinung, dass ich alles so eingestellt und installiert hatte, wie in der 12.3.
    Aber leider habe ich Probleme mit dem Abspielen von .mp4 Videos.
    Zum einen offline. Ich habe die 4 Programme dafür installiert:
    Xine, VLC, Dragon, Kaffeine.
    Das packman Repository ist eingebunden.
    Leider wollen die nicht so wie ich es erwarte.


    • VLC ruckelt nach ein paar Sekunden und verzerrt das Bild.
      Einmal habe ich mitten unterm Abspielen den Fortschrittsbalken nach vorne gezogen. Dann hat er das ordentlich abgespielt.
      Beim 2. gleichen Versuch stürzt VLC ab.
    • bei XINE und Kaffeine flackert das Bild im Sekundentakt, wie bei einem Stroboskop. (Bild wird dann fast schwarz und dann wieder ok)
    • Dragon hatte ich zu dem Zeitpunkt noch nicht probiert.


    Zum anderen mp4-Videos im Internet mit Firefox:
    Code:
    Video kann nicht abgespielt werden, weil die Datei beschädigt ist
    Ist sie aber definitiv nicht.
    Im Firefox ist bei Einstellungen/Anwendungen/ bei mp4 (und bei fast allen anderen Mediatypen) das XINE-Plugin eingestellt.

    Ich habe dann (wie weiss ich nicht mehr, war schwer zum Finden) folgende Seite gefunden:http://opensuse-guide.org/codecs.php
    Genau so habe ich es gemacht.
    Seitdem kann ich mit Dragon die Videos am Notebook anschauen.
    Die anderen Probleme sind geblieben, einschliesslich Firefox.

    Wer hat schon Erfahrung damit oder weiß einen Rat. Bei wem funktionierts mit Leap 42.1, insbesondere das Abspielen in Firefox?

  2. #2

    Default Re: Probleme mit MP4 Videos

    Schau mal ob libvdpau_va_gl1 installiert ist und entferne es.

    Für Xine muss das Paket libxine2-codecs installiert sein um alle Formate abspielen zu können.
    Das ist auf der Seite nicht mehr gelistet, vermutlich weil Kaffeine/Xine nicht mehr per Default installiert sind. Kaffeine sollte aber sowieso selber automatisch das Paket zu installieren versuchen...
    Last edited by wolfi323; 20-Feb-2016 at 09:38.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,798

    Default AW: Probleme mit MP4 Videos


  4. #4

    Default AW: Re: Probleme mit MP4 Videos

    Quote Originally Posted by wolfi323 View Post
    Schau mal ob libvdpau_va_gl1 installiert ist und entferne es.

    Für Xine muss das Paket libxine2-codecs installiert sein um alle Formate abspielen zu können.
    Das ist auf der Seite nicht mehr gelistet, vermutlich weil Kaffeine/Xine nicht mehr per Default installiert sind. Kaffeine sollte aber sowieso selber automatisch das Paket zu installieren versuchen...
    libvdpau_va_gl1 war installiert und habe es entfernt.
    libxine2-codecs war bereits installiert.

    Bei Kaffeine, XINE und Firefox hat sich nichts geändert.
    VLC spielt jetzt das Video normal ab.

    Ich schau jetzt noch den Hinweis von Sauerland an.

  5. #5

    Default AW: Probleme mit MP4 Videos

    Quote Originally Posted by Sauerland View Post
    Ich habe das jetzt nachvollzogen. Einziger Unterschied ist, dass ich das angebotene packman-Repo der Community benütze.

    Ich habe jetzt 2 neue Player drin - mpv und SMPlayer.

    Leider ist alles unverändert.

    Bei mpv und SMPlayer bekomme ich keinen Ton, aber das Video spielt normal ab.

    Ich versteh nicht, warum es in der 12.3 so einfach funktioniert hat?

  6. #6

    Default AW: Probleme mit MP4 Videos

    Ach so, hab ich vergessen.
    nach der Installation habe ich mich abgemeldet.
    Dabei hängt sich das System auf. Es ist nur noch der Notknopf möglich.
    Hatte ich schon mehrmals.
    Ich weiß aber nicht, wie man dazu UNterlagen erstellen kann?

  7. #7

    Default AW: Probleme mit MP4 Videos

    Folgendes Problem wir mir auch noch angezeigt:
    Code:
    sudo zypper dup --from "Packman Repository"
    root's password:
    Daten des Repositories laden ...
    Installierte Pakete lesen ...
    Distributionsaktualisierung berechnen ...
    
    Problem: libavcodec.so.57()(64bit) benötigt von mpv-0.15.0-38.6.x86_64 wird nirgends zur Verfügung gestellt
    Lösung 1: Deinstallation von mpv-0.15.0-38.3.x86_64
    Lösung 2: mpv-0.11.0-1.1.x86_64 aus dem ausgeschlossenen Repository installieren
    Lösung 3: mpv-0.15.0-38.6.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie a(b). [1/2/3/b] (b):
    Die Bibliothek taucht tatsächlich nirgends auf.

    @ Sauerland: Wie schaut das bei Dir aus?

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,798

    Default AW: Probleme mit MP4 Videos

    openSUSE 13.2:

    Code:
    zypper wp libavcodec.so.57
    Das Kommando 'what-provides' wurde durch 'search --provides --match-exact' ersetzt.
    Siehe 'help search' für alle verfügbaren Optionen.
    Daten des Repositories laden ...
    Installierte Pakete lesen ...
    
    S | Name               | Zusammenfassung      | Typ  
    --+--------------------+----------------------+------
    i | libavcodec57       | FFmpeg codec library | Paket
      | libavcodec57-32bit | FFmpeg codec library | Paket
    Code:
    zypper se -si libavcodec57
    Daten des Repositories laden ...
    Installierte Pakete lesen ...
    
    S | Name         | Typ   | Version  | Arch   | Repository    
    --+--------------+-------+----------+--------+---------------
    i | libavcodec57 | Paket | 3.0-61.2 | x86_64 | Packman-Mirror

  9. #9

    Default Re: Probleme mit MP4 Videos

    ffmpeg wurde kürzlich auf Version 3.0 upgedated, das mpv das du installieren willst benötigt eben diese.
    Kann sein dass es da zeitweilig eine Inkonsistenz im Repo/auf dem verwendeten Spiegelserver gab, also das neue mpv bereits vorhanden war aber das neue ffmpeg noch nicht.

    Ich würds also einfach nochmal probieren, und eventuell vorher mit "sudo zypper ref" den Repo-Cache auf deinem Rechner manuell aktualisieren...
    (ich hoffe, Auto-Aktualisierung ist für das Packman Repo eingeschaltet? )

  10. #10

    Default AW: Probleme mit MP4 Videos

    Heute kamen Updates zu Multimedipaketen.
    Seitdem laufen auch mpv und SMPlayer.
    (ich hoffe, Auto-Aktualisierung ist für das Packman Repo eingeschaltet?
    Die libavcodec.so.57 ist auch im Repo vorhanden und selbstverständliche habe ich das packman auf auto.

    Bleiben immer noch die Probleme mit XINE, Kaffeine und Firefox (Plugin).

    Kann sein dass es da zeitweilig eine Inkonsistenz im Repo/auf dem verwendeten Spiegelserver gab, also das neue mpv bereits vorhanden war aber das neue ffmpeg noch nicht.
    Da hab ich ja wirklich wieder Glück gehabt? Anscheinend zieh ich die Probleme magnetisch an.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •