Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Probleme mit MP4 Videos

  1. #11

    Default Re: Probleme mit MP4 Videos

    Quote Originally Posted by boogiewoogie View Post
    Bleiben immer noch die Probleme mit XINE, Kaffeine und Firefox (Plugin).
    Dann probier mal ein anderes Video-Ausgabegerät zu wählen.
    Für Xine kannst du das in der GUI (xine-ui) tun, für Kaffeine musst du die Konfiguration händisch ändern (~/.kde4/share/apps/kaffeine/xine-config), Option "video.driver". Letzteres ist auch für Xine möglich, die Datei wäre da ~/.xine/config.

    Probier z.B. mal "xshm".

    Andere Optionen die evtl. helfen könnten:
    Code:
    video.processing.ffmpeg_enable_vaapi:0
    video.processing.ffmpeg_direct_rendering:0
    video.processing.vaapi_mpeg_softdec:1
    Die letzte Option hat aber laut Kommentar im Configfile nur für MPEG 1 und 2 eine Auswirkung...

  2. #12

    Default AW: Re: Probleme mit MP4 Videos

    Quote Originally Posted by wolfi323 View Post
    Dann probier mal ein anderes Video-Ausgabegerät zu wählen.
    Für Xine kannst du das in der GUI (xine-ui) tun, für Kaffeine musst du die Konfiguration händisch ändern (~/.kde4/share/apps/kaffeine/xine-config), Option "video.driver". Letzteres ist auch für Xine möglich, die Datei wäre da ~/.xine/config.

    Probier z.B. mal "xshm".

    Andere Optionen die evtl. helfen könnten:
    Code:
    video.processing.ffmpeg_enable_vaapi:0
    video.processing.ffmpeg_direct_rendering:0
    video.processing.vaapi_mpeg_softdec:1
    Die letzte Option hat aber laut Kommentar im Configfile nur für MPEG 1 und 2 eine Auswirkung...
    Standard ist ja "auto"das nicht funktioniert.
    Ich habe xshm ausprobiert. Es funktionieren dann XINE und Kaffeine.
    Ausserdem funtionierts nur noch mit opengl und opengl2.
    Das ist bis hierher super.

    Leider hat es keine Auswirkungen auf die Firefoxanzeige.

    Auf meinem 13.2 Testsystem funktioniert das.
    Ich wollte mal die Unterschiede sehen zu Leap.

    13.2 Leap
    Firefox Plugin OpenH264-VideoCodec Firefox PluginOpenH264-VideoCodec
    gleiche Version
    nicht vorhanden XINE 1.0.2 (nicht von mir installiert)
    auch deaktivieren hilft nicht
    in ~/.mozilla/firefox/profil.default/pluginreg.dat
    nichts von XINE vorhanden
    in ~/.mozilla/firefox/profil.default/pluginreg.dat sind Einträge für Anwendungen vorhanden z.B.mp4.
    Die spiegeln sich im FF bei Einstellungen/Anwendung
    In /usr/lib64/browser-plugins keine xineplugin.so
    vorhanden
    In Leap ist unter /usr/lib64/browser-plugins eine xineplugin.so vorhanden.


    Trotz allem wird das Video in der 13.2 in Firefox sauber gestreamt!

    Ach ja. Ich habe noch ein Kommando gefunden: ffplay.
    Wenn ich in Leap 42.1 "ffplay internetadresse" angebe, dann wird auch ein Fenster aufgemacht und das Video sauber abgespielt, wie ich es in FF erwarten würde.
    Ich weiss allerdings nicht, wie und ob ffplay mit xine "verbandelt" ist.

  3. #13

    Default Re: Probleme mit MP4 Videos

    Quote Originally Posted by boogiewoogie View Post
    Standard ist ja "auto"das nicht funktioniert.
    Deswegen sagte ich ja dass du was anderes probieren sollst...

    Ich habe xshm ausprobiert. Es funktionieren dann XINE und Kaffeine.
    Ausserdem funtionierts nur noch mit opengl und opengl2.
    Ok, also wie vermutet liegt das Problem beim Versuch, Hardwaredecodierung zu verwenden.

    Leider hat es keine Auswirkungen auf die Firefoxanzeige.
    Tja, ich weiß im Moment leider nicht ob und wie man das Browser-Plugin konfigurieren kann, ich dachte eigentlich dass das die normalen Xine Einstellungen verwendet... Evtl. gibts eine Datei in ~/.mozilla/?


    Auf meinem 13.2 Testsystem funktioniert das.
    Laut deiner Tabelle hast du in 13.2 das Xine-Plugin ja gar nicht installiert.
    Also probier es auch in Leap zu deinstallieren, das Paket heißt xine-browser-plugin.

    Ansonsten machts auch einen Unterschied ob libxine2 vom Standard- oder vom Packman-Repo installiert ist.
    Das erstere hat keine VDPAU-Unterstützung, das letztere verwendet VDPAU bevorzugt.
    Wenn du also Probleme mit VDPAU hast, wird das Standardpaket funktionieren, Packmans aber nicht (ohne die Einstellungen zu ändern).
    Andererseits, wenn VDPAU funktioniert aber VAAPI nicht, ists genau umgekehrt.
    Also schau mal in YaST (über den Versionen-Tab) welche installiert ist, und wechsle zur anderen.

    Ach ja. Ich habe noch ein Kommando gefunden: ffplay.
    Wenn ich in Leap 42.1 "ffplay internetadresse" angebe, dann wird auch ein Fenster aufgemacht und das Video sauber abgespielt, wie ich es in FF erwarten würde.
    Ich weiss allerdings nicht, wie und ob ffplay mit xine "verbandelt" ist.
    Gar nicht.
    ffplay ist ein Kommandozeilenplayer der in ffmpeg enthalten ist.
    Last edited by wolfi323; 05-Mar-2016 at 09:28.

  4. #14

    Default AW: Re: Probleme mit MP4 Videos

    Quote Originally Posted by wolfi323 View Post
    Deswegen sagte ich ja dass du was anderes probieren sollst...
    Ich hab das nur noch mal zur Dokumentation geschrieben.

    Tja, ich weiß im Moment leider nicht ob und wie man das Browser-Plugin konfigurieren kann, ich dachte eigentlich dass das die normalen Xine Einstellungen verwendet... Evtl. gibts eine Datei in ~/.mozilla/?
    Hab ich geschrieben, dass es da ein pluginreg.dat gibt, wo die XINE Einträge drin sind, die den FF Anwendungseinträgen entsprechen.

    Laut deiner Tabelle hast du in 13.2 das Xine-Plugin ja gar nicht installiert.
    Also probier es auch in Leap zu deinstallieren, das Paket heißt xine-browser-plugin.
    Ich hatte zwar vorher schon mal das Plugin in FF deakiviert, habe aber das Paket auch noch mal deinstalliert.
    Keine Änderung.

    Ansonsten machts auch einen Unterschied ob libxine2 vom Standard- oder vom Packman-Repo installiert ist.
    Das erstere hat keine VDPAU-Unterstützung, das letztere verwendet VDPAU bevorzugt.
    Wenn du also Probleme mit VDPAU hast, wird das Standardpaket funktionieren, Packmans aber nicht (ohne die Einstellungen zu ändern).
    Andererseits, wenn VDPAU funktioniert aber VAAPI nicht, ists genau umgekehrt.
    Also schau mal in YaST (über den Versionen-Tab) welche installiert ist, und wechsle zur anderen.
    libxine2 war von packman installiert. Ich habe dann das vom Standard Repo genommen.
    Auch hier leider keine Änderung.



    Gar nicht.
    ffplay ist ein Kommandozeilenplayer der in ffmpeg enthalten ist.[/QUOTE]

  5. #15

    Default Re: Probleme mit MP4 Videos

    Quote Originally Posted by boogiewoogie View Post
    Hab ich geschrieben, dass es da ein pluginreg.dat gibt, wo die XINE Einträge drin sind, die den FF Anwendungseinträgen entsprechen.

    Ja schon, aber ich meinte die *Xine* Einstellungen die das Plugin verwendet.

    Ich hatte zwar vorher schon mal das Plugin in FF deakiviert, habe aber das Paket auch noch mal deinstalliert.
    Keine Änderung.
    Also wenns auf den einem System ohne Xine Plugin funktioniert, aber auf dem anderen nicht, dann fehlt da was anderes würd ich sagen.

    Firefox benutzt normalerweise gstreamer zur Videowiedergabe.
    Also schau ob du all Plugins von Packman installiert hast.

    Bzw. könnte es sich auch um ein Flashvideo handeln, dann brauchst du den flash-player.

  6. #16

    Default AW: Probleme mit MP4 Videos

    Es ist wie verhext.
    Heute habe ich mal einfach so wieder probiert das Video mit FF abzuspielen - und er tut's!
    Warum auch immer.
    Das Ganze ohne XINE Plugin.
    Wohler wäre mir,wenn ich wüsste, warum und wie es jetzt funktioniert.
    Langsam kann ich mich wieder meinen eigentlichen Arbeiten widmen.

  7. #17

    Default Re: Probleme mit MP4 Videos

    Hallo Wolfi,
    ich hatte bis eben mit Firefox das gleiche Problem. Dann habe ich die xine-codecs installiert und firefox spielt Videos ab.

    Gruß fanifeey

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •