Results 1 to 10 of 10

Thread: Drad-and-drop to Firefox

  1. #1
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Drad-and-drop to Firefox

    Hi

    I have strange behavior in Firefox.
    When I try to drag file (e.g. pdf, mp4 html) into Firefox, it say in the main window 'Server not found' and some crazy Japanese characters. In the address bar I have http:// and afterwards the same Japanese characters.

    When I was using OpenSuse 13.2 it work normally - I could drag and paste any file Firefox recognized.

    any help, suggestion?
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Drad-and-drop to Firefox

    Hi, seems a Plasma 5 related issue, I can reproduce it in a VM with a standard KDE install.
    Drag 'n Drop works fine on my main Gnome install though.
    Maybe you can check it out by logging in to IceWM...
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Drad-and-drop to Firefox

    It's the same in IceWM - error + Japanese characters
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Drag-and-drop to Firefox

    Quote Originally Posted by GazetaCypr View Post
    It's the same in IceWM - error + Japanese characters
    Interestingly, I can confirm your finding logging in with IceWM on the VM "KDE" install: same error and "Japanese" characters.
    BUT logging in IceWM in my main "Gnome" install, everything works as expected.
    So it seems that the culprit is hidden in some difference between the "KDE" and "Gnome" standard install, not in the WM proper.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Drad-and-drop to Firefox

    SDDM problem maybe???????? OR QT5??

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Drag-and-drop to Firefox

    Tried to update Firefox to 44.0.2 to no effect.
    Tried to remove mozilla-kde4-integration (this is NOT installed in Gnome, of course) to no effect.
    Looks like some quirks happening when interpreting pairs of UTF-8 characters as single UTF-16 characters, but I could not find a pattern so far.
    Opening the test files in Firefox by its "Open File" command works as expected, so it seems just a "Drag'n'Drop" problem.
    BTW LibreOffice tells me that the strange characters are "Chinese-simplified", not really Japanese (don't call on me to assess this )
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  7. #7
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,216

    Default Re: Drag-and-drop to Firefox

    Quote Originally Posted by OrsoBruno View Post
    Tried to update Firefox to 44.0.2 to no effect.
    Tried to remove mozilla-kde4-integration (this is NOT installed in Gnome, of course) to no effect.
    Looks like some quirks happening when interpreting pairs of UTF-8 characters as single UTF-16 characters, but I could not find a pattern so far.
    Opening the test files in Firefox by its "Open File" command works as expected, so it seems just a "Drag'n'Drop" problem.
    BTW LibreOffice tells me that the strange characters are "Chinese-simplified", not really Japanese (don't call on me to assess this )

    I think you've maybe been bitten by this Qt bug:

    https://bugreports.qt.io/browse/QTBUG-49947 (Dropping text/urilist over browser windows stop working.)
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  8. #8
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Drag-and-drop to Firefox

    Quote Originally Posted by tannington View Post
    I think you've maybe been bitten by this Qt bug:

    https://bugreports.qt.io/browse/QTBUG-49947 (Dropping text/urilist over browser windows stop working.)
    Yes, Paul, the symptoms appear to be the same and might explain why dragging from a GTK3 File manager (Nautilus on Gnome) works fine.
    Maybe the OP is willing to join that bug report.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  9. #9
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Drad-and-drop to Firefox

    Where shall we then turn to with this problem?
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  10. #10
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Drad-and-drop to Firefox

    Quote Originally Posted by GazetaCypr View Post
    Where shall we then turn to with this problem?
    As said, you may join this bug report with a "me too" comment: https://bugreports.qt.io/browse/QTBUG-49947
    On my side, I'm not a regular KDE user and won't follow that bug any further.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •