Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Help Please Cannot Start KDE Desktop

  1. #11

    Default Re: Help Please Cannot Start KDE Desktop

    Hi Wolfi323,
    I didn't delete Xorg.conf.d only moved it to Xorg.conf.bak so I can restore it no problem. There is no Xorg.conf in the directory which is strange.

    Sadly I do not get a boot menu at present so cannot chose any options. I could run a recovery CD but since I have a running system there doesn't seem to be much point

    Will restore Xorg.conf.d and await further instructions.

  2. #12

    Default Re: Help Please Cannot Start KDE Desktop

    Quote Originally Posted by Budgie2 View Post
    I didn't delete Xorg.conf.d only moved it to Xorg.conf.bak so I can restore it no problem.
    Good.

    There is no Xorg.conf in the directory which is strange.
    No, that's not strange.
    This normally is not used any more since years.

    But it is still respected when it exists, and it might have caused Xorg failing to start (e.g. if it specifies a not installed or not working driver).

    Sadly I do not get a boot menu at present so cannot chose any options.
    Hm?
    Try to delete the file /boot/grub2/grubenv, this could cause a missing boot menu on 13.2 (or earlier) systems using btrfs.

    If that doesn't help, try to edit /boot/grub2/grub.cfg directly and add "x11failsafe" to the boot entries.
    Or edit /etc/default/grub and add "x11failsafe" there to the GRUB_CMDLINE_LINUX_DEFAULT line, and run "grub2-mkconfig -o /boot/grub2/grub.cfg" to regenerate the boot menu.

  3. #13

    Default Re: Help Please Cannot Start KDE Desktop

    Hi Wolfi323,
    Sorry about the long delays. Rebooting takes more than 5 minutes due to strange IBM RAID card which causes delay.

    Deleting grubenv made no difference.
    Dire warnings not to edit grub.cfg directly.
    I therefore added x11failsafe to command line default and rebuilt the boot menu.
    Trying reboot now.
    Meanwhile how can I force use of the failsafe mode because it is all there in the grub file. I can use Yast (in clunky mode!!!) to edit it rather than using vim on grub file.

    BTW how much time do you have as I believe you are in different time zone. I am in UK and it is 19:37.
    Regards,
    Budgie2

  4. #14

    Default Re: Help Please Cannot Start KDE Desktop

    Quote Originally Posted by Budgie2 View Post
    Deleting grubenv made no difference.
    Hm, strange.
    Did you maybe set the GRUB_TIMEOUT to 0 by chance?

    Dire warnings not to edit grub.cfg directly.
    Yes, because they will be overwritten. But it would be ok for a quick test.

    Meanwhile how can I force use of the failsafe mode because it is all there in the grub file. I can use Yast (in clunky mode!!!) to edit it rather than using vim on grub file.
    Well, you can just as well use YaST->System->Boot Loader to add the "x11failsafe" option. But that does the same as editing /etc/default/grub and running "grub2-mkconfig".

    You can also try to add "nomodeset" in addition or instead "x11failsafe" to see if it helps.

    BTW how much time do you have as I believe you are in different time zone. I am in UK and it is 19:37.
    It's 21:17 here currently, so I do have a few hours left this evening...
    Last edited by wolfi323; 17-Feb-2016 at 13:24.

  5. #15

    Default Re: Help Please Cannot Start KDE Desktop

    Ok and thanks.
    Well the reboot was less successful than before because now I cannot get to console. The start up script scrolls and stops at:-

    Code:
    [OK] Started Locale Service
    [FAILED] Failed to start X Display Manager
    ''See systemctl status display-manager.service'' for details.
    [OK] Started SuSEfirewall2 phase 2
    [OK] Reached target Multi-User System.
    [OK] Reached target Graphical Interface.
    If I press down arrow I get three small green blobs containing question marks in middle of black screen.
    If I press it again I get the scrolling down to the above lines.

    Cannot start yast any longer. Is it time to run the installation DVD and see if the graphics come up on that and then aborting or running recovery from DVD?

  6. #16

    Default Re: Help Please Cannot Start KDE Desktop

    Quote Originally Posted by Budgie2 View Post
    Ok and thanks.
    Well the reboot was less successful than before because now I cannot get to console.
    You should be able to login after pressing Ctrl+Alt+F1.

    The start up script scrolls and stops at:-

    Code:
    [OK] Started Locale Service
    [FAILED] Failed to start X Display Manager
    ''See systemctl status display-manager.service'' for details.
    So it fails to start completely now.
    What exactly did you change? Adding x11failsafe?
    Then maybe the file /etc/X11/xorg.conf.install does not exist?

    What does "systemctl status display-manager" say?

    Maybe it helps if you just add "nomodeset"?

    Also I would suggest to run "mkinitrd". Maybe something went wrong with that the last time, this could definitely cause graphics driver problems.
    Are you using a separate /boot? Maybe this was/is full...

    If I press down arrow I get three small green blobs containing question marks in middle of black screen.
    That's plymouth the boot splash in the text mode version (but with a wrong character set).

    Cannot start yast any longer. Is it time to run the installation DVD and see if the graphics come up on that and then aborting or running recovery from DVD?
    Well, in worst case you should get to a graphical system if you uninstall the nvidia driver I suppose.
    But please save the /var/log/Xorg.0.log and Xorg.0.log.old somewhere first so that we can see what the problem was.

    The installation DVD should definitely come up with graphics, unless your hardware is broken.
    But I thought we want to fix your system?
    Last edited by wolfi323; 17-Feb-2016 at 14:08.

  7. #17

    Default Re: Help Please Cannot Start KDE Desktop

    Hi Wolfi323,
    The Ctrl + Alt+ F1 worked.
    Yes I do want to fix system but thought I should check hardware.
    You have given me more stuff to try which will take a while.
    Will call it a day now and start again in the morning.
    Many thanks once more
    Regards,
    Budgie2

  8. #18

    Default Re: Help Please Cannot Start KDE Desktop

    Hi Wolfi323,
    Tried just about everything with no luck so un-installed the nvidia drivers and got back to 1024 x 768 display mode with graphics OK.
    Reinstalled the nvidia drivers and no graphics again.

    I have un-installed nvidia drivers pending somebody sorting them out. Strange that nobody else has posted this problem. Meanwhile where should I post the Xorg.0.log file for you to look at?

    Regards,
    Budgie2

  9. #19

    Default Re: Help Please Cannot Start KDE Desktop

    Quote Originally Posted by Budgie2 View Post
    Tried just about everything with no luck so un-installed the nvidia drivers and got back to 1024 x 768 display mode with graphics OK.
    Reinstalled the nvidia drivers and no graphics again.
    Ok. The Xorg log from both cases would be interesting I think.

    I have un-installed nvidia drivers pending somebody sorting them out. Strange that nobody else has posted this problem.
    Well, I suppose the nvidia drivers do work for most people.
    I doubt there is a general problem with the current versions, or there would have been a lot of people complaining already.

    Meanwhile where should I post the Xorg.0.log file for you to look at?
    E.g. http://susepaste.org

  10. #20
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Help Please Cannot Start KDE Desktop

    Which flavour of NVIDIA are you installing and what is the card?

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •