Results 1 to 2 of 2

Thread: System Stalled and Now Cannot Start Desktop

  1. #1

    Default System Stalled and Now Cannot Start Desktop

    Running 13.2 with KDE desktop and was in process of setting up an NFS share as a client using Yast. Sadly the system froze and nothing worked so I had to do a Alt+Sys rq REISUB to reboot. When system started up again it went to console. After logging in I tried to start desktop with startx and this failed. I have a message on the machine which I shall try and copy as follows:--

    xinit failed. /usr/bin/Xorg is not set setuid, maybe that's the reason?
    If so either use a display manager (strongly recommended) or adjust /etc/permissions/.local 
    and run "chkstat --system --set" afterwards
    Grateful for some guidance please before I mess up system more!!!

  2. #2
    Join Date
    Nov 2013
    Kamloops, BC, Canada

    Default Re: System Stalled and Now Cannot Start Desktop

    rpm -a --setugids --setperms
    then do:
    chkstat --system
    This will check & reset systems permissions in system mode to what is set in /etc/permissions/security
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    If I helped you, consider clicking the Star at the bottom left of my post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts