Results 1 to 4 of 4

Thread: SSH login with ksshaskpass: Cancel does not work

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    545

    Default SSH login with ksshaskpass: Cancel does not work

    Executing a command with ssh open ksshaskpass. However it keeps popping up after clicking cancel.

    After 3 tries, With either OK or Cancel the returned error message does not make sense for most end users.
    Code:
    ksshaskpass(12662)/kdeui (Wallet): The kwalletd service has been disabled 
    ksshaskpass(12662)/kdeui (Wallet): The kwalletd service has been disabled 
    ksshaskpass(12662)/kdeui (Wallet): The kwalletd service has been disabled 
    ksshaskpass(12662)/kdeui (Wallet): The kwalletd service has been disabled 
    ksshaskpass(12662)/kdeui (Wallet): The kwalletd service has been disabled 
    ksshaskpass(12662)/kdeui (Wallet): The kwalletd service has been disabled 
    Permission denied (publickey, keyboard-interactive)
    So in affect, Cancel is indistinguishable from Ok.

    Clicking cancel it should not ask for the password again, but just close (without any error message).
    Perhaps this is a bug with ksshaskpass.

    Using the standard KDE that comes with openSUSE 13.2

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,492
    Blog Entries
    3

    Default Re: SSH login with ksshaskpass: Cancel does not work

    I'm not sure that I understand the issue.

    "ksshaskpass" does two things:
    1: it requests a password for the user on behalf of openssh;
    2: it offers to save that password in kdewallet.

    If kdewallet is disabled, I would expect that to interfere with the second of those. But it is still supposed to request the password that openssh wants.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    545

    Default Re: SSH login with ksshaskpass: Cancel does not work

    The problem is clicking cancel does not work. It is the same as clicking OK without entering a password.
    Cancel is cancel and it should close and not pop up again. After 3 times without supply a password the error message I posted in OT was shown.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,492
    Blog Entries
    3

    Default Re: SSH login with ksshaskpass: Cancel does not work

    Quote Originally Posted by DJViking View Post
    The problem is clicking cancel does not work. It is the same as clicking OK without entering a password.
    Cancel is cancel and it should close and not pop up again. After 3 times without supply a password the error message I posted in OT was shown.
    I'm guessing that "Cancel" works perfectly.

    That is to say, on "Cancel", ksshaskpass goes away and does not pop up again.

    But there's still a running openssh process. And it still wants that password. So it starts a new "ksshaskpass" process to request it.

    I'm not sure what you are doing. For me, the "ksshaskpass" shows up when I use "ssh-add" to add a public key to ssh-agent, as in
    Code:
    ssh-add keyid < /dev/null
    If I don't want to give the key, then I don't run "ssh-add", or I run that command without the I/O redirection so that it can prompt me at the terminal.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •