Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: OpenSuse Leap 42.1 does not boot

  1. #1

    Default OpenSuse Leap 42.1 does not boot

    I updated my Laptop from OS 13.2 to Leap 42.1 (by 'update', not 'install'. Everything worked well but I wondered why the splash screen still showed OpenSUSE 13.1 rather than Leap 42.1.
    This made me look in the Boot Loader via Yast.

    I typed 'OpenSUSE Leap 42.1 in the boot loader options, but that had no effect. So I decided to check what I had on my desktop (also working with Leap 42.1 Installed but not with 'update')

    After I changed the boot loader location to 'Boot from Root Partition' only and 'set active Flag in Partition Table for Boot Partition' my laptop no longer boots at all!!

    I had naively assumed if anything went wrong, I could always boot from a rescue CD. But no! The boot sequence hangs at the word 'GRUB ' and that's it.

    Changing the boot sequence in the BIOS seems to have no effect?

    What can I do now? Does anyone have any ideas?

  2. #2

    Default Re: OpenSuse Leap 42.1 does not boot

    Quote Originally Posted by hnimmo View Post

    I had naively assumed if anything went wrong, I could always boot from a rescue CD. But no! The boot sequence hangs at the word 'GRUB ' and that's it.


    Correction:

    I can boot from system rescue CD. But where are the data I need to reset again, to what?

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: OpenSuse Leap 42.1 does not boot

    Totally unclear......

    How was 13.1 or 13.2 (which??) installed? legacy boot or EFI boot??

    I suspect you had a legacy boot using the MBR configuration and the boot flag got moved. But that is a pure guess because you did not tell us how things were set up?

  4. #4

    Default Re: OpenSuse Leap 42.1 does not boot

    Quote Originally Posted by gogalthorp View Post
    Totally unclear......

    How was 13.1 or 13.2 (which??) installed? legacy boot or EFI boot??

    I suspect you had a legacy boot using the MBR configuration and the boot flag got moved. But that is a pure guess because you did not tell us how things were set up?
    Yep. Those are the parameters I fiddled with (MBR -> root, and boot flag set). I guess, I was expecting the boot loader configurator to stop me, if I did something risky, impermissible, forbidden, stupid!

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: OpenSuse Leap 42.1 does not boot

    The choice to shoot your foot is yours to make this is not a nanny operating system it does what you tell it to do.

    So I guess the original was a legacy install using what in the MBR? generic code or grub MBR code?


    Note one thing that surely will mess things up is to mix boot methods ie EFI and MBR

    If this is MBR based boot it is not too hard to fix but you do a chroot and reinstall grub2

    First let us be totally sure what you have is this a dual boot with Windows?

    It would help if you could show use fdisk -l if you can get some Linux to boot

  6. #6

    Default Re: OpenSuse Leap 42.1 does not boot

    Quote Originally Posted by gogalthorp View Post
    The choice to shoot your foot is yours to make this is not a nanny operating system it does what you tell it to do.

    So I guess the original was a legacy install using what in the MBR? generic code or grub MBR code?


    Note one thing that surely will mess things up is to mix boot methods ie EFI and MBR

    If this is MBR based boot it is not too hard to fix but you do a chroot and reinstall grub2

    First let us be totally sure what you have is this a dual boot with Windows?

    It would help if you could show use fdisk -l if you can get some Linux to boot
    ....and often, it is so good, it warns you when you are about to do something stupid...but not always!

    It was using MBR grub2 code. Yes, it is a dual boot with Windows (where could I get a laptop without Windows pre-installed. But then one doesn't deinstall Windows, at best it just gets a little bit of space to keep it happy )

    How about this?
    Code:
    Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0x92e61106
    
    Device     Boot      Start        End    Sectors   Size Id Type
    /dev/sda1             2048  704500491  704498444   336G  7 HPFS/NTFS/exFAT
    /dev/sda2       1912008704 1953521663   41512960  19.8G 27 Hidden NTFS WinRE
    /dev/sda3  *     704501760 1912008703 1207506944 575.8G  f W95 Ext'd (LBA)
    /dev/sda5        704503808  708708351    4204544     2G 82 Linux swap / Solaris
    /dev/sda6        708710400  750653439   41943040    20G 83 Linux
    /dev/sda7        750655488 1912008703 1161353216 553.8G 83 Linux
    
    Partition table entries are not in disk order.

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: OpenSuse Leap 42.1 does not boot

    Sure you can wipe Windows you don't have to have it but you do have to actively chose that.

    ok there are two way this is done one is to put grub in the MBR the other is to put generic boot code in the MBR. With generic you need to have a boot flag. This way is a bit more Windows friendly in that Windows lso use generic code and at most will mess things by changing the boot flag with some updates.

    Putting grub in MBR does not require a boot flag since grub knows wher you put the /boot directory and can go straight there.


    So you need to do a chroot and reinstall grub

    Code:
    # mount /dev/sda6 /mnt 
    # for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done
    
    Enter chroot mode:
    # chroot /mnt
    # grub2-install 
    # grub2-mkconfig -o /boot/grub2/grub.cfg

  8. #8

    Default Re: OpenSuse Leap 42.1 does not boot

    Quote Originally Posted by gogalthorp View Post
    Sure you can wipe Windows you don't have to have it but you do have to actively chose that.

    ok there are two way this is done one is to put grub in the MBR the other is to put generic boot code in the MBR. With generic you need to have a boot flag. This way is a bit more Windows friendly in that Windows lso use generic code and at most will mess things by changing the boot flag with some updates.

    Putting grub in MBR does not require a boot flag since grub knows wher you put the /boot directory and can go straight there.


    So you need to do a chroot and reinstall grub

    Code:
    # mount /dev/sda6 /mnt 
    # for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done
    
    Enter chroot mode:
    # chroot /mnt
    # grub2-install 
    # grub2-mkconfig -o /boot/grub2/grub.cfg
    So far so good. But at the step grub2-install, I get the message: "error: install device isn't specified"

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,768

    Default Re: OpenSuse Leap 42.1 does not boot

    oops should be

    grub-install /dev/sda

    copied that code did no notice the missing parameter

  10. #10

    Default Re: OpenSuse Leap 42.1 does not boot

    Quote Originally Posted by gogalthorp View Post
    oops should be

    grub-install /dev/sda

    copied that code did no notice the missing parameter
    Thanks! That works a treat. Take a big kiss!

    By the way, I assumed you meant grub2-install. And the Yast boot loader still had the changed (wrong) parameters, so I had to change them back there before it worked properly again.

    But now back to my original question, the reason why I fiddled around with the boot loader in the first place:

    Why does the splash screen still say "booting openSUSE 13.1" instead of Leap 42.1?
    What needs to be lined up now?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •