Results 1 to 3 of 3

Thread: ibus preferences not sticking

  1. #1

    Default ibus preferences not sticking

    Testing on 2 pc's both with :

    Leap42.1 KDE with latest updates

    After installing additional language chinese via yast and adding input method
    google-pinyin does not stick and only the default EN is shown in ibus settings or via tray icon.
    The .bashrc was also updated according to the pop up when starting the ibus deamon.
    Anything else I could try ?


    On another machine the same setup the google-pinyin or intelligent pinyin methods survive a restart, but
    often the trayicon showing EN or CN disappears and may or may not reappear after a system reboot.
    Any settings to tweak in this case ?

    Thanks for any ideas.

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,587

    Default Re: ibus preferences not sticking

    Quote Originally Posted by Darkblue2 View Post
    Testing on 2 pc's both with :

    Leap42.1 KDE with latest updates

    After installing additional language chinese via yast and adding input method
    google-pinyin does not stick and only the default EN is shown in ibus settings or via tray icon.
    The .bashrc was also updated according to the pop up when starting the ibus deamon.
    Anything else I could try ?


    On another machine the same setup the google-pinyin or intelligent pinyin methods survive a restart, but
    often the trayicon showing EN or CN disappears and may or may not reappear after a system reboot.
    Any settings to tweak in this case ?

    Thanks for any ideas.
    sorry - not sure why settings are not sticking for you.
    On my leap installation using ibus>anthy it works fine and settings stick.

    You could trying using fcitx instead of ibus, which seems to have better KDE integration anyway. It does have an annoying blank xembed icon in the system tray (along with its usual keyboard icon - but you can hide that - and it has been fixed in the upcoming plasma 5.6)

    What version of plasma are you using?
    If you want to stick with ibus then perhaps try updating plasma from the frameworks 5 repo. While the system tray is still quite flaky, it is much improved over earlier versions of plasma - so that may solve your disappearing icons.

  3. #3

    Default Re: ibus preferences not sticking

    Thank you for your reply, I now switched both systems to fcitx and this
    this seems to work much better than ibus .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •