Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: YAST modules not loading in GUI

  1. #1
    Join Date
    Feb 2016
    Location
    North Carolina
    Posts
    18

    Default YAST modules not loading in GUI

    So I am a complete and utter noob when it comes to anything linux. I have been using OpenSUSE stably for about a month now and it has gone 100x better than any of my other linux experiences. However, I have now encountered my first problem. I am thankful though, because I want to learn my way around and be able to troubleshoot any future issues. So, let me explain to you my situation:

    I decided to update today, so I went to the package updater and installed all of those. Then I went to the terminal and executed "sudo zypper update," which took me to OpenSUSE Leap. I am fine with this upgrade, as it seems much smoother for some unknown reason. Though my adventurous self was not done, so I wanted to finally install the drivers for my NVIDIA GTX 650. I went to the following page:
    https://en.opensuse.org/SDB:NVIDIA_d...NVIDIA_drivers

    I opened YAST and clicked the Software Repositories module, but it simply tries loading it for a few seconds and then nothing. No error message or anything. I went into terminal and it seems to launch just fine through there. I have also found that my one-click installs do not work anymore. Instead of it simply opening in YAST after the download, nothing happens. Any help will be appreciated. I will be heading to bed at the moment, but I will be actively on here tomorrow. Ask me any followup questions and I will do my best to answer them.

    Regards,
    tstor

  2. #2

    Default Re: YAST modules not loading in GUI

    Yes, openSUSE is the best distro. I'm glad you found out before wasting
    time on others. Well done on being willing to learn.

    Simple starting point:

    /var/log/YaST2/y2log

    In particular, look for anything written during one of your tests, using
    something like the following in a terminal with a big scrollback buffer,
    or using 'tee', or something. I'll show a couple ways, all mutually
    exclusive, and all assuming you are a non-root user (thus the use of 'sudo'):

    Code:
    #Follow new lines added to the files so you can then test YaST2 and see
    #what is written to its log file.
    
    sudo tail -f /var/log/YaST2/y2log
    
    
    
    #In case your konsole/gnome-terminal/xterm scrollback is small, see
    #that output and also write it to a new file for you to review later.
    #Look at /tmp/yast-testing.log for the specific output from your test.
    
    sudo tail -f /var/log/YaST2/y2log | tee -a /tmp/yast-testing.log
    Regarding one-click installs, that may be something broken in your
    browser, or it may be related since it basically uses a lot of the same
    things you mentioned are broken. Hard to say, and I'm no expert on
    troubleshooting broken YaST stuff, but the log is very verbose and often
    helps.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...
    Last edited by hcvv; 09-Feb-2016 at 14:50. Reason: repaired CODE tag

  3. #3

    Default Re: YAST modules not loading in GUI

    Yes, openSUSE is the best distro. I'm glad you found out before wasting
    time on others. Well done on being willing to learn.

    Simple starting point:

    /var/log/YaST2/y2log

    In particular, look for anything written during one of your tests, using
    something like the following in a terminal with a big scrollback buffer,
    or using 'tee', or something. I'll show a couple ways, all mutually
    exclusive, and all assuming you are a non-root user (thus the use of 'sudo'):

    [CODE[
    #Follow new lines added to the files so you can then test YaST2 and see
    #what is written to its log file.

    sudo tail -f /var/log/YaST2/y2log



    #In case your konsole/gnome-terminal/xterm scrollback is small, see
    #that output and also write it to a new file for you to review later.
    #Look at /tmp/yast-testing.log for the specific output from your test.

    sudo tail -f /var/log/YaST2/y2log | tee -a /tmp/yast-testing.log
    [/CODE]

    Regarding one-click installs, that may be something broken in your
    browser, or it may be related since it basically uses a lot of the same
    things you mentioned are broken. Hard to say, and I'm no expert on
    troubleshooting broken YaST stuff, but the log is very verbose and often
    helps.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,330
    Blog Entries
    3

    Default Re: YAST modules not loading in GUI

    Quote Originally Posted by tstor View Post
    Then I went to the terminal and executed "sudo zypper update," which took me to OpenSUSE Leap.
    As far as I know, the recommendation is to use "sudo zypper dup" (distribution upgrade). Possibly you now have a mixture of 13.2 and Leap 42.1 software, resulting in the problem that you are seeing.

    I am assuming that you switched to the 42.1 repos, though you did not mention that.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Feb 2016
    Location
    North Carolina
    Posts
    18

    Default Re: YAST modules not loading in GUI

    Quote Originally Posted by ab View Post
    Simple starting point:

    /var/log/YaST2/y2log

    In particular, look for anything written during one of your tests, using
    something like the following in a terminal with a big scrollback buffer,
    or using 'tee', or something. I'll show a couple ways, all mutually
    exclusive, and all assuming you are a non-root user (thus the use of 'sudo'):

    [CODE[
    #Follow new lines added to the files so you can then test YaST2 and see
    #what is written to its log file.

    sudo tail -f /var/log/YaST2/y2log



    #In case your konsole/gnome-terminal/xterm scrollback is small, see
    #that output and also write it to a new file for you to review later.
    #Look at /tmp/yast-testing.log for the specific output from your test.

    sudo tail -f /var/log/YaST2/y2log | tee -a /tmp/yast-testing.log
    [/CODE]
    Okay, so I tried to access the YaST2 folder, but I do not have permission. How would I go about gaining permission to view the content? Apparently it is not as simple as I was expecting, as I have went to 5 different website and received 5 different (equally as confusing) answers. I did, however, run the line you gave me consisting of "sudo tail -f /var/log/YaST2/y2log." It gave me the following output:

    Code:
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YSettings.cc(setLocaleDir):147 localeDir is now locked.
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YPath.cc(YPath):49 Given filename: libyui-qt.so.7
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YSettings.cc(progDir):73 progDir: "/usr/share/YaST2"
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YPath.cc(YPath):65 Preferring subdir: /usr/share/YaST2
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YPath.cc(YPath):66 Subdir given with filename: 
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YPath.cc(YPath):67 Looking for: libyui-qt.so.7
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YPath.cc(lsDir):138 Looking in /usr/lib64/yui
    2016-02-09 06:50:35 <1> linux.suse(3058) [ui] YPath.cc(YPath):121 Could NOT find libyui-qt.so.7 by looking recursive inside /usr/lib64/yui
    2016-02-09 06:50:35 <3> linux.suse(3058) [ui] YUIPlugin.cc(YUIPlugin):50 Could not load UI plugin "qt": libyui-qt.so.7: cannot open shared object file: No such file or directory
    2016-02-09 06:50:35 <2> linux.suse(3058) [ui] YUILoader.cc(loadPlugin):136     THROW:    Couldn't load plug-in qt
    I am not sure how to decipher this message.

    Quote Originally Posted by nrickert View Post
    As far as I know, the recommendation is to use "sudo zypper dup" (distribution upgrade). Possibly you now have a mixture of 13.2 and Leap 42.1 software, resulting in the problem that you are seeing.

    I am assuming that you switched to the 42.1 repos, though you did not mention that.
    Alright, so I went into the terminal and ran the line "sudo yast" and I got access to the software repositories module (will not open in GUI). I do have a majority 13.2 repo selection. Specifically, I can see the following:
    Code:
    │Priority     │Enabled│Autorefresh│Name                        ││ 
      │ 99 (Default)│   x   │     x     │openSUSE-13.2-Update-Non-Oss││ 
      │ 99 (Default)│   x   │     x     │openSUSE-13.2-Oss           ││ 
      │ 99 (Default)│   x   │     x     │mono-project                ││ 
      │ 99 (Default)│   x   │     x     │openSUSE-13.2-Update        ││ 
      │ 99 (Default)│   x   │     x     │openSUSE-13.2-Non-Oss       ││ 
      │ 99 (Default)│   x   │     x     │openSUSE:Leap:42.1          ││

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,330
    Blog Entries
    3

    Default Re: YAST modules not loading in GUI

    At this stage, you should either change them to all 42.1 or to all 13.2. A mixture is going to cause problems. And maybe disable that mono repo. Then use "zypper dup" to bring everything to a consistent version. You can look into getting the right repo for mono and updating that after all else is working.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Feb 2016
    Location
    North Carolina
    Posts
    18

    Default Re: YAST modules not loading in GUI

    Quote Originally Posted by nrickert View Post
    At this stage, you should either change them to all 42.1 or to all 13.2. A mixture is going to cause problems. And maybe disable that mono repo. Then use "zypper dup" to bring everything to a consistent version. You can look into getting the right repo for mono and updating that after all else is working.
    How would I do this? I was reading on the OpenSUSE wiki that adding a repo in the terminal can be done through the command "zypper ar -f <URL> <alias>." I noticed that the repos can be found here:
    https://en.opensuse.org/Package_repo...l_Repositories

    So, for example, if I wanted to add the OSS repo, would it look something like "zypper ar -f <http://download.opensuse.org/distribution/leap/42.1/repo/oss/> <openSUSE-42.1-Oss>"?

    Also, how would I remove a repo?

  8. #8
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,804

    Default Re: YAST modules not loading in GUI

    Quote Originally Posted by tstor View Post
    How would I do this? I was reading on the OpenSUSE wiki that adding a repo in the terminal can be done through the command "zypper ar -f <URL> <alias>." I noticed that the repos can be found here:
    https://en.opensuse.org/Package_repo...l_Repositories

    So, for example, if I wanted to add the OSS repo, would it look something like "zypper ar -f <http://download.opensuse.org/distribution/leap/42.1/repo/oss/> <openSUSE-42.1-Oss>"?

    Also, how would I remove a repo?

    To remove all repos for OS 13.2:
    Code:
    su -
    (type root password)
    zypper repos
    You get a list of all repositories in your system; note down the numbers of those marked 13.2; then:
    Code:
    zypper removerepo <all the numbers marked above>
    Then if you have already your 42.1 repos listed, type:
    Code:
    zypper ref
    zypper dup
    After that you should truly have a Leap updated system and the "new" Yast should work, unless there are other problems...
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Beta

  9. #9
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,804

    Default Re: YAST modules not loading in GUI

    Sorry for missing part of your question, you have to type in URI and alias WITHOUT <> brackets... e.g.
    Code:
    zypper ar -f http://download.opensuse.org/distribution/leap/42.1/repo/oss/ openSUSE-42.1-Oss
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Beta

  10. #10
    Join Date
    Feb 2016
    Location
    North Carolina
    Posts
    18

    Default Re: YAST modules not loading in GUI

    Quote Originally Posted by OrsoBruno View Post
    To remove all repos for OS 13.2:
    Code:
    su -
    (type root password)
    zypper repos
    You get a list of all repositories in your system; note down the numbers of those marked 13.2; then:
    Code:
    zypper removerepo <all the numbers marked above>
    Then if you have already your 42.1 repos listed, type:
    Code:
    zypper ref
    zypper dup
    After that you should truly have a Leap updated system and the "new" Yast should work, unless there are other problems...
    I have followed your instructions and now the only repo remaining is openSUSE:Leap:42.1. So which repos do I need to add? I assume I would add the following:
    OSS (http://download.opensuse.org/distrib...42.1/repo/oss/)
    Non-OSS (http://download.opensuse.org/distrib.../repo/non-oss/)
    Update (http://download.opensuse.org/update/leap/42.1/oss/)
    Update Non-OSS (http://download.opensuse.org/update/leap/42.1/non-oss/)

    Would those be the repos I need to add? If they are, then would those be the correct URLs to use when adding the repos?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •