Results 1 to 9 of 9

Thread: VLC not playing MP4

  1. #1

    Exclamation VLC not playing MP4

    Hi guys,

    I am started just today with a new fresh installation of Leap with Gnome DE. Everything seems ok and hopefully my hopping is now over, I am tired.
    The only problem I have is VLC playing MP4. Actually I can play other videos, like AVI but MP4..no way.

    I installed all the codecs according to http://opensuse-guide.org/codecs.php from the terminal.
    I have also changed VLC Video Output setting to X11, at no avail.

    When I start those MP4's with Totem they do not play too and Gnome Software pops out saying that some Gstreamer codecs are needed.
    The same MP4's played with no problems on Xubuntu, Fedora, etc so those files should be ok.

    I am kind of stuck now.

    Thanks in advance for your help.

  2. #2

    Default Re: VLC not playing MP4

    rpm -qa | grep vlc

    returns:

    phonon4qt5-backend-vlc-0.8.2-2.3.x86_64
    libvlccore8-2.2.2-1.1.x86_64
    vlc-2.2.2-1.1.x86_64
    vlc-noX-2.2.2-1.1.x86_64
    libvlc5-2.2.2-1.1.x86_64
    vlc-qt-2.2.2-1.1.x86_64
    vlc-codecs-2.2.2-1.1.x86_64
    phonon-backend-vlc-0.8.2-1.2.x86_64


    So all codecs should be there.

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC not playing MP4

    that guide is incomplete and a bit buggy
    you need to do a full vendor change with packman as just adding a repo is not enough you need to make sure rpm files come from that repo
    https://en.opensuse.org/SDB:Vendor_c..._Vendor_change
    post your repo list
    Code:
    zypper lr -d
    and although phonon-backend-vlc works with leap phonon-backend-gstreamer is better so install that one (you don't have to remove vlc's but it's better you do)
    Code:
    zypper rm phonon-backend-vlc
    zypper in phonon-backend-gstreamer

  4. #4

    Default Re: VLC not playing MP4

    Thanks.
    I've had to reinstall Fedora because I had to work on urgent things, next week I hope to have time to make a new install and then follow your advice.

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC not playing MP4

    Quote Originally Posted by VimClorex View Post
    Thanks.
    I've had to reinstall Fedora because I had to work on urgent things, next week I hope to have time to make a new install and then follow your advice.
    The only thing you need to get full multimedia is to add the packman repo, switch installed rpm's from that repo and just in case pull rpm's that don't exist in the OSS repo, in 3 commands:
    Code:
    sudo zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.1/ packman
    sudo zypper dup --from packman
    sudo zypper in vlc-codecs libxine2-codecs
    That's it now you have full multimedia support in opensuse and not just in vlc but with kaffeine, dragon, totem, Firefox etc...
    the last command might not be needed as vlc from packman should pull vlc-codecs but pull them just in case

  6. #6

    Default Re: VLC not playing MP4

    Long time Debian user, I just experienced and installed openSUSE for the first time this week and liking it a lot.

    I'm having the same problem the OP describes and with no luck resolving it yet.

    Working with a fresh install of LEAP 42.1.

    VLC plays avi, mkv without problem. mp4 gives audio output, but no video output.

    rpm -qa | grep vlc

    returns:

    libvlccore8-2.2.2-1.1.x86_64
    vlc-2.2.2-1.1.x86_64
    vlc-qt-2.2.2-1.1.x86_64
    vlc-noX-2.2.2-1.1.x86_64
    vlc-noX-lang-2.2.2-1.1.noarch
    phonon4qt5-backend-vlc-0.8.2-2.3.x86_64
    libvlc5-2.2.2-1.1.x86_64
    vlc-codecs-2.2.2-1.1.x86_64
    phonon-backend-vlc-0.8.2-1.2.x86_64

    I've added packman repo, given it highest priority. I never added VLC repo, so no conflict there.

    In YAST vlc and codecs are listed as installed from packman repo

    ran as recommended:
    sudo zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.1/ packman
    sudo zypper dup --from packman
    sudo zypper in vlc-codecs libxine2-codecs

    Still no mp4 video output.

    Also tried fix from: https://forums.opensuse.org/showthre...ing-mp4-videos

    by switching video output to x11, but no change.

    Any help would be greatly appreciated.

  7. #7

    Default Re: VLC not playing MP4

    uninstalled:

    libvdpau_va_gl1

    as referenced here: https://forums.opensuse.org/showthre...-screen-in-vlc

    and it resolved the issue for me. Hope this helps OP and others too!

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC not playing MP4

    Quote Originally Posted by noctuanova View Post
    uninstalled:

    libvdpau_va_gl1

    as referenced here: https://forums.opensuse.org/showthre...-screen-in-vlc

    and it resolved the issue for me. Hope this helps OP and others too!
    that's an intel graphic card issue, not a vlc issue, actually nvidia users need libvdpau_va_gl1 (vdpau was developed by nvidia) for hardware acceleration, so please don't mix things up

  9. #9

    Default Re: VLC not playing MP4

    Quote Originally Posted by I_A View Post
    actually nvidia users need libvdpau_va_gl1 (vdpau was developed by nvidia) for hardware acceleration
    No, they don't!

    Actually, libvdpau_va_gl1 *breaks* nvidia's VDPAU, because it redirects VDPAU to VA-API (which nvidia doesn't support).

    On an nvidia system, you *must not* have libvdpau_va_gl1 installed, if you want to use hardware decoding.

    intel users do need libvdpau_va_gl1 though for VDPAU support, although most players should support VA-API natively too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •