The last weekend I used Handbrake (in Windows 10) to re-encode my videos to x265 to save some space in my HDD, and in a way also insert several subtitles (*.srt format) to the videos. Everything worked as expected.

Considering the time Handbrake took to re-encode for each video (appr. 2 hours) and that much of my work time was spent in openSUSE, I installed Handbrake in openSUSE.

This is where something weird happened. With all of the preset (that is what it is called in Handbrake) the same as it is in Windows 10, everything went well except that the subtitles was not there.

I rechecked everything to see whether I missed anything, still no subs appear (I use SMPlayer to see the subtitles). I even re-encode the video, the one that succesfully re-encoded with added subtitles in Windows 10, to see whether the video or the Handbrake was to be blamed.

And based on this, my conclusion is that something is definitely different between Handbrake in openSUSE and in Windows 10.

Does anyone here familiar with Handbrake to help me to add subtitles to the video ?

Thanks