Results 1 to 9 of 9

Thread: How to customize sound outputs? Headphones only or Headphones + Speakers

  1. #1

    Default How to customize sound outputs? Headphones only or Headphones + Speakers

    Hi,
    I just got a pair of headphones and noticed I can't find where I can select what happens when I plug my headphones in. Currently when I plug them I have sound on both my speakers and headphones, even though I want the speakers muted when I plug in my heaphones, like on my laptop. I went in Pulse Audio settings, Audio Volume control setting but can't find the setting.

    The headphones are plugged in the headphones jack on the front of the case. The front panel is connected to the mobo via HD Audio front header.

    Also is there some equalizer app for KDE?

    Leap 42.1 x64 KDE

    AMD A10-7700K
    FM2A68M-HD+ mobo
    OpenSUSE Leap 42.2 x64 KDE

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,789

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Give pavucontrol a shot. It gives finer control on audio sources and sinks. Note it is app specific so you can have different set ups for different apps

    Try pulseaudio-equalizer

  3. #3

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Quote Originally Posted by gogalthorp View Post
    Give pavucontrol a shot. It gives finer control on audio sources and sinks. Note it is app specific so you can have different set ups for different apps

    Try pulseaudio-equalizer
    Hi,
    I do have pavucontrol installed. I did played with the drop down menu there selecting Headphones and Line Out but what happens is this

    If I choose Line Out, I get sound on the speakers only wich is ok
    If I choose Headphones I get sound on both the speakers and headphones.

    See attachments

    http://imgur.com/a/lDgol
    OpenSUSE Leap 42.2 x64 KDE

  4. #4

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    I do not use Pulseaudio but I know that in my alsamixer "automute" is enabled and that prevents that various sound outputs are chosen at the same time.

    Seems postimage is down for me and I cannot insert the screenshot. Though if you use Pulse you cannot access all settings from alsamixer or at least I do not know how.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,581
    Blog Entries
    38

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Quote Originally Posted by robertot5 View Post
    Currently when I plug them I have sound on both my speakers and headphones, even though I want the speakers muted when I plug in my heaphones, like on my laptop.
    This is anomalous behaviour and regardless of your fix (if you manage to find a fix) it deserves having a bug report written on openSUSE (likely on the kernel sound module).

    The advice given (to look at pavucontrol and alsamixer) is likely the best initial advice.

    Its also possible a custom alsa configuration could be applied - but that would only be as a last resort.
    .

  6. #6

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Quote Originally Posted by oldcpu View Post
    This is anomalous behaviour and regardless of your fix (if you manage to find a fix) it deserves having a bug report written on openSUSE (likely on the kernel sound module).

    The advice given (to look at pavucontrol and alsamixer) is likely the best initial advice.

    Its also possible a custom alsa configuration could be applied - but that would only be as a last resort.
    .
    This is what I did in the last hours:

    I went and ran alsa-info.sh that created the attached file.

    Also, I noticed that pulse-equalizer doesn't do anything.

    My mobo seems to have the Realtek ALC662 Audio Codec

    I played with "
    pacmd load-module module-switch-on-port-available" and "pacmd load-module module-switch-on-connect", does nothing.

    alsa-info.sh output here http://pastebin.com/gcynB7dC

    Code:
    rpm -qa | grep alsaalsa-utils-1.0.29-9.1.x86_64
    alsa-plugins-32bit-1.0.29-10.1.x86_64
    alsa-oss-1.0.28-5.2.x86_64
    alsa-oss-32bit-1.0.28-5.2.x86_64
    alsa-plugins-pulse-1.0.29-10.1.x86_64
    alsa-devel-1.0.29-10.1.x86_64
    alsa-devel-32bit-1.0.29-10.1.x86_64
    alsa-1.0.29-10.1.x86_64
    alsa-plugins-1.0.29-10.1.x86_64
    alsa-plugins-pulse-32bit-1.0.29-10.1.x86_64
    Code:
    rpm -qa | grep pulsepulseaudio-module-lirc-7.0-5.1.x86_64
    pulseaudio-utils-32bit-7.0-5.1.x86_64
    pulseaudio-equalizer-2.7.0.2-3.1.noarch
    libpulse0-7.0-5.1.x86_64
    alsa-plugins-pulse-1.0.29-10.1.x86_64
    libpulse0-32bit-7.0-5.1.x86_64
    pulseaudio-module-gconf-7.0-5.1.x86_64
    pulseaudio-7.0-5.1.x86_64
    pulseaudio-module-zeroconf-7.0-5.1.x86_64
    pulseaudio-module-bluetooth-7.0-5.1.x86_64
    libpulse-mainloop-glib0-7.0-5.1.x86_64
    pulseaudio-lang-7.0-5.1.noarch
    pulseaudio-module-x11-7.0-5.1.x86_64
    alsa-plugins-pulse-32bit-1.0.29-10.1.x86_64
    pulseaudio-bash-completion-7.0-5.1.x86_64
    pulseaudio-module-jack-7.0-5.1.x86_64
    pulseaudio-utils-7.0-5.1.x86_64
    libxine2-pulse-1.2.6-3.2.x86_64
    Code:
    rpm -qa | grep soundoxygen5-sounds-5.5.5-9.1.x86_64
    sound-theme-freedesktop-0.8-8.1.noarch
    libSDL_sound-1_0-1-1.0.3-95.2.x86_64
    libasound2-1.0.29-10.1.x86_64
    esound-daemon-0.2.41-29.1.x86_64
    libasound2-32bit-1.0.29-10.1.x86_64
    yast2-sound-3.1.7-6.6.x86_64
    Code:
    cat /etc/modprobe.d/50-sound.conf
    
    options snd slots=snd-hda-intel
    # 5Dex.Llr7zS2YqdE:SBx00 Azalia (Intel HDA)
    alias snd-card-0 snd-hda-intel
    OpenSUSE Leap 42.2 x64 KDE

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,581
    Blog Entries
    38

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Quote Originally Posted by robertot5 View Post
    alsa-info.sh output here http://pastebin.com/gcynB7dC

    Code:
    cat /etc/modprobe.d/50-sound.conf
    
    options snd slots=snd-hda-intel
    # 5Dex.Llr7zS2YqdE:SBx00 Azalia (Intel HDA)
    alias snd-card-0 snd-hda-intel
    As noted by myself already, my view is you are already in bug reporting territory ... and whether we come up with a fix or not, a bug report should be raised as this should 'just work' and it does not 'just work'. There is guidance for raising a bug report here: https://en.opensuse.org/openSUSE:Submitting_bug_reports

    Raising a bug report gets the attention of the best experts on sound - the packagers of openSUSE and also possibly an alsa developer. Do not bother referencing a forum thread in a bug report as they will not read it. Your bug report needs to be complete. You do not need to post all those custom retrievals you have done. Just post the output of the diagnostic script I had you run. ie /usr/sbin/alsa-info.sh

    Now anything I can provide is only pure speculation - which is why a bug report is a better idea.

    Now I note your PC has the HDMI device as card-0 and the analog sound device as core-1 . That can cause sound problems (such as no sound) if one does not know how to work around it. This is because by default all sound goes to card-0 (ie the HDMI). Clearly you do not have that no sound problem - but maybe the order is messing up the automatic mute of the speakers when headphones are plugged in . <<<< and that is speculation.

    Now does your PC have more than one audio out jack ? If so, does either jack work wrt muting the sound?

    Possibly one could force a specific alsa config upon boot using this from the HD-Audio-Models.txt file, trying one value at a time in the 50-sound.conf with some very exact syntax (that I would need to provide). And given both the HDMI and analog device both use the intel driver, its possible I need to fix the sound card order prior to do such in order to ensure the config is applied to the correct instance.
    Code:
    ALC66x/67x/892
    ==============
      mario            Chromebook mario model fixup
      asus-mode1        ASUS
      asus-mode2        ASUS
      asus-mode3        ASUS
      asus-mode4        ASUS
      asus-mode5        ASUS
      asus-mode6        ASUS
      asus-mode7        ASUS
      asus-mode8        ASUS
      inv-dmic        Inverted internal mic workaround
      dell-headset-multi    Headset jack, which can also be used as mic-in
    In all due honesty - this is not something quick to do given my degree of speculation and likely we would end up trying dozen or more possibilities. If you raise a bug report it will IMHO be far quicker to get a working solution, than anything I can provide.
    .

  8. #8

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Quote Originally Posted by oldcpu View Post
    As noted by myself already, my view is you are already in bug reporting territory ... and whether we come up with a fix or not, a bug report should be raised as this should 'just work' and it does not 'just work'. There is guidance for raising a bug report here: https://en.opensuse.org/openSUSE:Submitting_bug_reports

    Raising a bug report gets the attention of the best experts on sound - the packagers of openSUSE and also possibly an alsa developer. Do not bother referencing a forum thread in a bug report as they will not read it. Your bug report needs to be complete. You do not need to post all those custom retrievals you have done. Just post the output of the diagnostic script I had you run. ie /usr/sbin/alsa-info.sh

    Now anything I can provide is only pure speculation - which is why a bug report is a better idea.

    Now I note your PC has the HDMI device as card-0 and the analog sound device as core-1 . That can cause sound problems (such as no sound) if one does not know how to work around it. This is because by default all sound goes to card-0 (ie the HDMI). Clearly you do not have that no sound problem - but maybe the order is messing up the automatic mute of the speakers when headphones are plugged in . <<<< and that is speculation.

    Now does your PC have more than one audio out jack ? If so, does either jack work wrt muting the sound?

    Possibly one could force a specific alsa config upon boot using this from the HD-Audio-Models.txt file, trying one value at a time in the 50-sound.conf with some very exact syntax (that I would need to provide). And given both the HDMI and analog device both use the intel driver, its possible I need to fix the sound card order prior to do such in order to ensure the config is applied to the correct instance.
    Code:
    ALC66x/67x/892
    ==============
      mario            Chromebook mario model fixup
      asus-mode1        ASUS
      asus-mode2        ASUS
      asus-mode3        ASUS
      asus-mode4        ASUS
      asus-mode5        ASUS
      asus-mode6        ASUS
      asus-mode7        ASUS
      asus-mode8        ASUS
      inv-dmic        Inverted internal mic workaround
      dell-headset-multi    Headset jack, which can also be used as mic-in
    In all due honesty - this is not something quick to do given my degree of speculation and likely we would end up trying dozen or more possibilities. If you raise a bug report it will IMHO be far quicker to get a working solution, than anything I can provide.
    .
    Thank you for your input!
    I will off course start a bug but before that I'll pop the case open tomorrow and check again the front panel connections and will try some BIOS settings if available and maybe another pair of headphones.

    To answer your observations, I only have 3 jacks on the back, speakers, mic, line in. On the front of the case I have headphones and mic. That HDMI sound output device is most likely the AMD APU with its integrated Radeon graphics and HDMI port on the motherboard. I don't have that set in Pulse Audio Control, the second Output device is OFF. There is only one output device set and that is Analog Stereo Output. Anyways, I played with all possible combinations there and couldn't made the automute work. What I noticed is that on the drop down list where you can select LineOut and Headphones, only the Line Out appears as LineOut (plugged in), headphones don't have the plugged in status. Removing the speakers jack does remove the plugged in status so I think jack sensing work though.
    Will return tomorrow with some results!
    OpenSUSE Leap 42.2 x64 KDE

  9. #9

    Default Re: How to customize sound outputs? Headphones only or Headphones + Speakers

    Well, I think I just found out what's happening with my sound issue.

    It seems that because I have an old case, a Thermaltake Mambo wich has a AC97 style audio front panel combined with my newer mobo, wich has only a HD Audio front panel header but NO option in BIOS to emulate AC97 connection, the jack sensing function is missing. I did some research on both the mobo's manual and the case's manual. Even though I have a wiring pinout on how to connect the case's front panel on both AC97 and HD audio style headers, is acts (I think) as a normal Line Out duplicate, some sort of splitter. Due to that I think its impossible for the kernel to know when I plug in my headphones in order to mute the Line Out, it basically doen't see the headphones port activity because its wired in this compatibility way.

    I will invest in a new case soon, that will most likely have an HD Audio header.

    I don't know if there is a way to solve my problem via software, I don't know if there is a software method of muting the Line Out jack on the back of the mobo and allow audio only on the HD Audio header and vice versa.
    OpenSUSE Leap 42.2 x64 KDE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •