Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: Sound card greyed out in Kmix, not visible in plasma5-pa in Leap 42.1

  1. #31
    Jon_Freeman NNTP User

    Default Re: Sound card greyed out in Kmix, not visible in plasma5-pa in Leap 42.1

    Quote Originally Posted by Jon_Freeman View Post
    For me, on the laptop, I think I've now found something that does shift things in favour of pulse audio. I'll look to find a more complete solution with pulse, timidity and Jack later in the week.
    I'll start a new thread if I need to work out my own individual problems with others but do want to post my initial bit here.

    After a couple of hours trying, I gave up with timidity. It works fine without pulse audio but I didn't get beyond midis mostly sounding like a machine gun with pulse running - that and the timidity control flashing/refreshing itself like mad. I thought I'd fixed things by starting timidit using the KDE "pre KDE" startup option but then noticed that stopped the soundcard being visible to pulse.

    I've had an initial play using fluidsynth instead which is playing reasonably with pulse running but have yet to work out where to start it.

    There are also major problems with pulse audio and my Zoom H6 when started in multitrack mode. I'm not convinced there is not an underlying ALSA problem as sound files can have a buzz added to them when played through audacity (although I've not had this with Jack running) but there have been problems specific to pulse, ie:

    puavcontrol locking up, Firefox playing YouTube video locking up and after about a minute of the H6 connected, it starting buzzing even when nothing is playing.

    Fortunately, puavcontrol does provide a solution to this. I can set the profile to off. This probably makes more sense anyway. A simple system using pulse for "normal stuff" and the (for want of a better term) the "pro audio" stuff off pulse for use with Jack (including if I want it, using an external MIDI device - I don't really see timidity or fluidsynth for that) could be the answer if only I get the "standard midi" working with pulse.

    Whatever, some aspects certainly have got harder trying to have the laptop with pulse.

  2. #32
    Join Date
    Sep 2011
    Location
    Athens, Greece
    Posts
    4

    Default Re: Sound card greyed out in Kmix, not visible in plasma5-pa in Leap 42.1

    I had the same problem and noticed that /usr/bin/kmix had not the setuid bit set.
    Thus I ran:
    sudo chmod +s /usr/bin/kmix
    and the sound card was greyed out no more. I know its a late post, but I post it in case someone else has the same problem is directed here by google.
    Thanasis

  3. #33

    Default Re: Sound card greyed out in Kmix, not visible in plasma5-pa in Leap 42.1

    Quote Originally Posted by cyberthanasis View Post
    I had the same problem and noticed that /usr/bin/kmix had not the setuid bit set.
    Thus I ran:
    sudo chmod +s /usr/bin/kmix
    and the sound card was greyed out no more. I know its a late post, but I post it in case someone else has the same problem is directed here by google.
    Sorry, but that's not just a late post, it's also nonsense.

    kmix does not need (and should not have) the setuid bit set at all.
    Please remove that again immediately!
    You basically are running kmix as root in your user session now, which means it won't respect the user settings and may also cause other problems (like the user config files being owned by root).

    What you may have noticed is the broken kernel update in 13.2 though, see other recent threads, and/or this bug report:
    http://bugzilla.opensuse.org/show_bug.cgi?id=1007035
    Booting the previous kernel should help, or wait for the next update, hopefully being released tomorrow...
    Last edited by wolfi323; 27-Oct-2016 at 13:45.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •