Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: YAST2 SOFTWARE MANAGEMENT fails

  1. #1

    Default YAST2 SOFTWARE MANAGEMENT fails

    After the most recent maintenance applied via ZYPPER DUP

    Code:
    linux-lcp7:/home/spcwh2 # yast2
    Run command: /sbin/yast2 sw_single &
    YaST got signal 11 at file /usr/share/YaST2/modules/PackagesUI.rb:315
      sender PID: 504
    /sbin/yast2: line 440:  3765 Segmentation fault      (core dumped) $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    Is anyone else seeing this issue ?

    Also is there a fix for this or is this something I just need to wait for the next maintenance to fix this issue
    Chuck Haatvedt (learning linux)

    Opensuse Tumbleweed / Windows 10 dual boot
    Opensuse Tumbleweed in VMWARE Player

  2. #2
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    769

    Default Re: YAST2 SOFTWARE MANAGEMENT fails

    Not much of a help, but after a fresh install and update i have the problem that YaST is not responding.

    Code:
    linux-mcm0:/home/ben # yast2
    Run command: /sbin/yast2 sw_single &
    /usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16should_be_loggediRKSs
    Think there is something wrong with the last update with YaST, maybe a fresh install can help.
    After the update Kmail is also not working.
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,529

    Default Re: YAST2 SOFTWARE MANAGEMENT fails

    Well almost always this kind of a problem is do to mixing repos from different versions

    Post
    zypper lr -d

  4. #4
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    769

    Default Re: YAST2 SOFTWARE MANAGEMENT fails

    Quote Originally Posted by gogalthorp View Post
    Well almost always this kind of a problem is do to mixing repos from different versions

    Post
    zypper lr -d
    Your right by that, but i have only the repos for TW installed.
    Also i have a lot of problems with Kmail and other applications in KDE, but thats on the Dutch part of the forum a issue .

    So this is back to Chaat its his thread. sorry.
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

  5. #5

    Default Re: YAST2 SOFTWARE MANAGEMENT fails

    I have the same problem with Yast2 and yast from terminal

    Code:
    yast
    /usr/lib/YaST2/bin/y2base: symbol lookup error: /usr/lib64/YaST2/plugin/libpy2UI.so.2: undefined symbol: _Z16s
    hould_be_loggediRKSs
    
    
    anyone have any idea how to fix this?

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,728

    Default AW: YAST2 SOFTWARE MANAGEMENT fails

    @chaat
    2 Monitors connected to the PC?
    Try to start Yast on the on the first one?

    @Dexter22
    You have another Problem with Yast.
    This is the thread opend by chaat.

  7. #7

    Default Re: AW: YAST2 SOFTWARE MANAGEMENT fails

    yes but don't be selfish man, why open 2 threat for the same problem...

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: YAST2 SOFTWARE MANAGEMENT fails

    I do not a problem
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,728

    Default AW: YAST2 SOFTWARE MANAGEMENT fails

    @Dexter22
    Your Error seems not the same as chaat's.

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,006
    Blog Entries
    3

    Default Re: YAST2 SOFTWARE MANAGEMENT fails

    No problem here. I checked before and after 20160414. So the first check was with 20160412.

    As Sauerland has indicated, there appear to be two distinct problem reported by different folk. There's the problem originally reported by chaat, and then there is a problem reported by Benmh and separately by Dexter22.

    The kind of problem being described by Benmh and by Dexter22 is usually due to incompatible libraries. And this is most often caused by having conflicting repos configured.
    openSUSE Leap 15.1; KDE Plasma 5;

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •