Results 1 to 3 of 3

Thread: Second Screen Disabled

  1. #1

    Default Second Screen Disabled

    Hello,
    Seems there was an update yesterday from Tumbelweed and I have lost my secondary screen.

    My xrandr -q looks like:
    Code:
    xrandr -qScreen 0: minimum 8 x 8, current 1680 x 1050, maximum 32767 x 32767
    DP1 disconnected (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    VGA1 connected primary 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
       1680x1050     59.95*+
       1280x1024     75.02    60.02  
       1440x900      74.98    59.89  
       1280x800      74.93    59.81  
       1280x720      60.00  
       1024x768      75.08    60.00  
       800x600       75.00    60.32  
       640x480       75.00    60.00  
       720x400       70.08  
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)
    I can see the logo of Tumbelweed showing up during Boot, but then it goes disable. My port should be on DP left of VGA1. Trying to add it manually through xrandr fails.

    My lspci -v looks like:

    Code:
    lspci -v00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
        Subsystem: Fujitsu Technology Solutions Device 114c
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] Vendor Specific Information: Len=0c <?>
        Kernel driver in use: agpgart-intel
    
    
    00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Fujitsu Technology Solutions Device 114c
        Flags: bus master, fast devsel, latency 0, IRQ 31
        Memory at fc000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1c70 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Kernel driver in use: i915
        Kernel modules: i915
    
    
    00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
        Subsystem: Fujitsu Technology Solutions Device 114c
        Flags: bus master, fast devsel, latency 0
        Memory at fc400000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [d0] Power Management version 2
    Will appreciate any suggestions to solve the problem. Thank you in advance

  2. #2

    Default Re: Second Screen Disabled

    Quote Originally Posted by alpukn View Post
    Hello,
    Seems there was an update yesterday from Tumbelweed and I have lost my secondary screen.

    I can see the logo of Tumbelweed showing up during Boot, but then it goes disable. My port should be on DP left of VGA1.
    Okay, given that info, it sounds like its a user level configuration of X problem (i.e. what is being applied when your desktop of choice starts up) ... For whatever reason, there have been several recent cases of such reported.

    Trying to add it manually through xrandr fails.
    What exactly did you use?

    In any regard, what desktop are you using? If KDE, try setting it with the KScreen utility (found in Configure Desktop > Display & Monitor). It is possible the KScreen configuration file has got messed up.

  3. #3
    Join Date
    May 2015
    Location
    Michigan/Florida
    Posts
    65

    Default Re: Second Screen Disabled

    I had the same issue and all I had to do was open the display and monitor and drag the left hand monitor off the top of the right monitor and reset both monitors resolution and I like the left monitor as the primary.

    Simple kscreen config and all is better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •