Results 1 to 5 of 5

Thread: video drivers

  1. #1

    Default video drivers

    Hey,
    I'm trying to install my Nvidia GTX550 Ti video drivers on my Sandisk SSD PLUS hard drive in Opensuse Leap 42.1 KDE system.
    Code:
    zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/ x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
    zypper ref
    zypper in x11-video-nvidiaG04
    But it gives me this error:
    Code:
    linux-anla:~ # zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/ x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
    Adding repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' ...................[done]
    Repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' successfully added
    Enabled     : Yes                                                 
    Autorefresh : Yes                                                 
    GPG Check   : Yes                                                 
    URI         : ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/
    Code:
    inux-anla:~ # zypper ref
    Repository 'openSUSE-42.1-0' is up to date.                                             
    Repository 'openSUSE-Leap-42.1-Oss' is up to date.                                      
    Repository 'openSUSE-Leap-42.1-Update' is up to date.                                   
    Repository 'openSUSE-Leap-42.1-Update-Non-Oss' is up to date.                           
    Retrieving repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' metadata .....[error]
    Repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' is invalid.
    [x11-video-nvidiaG04-352.55-17.1.x86_64.rpm|ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' because of the above error.
    Some of the repositories have not been refreshed because of an error
    Code:
    linux-anla:~ # zypper in x11-video-nvidiaG04-352.55-17.1.x86_64 .rpmRetrieving repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' metadata .....[error]
    Repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' is invalid.
    [x11-video-nvidiaG04-352.55-17.1.x86_64.rpm|ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' because of the above error.
    Loading repository data...
    Reading installed packages...
    'x11-video-nvidiaG04-352.55-17.1.x86_64' not found in package names. Trying capabilities.
    No provider of 'x11-video-nvidiaG04-352.55-17.1.x86_64' found.
    '.rpm' not found in package names. Trying capabilities.
    No provider of '.rpm' found.
    Resolving package dependencies...
    
    Nothing to do.
    And when I download the file from site and try to install it this happens:
    Code:
    linux-anla:~ # zypper in /home/user/Downloads/x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
    Retrieving repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' metadata .....[error]
    Repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' is invalid.
    [x11-video-nvidiaG04-352.55-17.1.x86_64.rpm|ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' because of the above error.
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libnvidia-ml.so.1()(64bit) needed by x11-video-nvidiaG04-352.55-17.1.x86_64
     Solution 1: do not install x11-video-nvidiaG04-352.55-17.1.x86_64
     Solution 2: break x11-video-nvidiaG04-352.55-17.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    ???

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,110
    Blog Entries
    15

    Default Re: video drivers

    Hi
    Your drilling too far down in the directory tree, remove and try;
    Code:
    zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1/ Nvidia
    zypper ref
    zypper in x11-video-nvidiaG04
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: video drivers

    Quote Originally Posted by user89 View Post
    Hey,
    I'm trying to install my Nvidia GTX550 Ti video drivers on my Sandisk SSD PLUS hard drive in Opensuse Leap 42.1 KDE system.
    Code:
    zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/ x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
    That is wrong.
    You called the repo "x11-video-nvidiaG04-352.55-17.1.x86_64.rpm" now on your system.
    You probably should rather use something like "nvidia" instead...

    Please post your current repo list for further, more explicit help:
    Code:
    zypper lr -d
    Code:
    linux-anla:~ # zypper in x11-video-nvidiaG04-352.55-17.1.x86_64 .rpm
    That's wrong as well.
    First, there shouldn't be a space between the package name and the '.rpm'. That's what causes the error about ".rpm not found".
    Second, you should not specify the full filename anyway in this case, rather just install "x11-video-nvidiaG04".

    And when I download the file from site and try to install it this happens:
    That's to be expected.
    You need more than just that one package...

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,395
    Blog Entries
    2

    Default Re: video drivers

    Quote Originally Posted by wolfi323 View Post
    That is wrong.
    You called the repo "x11-video-nvidiaG04-352.55-17.1.x86_64.rpm" now on your system.
    You probably should rather use something like "nvidia" instead...

    Please post your current repo list for further, more explicit help:
    Code:
    zypper lr -d
    Code:
    linux-anla:~ # zypper in x11-video-nvidiaG04-352.55-17.1.x86_64 .rpm
    That's wrong as well.
    First, there shouldn't be a space between the package name and the '.rpm'. That's what causes the error about ".rpm not found".
    Second, you should not specify the full filename anyway in this case, rather just install "x11-video-nvidiaG04".


    That's to be expected.
    You need more than just that one package...
    Actually his error is that when adding the repository, he gave the repository name as the rpm name.
    Although inadvisable, it shouldn't cause an error (unless this is a new bug) because you should be able to call a repo any kind of friendly name and the repo should "just work" as evidenced by the repo being added successfully.

    From his posts, it looks to me that the specific rpm he wants to install does not exist, and this might be either a problem for the repo maintainers (should this package really exist?) or the package might have been superceded by a newer version which would be named differently.

    So, to the OP, I recommend you search for all similar packages with the following
    Code:
    zypper se x11-video-nvidiaG04
    You should see a list of all packages and drivers available for your particular video chipset.
    Choose which one you'd like to install and install with
    Code:
    zypper in packagename 
    TSU

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,023

    Default AW: Re: video drivers

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Your drilling too far down in the directory tree, remove and try;
    Code:
    zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1/ Nvidia
    zypper ref
    zypper in x11-video-nvidiaG04
    Its because of the wrong Directory as Malcolm says:
    zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/ x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
    Without x86_64:
    Code:
    LANG=C zypper ar -f ftp://download.nvidia.com/opensuse/leap/42.1 x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
    Adding repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' ..................................................................................................[done]
    Repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' successfully added
    Enabled     : Yes                                         
    Autorefresh : Yes                                         
    GPG Check   : Yes                                         
    URI         : ftp://download.nvidia.com/opensuse/leap/42.1
    Code:
    LANG=C zypper ref
    Repository '/home:Sauerland' is up to date.                                                                                                                            
    Repository 'openSUSE-Leap-42.1-Non-Oss' is up to date.                                                                                                                 
    Repository 'openSUSE-Leap-42.1-Oss' is up to date.                                                                                                                     
    Repository 'openSUSE-Leap-42.1-Source' is up to date.                                                                                                                  
    Repository 'openSUSE-Leap-42.1-Update' is up to date.                                                                                                                  
    Repository 'openSUSE-Leap-42.1-Update-Non-Oss' is up to date.                                                                                                          
    Retrieving repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' metadata ----------------------------------------------------------------------------------------[\]
    
    New repository or package signing key received:
    
      Repository:       x11-video-nvidiaG04-352.55-17.1.x86_64.rpm  
      Key Name:         NVIDIA Corporation <linux-bugs@nvidia.com>  
      Key Fingerprint:  9B763D49 D8A5C892 FC178BAC F5113243 C66B6EAE
      Key Created:      Thu Jun 15 18:13:18 2006                    
      Key Expires:      (does not expire)                           
      Rpm Name:         gpg-pubkey-c66b6eae-4491871e                
    
    
    Do you want to reject the key, trust temporarily, or trust always? [r/t/a/? shows all options] (r): t
    Retrieving repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' metadata .....................................................................................[done]
    Building repository 'x11-video-nvidiaG04-352.55-17.1.x86_64.rpm' cache ..........................................................................................[done]
    All repositories have been refreshed.
    But you are right, x11-video-nvidiaG04-352.55-17.1.x86_64.rpm is not a good Name for a Repo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •