Results 1 to 2 of 2

Thread: libqt-creator 3.6.0 not built with qbs-path.diff?

  1. #1
    Join Date
    Sep 2013
    Location
    Eastern US
    Posts
    78

    Default libqt-creator 3.6.0 not built with qbs-path.diff?

    Just dup-ed TW and got the new 3.6.0 libqt5-creator. Nice. However, I use the qbs build system and when libqt5-creator starts, I now get this:

    Code:
    WARNING: Plugin path '/usr/lib64/qtcreator/plugins/qbs/plugins' does not exist.

    So, when building, you get a cpp file tag scanner error as the scanners are qbs plugins. I created the path above and copied the two plugins into it and all works fine.

    So, it seems like the patch "qbs-path.diff" is not getting included with the build.

    Should I post this on the Factory ML or file a bug report?

  2. #2

    Default Re: libqt-creator 3.6.0 not built with qbs-path.diff?

    Quote Originally Posted by noee View Post
    So, it seems like the patch "qbs-path.diff" is not getting included with the build.
    Well, AFAICS the patch is still included and is being applied when building.
    From the build log of the package in openSUSE:Factory:
    Code:
    [  199s] + echo 'Patch #0 (qbs-path.diff):'
    [  199s] Patch #0 (qbs-path.diff):
    [  199s] + /usr/bin/patch -p1 --fuzz=0
    [  199s] + /usr/bin/cat /home/abuild/rpmbuild/SOURCES/qbs-path.diff
    [  200s] patching file src/shared/qbs/src/plugins/plugins.pri
    [  200s] Hunk #1 succeeded at 17 (offset -2 lines).
    
    But apparently it doesn't have the desired effect any more, maybe because of changes in qt-creator (the patch hasn't been modified since 2 years ago).

    Should I post this on the Factory ML or file a bug report?
    I'd say file a bug report.
    But try with a fresh user account first, to rule out some problem in the user's config.
    Last edited by wolfi323; 17-Jan-2016 at 06:36.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •