Results 1 to 10 of 10

Thread: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

  1. #1

    Default Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    Leap 42.1 x64

    Note: Framework5 repo is being used because the Wolfie repo when enabled had a dependency only met by it being used (don't remember which dependency)

    running zypper ref && zypper up I get the message "The following 311 package updates will NOT be installed:" for the list see http://pastebin.com/afPAyZ1P

    running Yast sw manager and forcing an unconditional upgrade to all packages gets this message:

    I upgraded to Leap earlier this week but for the first couple of day everything upgraded fine


    regards and to Wolfi thanks
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  2. #2

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    Quote Originally Posted by google01103 View Post
    Note: Framework5 repo is being used because the Wolfie repo when enabled had a dependency only met by it being used (don't remember which dependency)
    Yes, you need the KDE:Frameworks5 repo if you use my repo, because my packages contain the latest versions of Plasma5 (actually branched from KDE:Frameworks5).
    And my repo only contains those packages that conflict with KDE4.
    In particular kwin5 is not in my repo, and the version included in Leap 42.1 is too old (Leap 42.1 comes with Plasma 5.4.3, my repo contains 5.5.3 at the moment). Adding/enabling the KDE:Frameworks5 repo (for Leap 42.1) should "fix" that.

    Code:
    running zypper ref && zypper up I get the message "The following 311 package updates will NOT be installed:" 
    zypper up is not a possible way to install my packages. It doesn't switch packages to some other repos, that's what that message tells you.

    running Yast sw manager and forcing an unconditional upgrade to all packages gets this message:
    Have you tried the first option?
    Apparently it wants to install some 5.4.3 packages from the standard repo, which you shouldn't install.

    Could you please post your repo list?
    Code:
    zypper lr -d
    To install Plasma5 from my repo, I would recommend the following procedure (although I haven't tested it myself on Leap 42.1 yet):
    - add the KDE:Frameworks5 *and* my repo, preferably give my repo a higher priority (lower priority number) to make sure the packages are preferred but this probably isn't even necessary
    - do a full switch to *both*, preferably at the same time. Something like:
    Code:
    sudo zypper dup --from KF5 --from wolfi323_KF5
    YaST doesn't allow to switch two repos at the same time, but you should be able to do it anyway: click on "Switch all packages to the versions from this repo" for KDE:Frameworks5 (if you get conflicts, just ignore them or better click cancel when asked for a resolution, should only happen if you have KDE4 installed though), then do the same for my repo.
    Last edited by wolfi323; 15-Jan-2016 at 06:21.

  3. #3

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    repos listings http://pastebin.com/DmrtWFSY or from Yast https://i.imgur.com/K02BRZa.png

    in 13.2 I had no issues running zypper with your repo

    your repo does have a lower priority number (higher priority)

    using Yast and doing switching for either KF5 or the Wolfie repos just upped some popplerer and dolphin packages

    running "zypper dup --from" with 2 repos gets an error "too many arguments"
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #4

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    Quote Originally Posted by google01103 View Post
    Looks ok, AFAICS. Although you could remove some of those old, disabled, ones (that probably don't exist any more) for better clarity...

    using Yast and doing switching for either KF5 or the Wolfie repos just upped some popplerer and dolphin packages
    So you already did the switch?
    What's the actual problem then?

    If you're asking about the zypper message about "The following 311 package updates will NOT be installed", that might be "normal".
    It means that those packages are available in a higher version (or sometimes only the rebuild number is higher) in a different repo. "zypper up" will not switch packages to another repo automatically (as already mentioned, and most of the time this probably would not be what you want anyway), so it informs you about that fact.

    You could check manually for each package which version from which repo you would prefer, but afterwards just ignore it.
    In particular, you should check wine. You added the additional wine repo (for the latest version), but apparently have the version included in Leap 42.1 installed. IOW, the added repo is not used, you can just as well remove it if you don't switch to it.
    From a quick glimpse, all the rest seem to be packages from KDE:Qt5 and KDE:Frameworks5. So either you did not fully switch yet (switching to KDE:Qt5 is not necessary at this point), or KDE:Frameworks5 does have higher numbered packages than my repo. In that case, you obviously should keep the lower versioned ones from my repo.

    FYI, regarding the poppler and dolphin "updates":
    dolphin has been updated to fix a crash (http://bugzilla.opensuse.org/show_bug.cgi?id=952460, https://bugs.kde.org/show_bug.cgi?id=354558).

    poppler was missing in my repo by mistake, I enabled it just yesterday when I noticed it (OBS was playing tricks on me: the package was both enabled and disabled for Leap, the OBS web interface showed it as enabled but OBS itself regarded it as disabled). It's needed because the poppler in Leap 42.1 doesn't come with the Qt5 bindings (i.e. poppler-qt5 is missing in Leap 42.1), kfilemetadata5 (used for file indexing and Dolphin's file metadata display) cannot be built with support for PDF files without it. An official update is running for this though, so I might be able to remove it again in the future.
    The missing poppler did cause dependency problems, but they should be fixed now.

    running "zypper dup --from" with 2 repos gets an error "too many arguments"
    You need to specify "--from" twice as well if you want to use 2 repos, as I wrote in my post. In your case:
    Code:
    sudo zypper dup --from 1 --from 4
    If you get conflicts and need help, please post them.

  5. #5

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    properly doing the zypper --from Kf5 --from Wolfi gets
    155
    packages to upgrade, 8 to downgrade, 4 to remove, 160 to change vendor
    .

    in Yast switching to QT5 repo upgrades 78 packages

    the remaining seem to be from OSS updates repo where the version number is higher than yours

    for wine I changed the proiority from the default (99)

    left with 80 packaged not installable which seems better, in 13.2 I always had 20 to 40 but not 300+

    thanks,
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  6. #6

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    Quote Originally Posted by google01103 View Post
    properly doing the zypper --from Kf5 --from Wolfi gets
    .

    Ok, so you did not have my packages installed yet, but Plasma 5.5 should work now.
    If you also want to use KDE4, you might have to install it manually.
    From the top of my head you need to at least select kdebase4-session and kscreen (or, if you prefer, the old krandr), probably also plasma-nm (if you use NetworkManager) and kde-gtk-config (not strictly necessary).

    I hope that's all, I probably should add a pattern to my repo at some point...

    Btw, your KF5 applications will now have been replaced by their KDE4 versions, you may need to install the KF5 versions you want manually (xxx5) like it was already in 13.2.
    Maybe I should add a pattern for that too...

    the remaining seem to be from OSS updates repo where the version number is higher than yours
    Likely not the *version* number, but the revision.
    Well, I cannot prevent that. OBS chooses that automatically.
    That's why I suggest to raise the priority of my repo.

    for wine I changed the proiority from the default (99)
    The priority doesn't influence install packages, only the installation of new ones. And as I wrote already, "zypper up" won't switch either, regradless of the priority.
    You have to switch wine to the version from the WINE repo manually if you want to have the latest version from there.

  7. #7

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    no I did have your packages installed was able to run KDE 4 and Plasma 5

    I have some reasons to be able to run 4 but have up'ed to 5 but somethings are a bit off like with "open with" Kate does not work but Kate/Kf5 does and I do understand why its just that in the dialogs the xxxxx/Kf5 is about 1/2 way down

    for wine I used the switch packages in Yast
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  8. #8

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    Quote Originally Posted by google01103 View Post
    no I did have your packages installed was able to run KDE 4 and Plasma 5
    Ok, then I misunderstood you, sorry.
    In that case a "zypper dup" shouldn't have been necessary any more.

    I have some reasons to be able to run 4 but have up'ed to 5 but somethings are a bit off like with "open with" Kate does not work but Kate/Kf5 does
    The problem is that when logging in to Plasma5 my start script adds /opt/kf5/bin/ to the front of the PATH to make things work. This also means that "kate" (which is run by KDE4 kate's menu entry) actually runs the KF5 version instead. But the command line parameters have changed, so that fails in this case.
    The only way around that would be to uninstall kate5, then the KDE4 version would correctly be started.

    I have not had time to fix that yet (this "problem" exists since I created my repo... ), nor am I sure how I should do that.
    Maybe I will be able to add a patch to Plasma5/KF5 similar to the one included in KDE4 that made it possible to start KDE3 applications (which are located in /opt/kde3/).
    Or maybe I could just patch Plasma5/KF5 to reset the PATH before running the command, my /KF5 menu entries to specify the full path anyway.

    in the dialogs the xxxxx/Kf5 is about 1/2 way down
    Hm, I'm not sure what you mean with that.
    Which dialogs exactly? The "Open With" one? I don't see a problem here.

  9. #9

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    re: xxxx/Kf5 and the open with dialog

    and this is in Plasma 5

    in some open with dialogs the kf5 option is found towards the bottom
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #10

    Default Re: Issue with the Wolfi repo " The following 311 package updates will NOT be installed:"

    Quote Originally Posted by google01103 View Post
    re: xxxx/Kf5 and the open with dialog

    and this is in Plasma 5
    I don't see anything wrong there.

    in some open with dialogs the kf5 option is found towards the bottom
    You talk about the sorting of the entries?

    That "dialog" just displays all available file associations for the selected file, in the order they are defined.
    To change it use systemsettings5 ("Configure Desktop)->File Associations, also reachable via the "Properties" dialog of the corresponding file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •