Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: KDE & Plasma5

  1. #1

    Default KDE & Plasma5

    Hi

    I'm able to login to KDE/Plasma5 but after login i could see only the wallpaper and nothing else.
    Panels are not appearing and right click is not working.i can come out by Ctrl + Alt + Backspace
    KDE Plasma workspace and Plasma5 used to work,but it suddenly started behaving weirdly.

    I tried reinstalling and clearing the .cache but it did not work.i'm using LXDE currently which is really good.However , i would like to get the KDE back to working condition.

    I'm planning to reinstall Leap to see if it helps.Is this a known bug and can be fixed without reinstalling??


    Thanks,
    Dharani

  2. #2

    Default Re: KDE & Plasma5

    Quote Originally Posted by dhara_chn View Post
    Hi

    I'm able to login to KDE/Plasma5 but after login i could see only the wallpaper and nothing else.
    Panels are not appearing and right click is not working.i can come out by Ctrl + Alt + Backspace
    KDE Plasma workspace and Plasma5 used to work,but it suddenly started behaving weirdly.

    I tried reinstalling and clearing the .cache but it did not work.i'm using LXDE currently which is really good.However , i would like to get the KDE back to working condition.

    I'm planning to reinstall Leap to see if it helps.Is this a known bug and can be fixed without reinstalling??
    If you have nvidia graphics card, you can try installing its proprietary driver from nvidia. It is possible to do it text-only mode. In fact, text-only mode is required for nvidia driver installation.

  3. #3

    Default Re: KDE & Plasma5

    Quote Originally Posted by ZStefan View Post
    If you have nvidia graphics card, you can try installing its proprietary driver from nvidia.
    Yes, that's certainly good advise.
    nouveau still has a lot of problems.

    If you don't have an nvidia card, or it is a hybrid system (intel+nvidia), installing the nvidia driver should NOT be done though, as it will break your system completely.

    If you are using intel, you might experience bugs in its SNA acceleration. Switching back to the older UXA might help:
    https://en.opensuse.org/SDB:Switch_x...o-intel_to_UXA

    For Radeon cards, the included open source radeon driver should work fine. Depending on your exact card, you as well might have better experience with the proprietary driver (fglrx), or not.
    This is also available from a repo, see here:
    https://en.opensuse.org/SDB:AMD_fglrx

    As a temporary workaround, add "nomodeset" to the boot options to use a generic fallback driver, to get to a workable system.


    It is possible to do it text-only mode. In fact, text-only mode is required for nvidia driver installation.
    That's wrong.
    It is certainly possible to install the driver in graphics mode, especially if you use openSUSE's packages.
    And that's what I would recommend anyway, as it survives kernel and other updates (Mesa, Xorg), and prevents you from having to reinstall the driver all the time to fix it.
    Also, you get updates for the driver automatically if you use the repo.

    See https://en.opensuse.org/SDB:NVIDIA_drivers .

    It also should be possible to use nvidia's installer (i.e. installing it "the hard way") in graphics mode, but you'd have to specify an option to force the installation.

  4. #4

    Default Re: KDE & Plasma5

    Quote Originally Posted by wolfi323 View Post
    Yes, that's certainly good advise.
    nouveau still has a lot of problems.

    If you don't have an nvidia card, or it is a hybrid system (intel+nvidia), installing the nvidia driver should NOT be done though, as it will break your system completely.

    If you are using intel, you might experience bugs in its SNA acceleration. Switching back to the older UXA might help:
    https://en.opensuse.org/SDB:Switch_x...o-intel_to_UXA

    For Radeon cards, the included open source radeon driver should work fine. Depending on your exact card, you as well might have better experience with the proprietary driver (fglrx), or not.
    This is also available from a repo, see here:
    https://en.opensuse.org/SDB:AMD_fglrx

    As a temporary workaround, add "nomodeset" to the boot options to use a generic fallback driver, to get to a workable system.


    That's wrong.
    It is certainly possible to install the driver in graphics mode, especially if you use openSUSE's packages.
    And that's what I would recommend anyway, as it survives kernel and other updates (Mesa, Xorg), and prevents you from having to reinstall the driver all the time to fix it.
    Also, you get updates for the driver automatically if you use the repo.

    See https://en.opensuse.org/SDB:NVIDIA_drivers .

    It also should be possible to use nvidia's installer (i.e. installing it "the hard way") in graphics mode, but you'd have to specify an option to force the installation.

    Thanks Both.I should have mentioned in post that i used a ati card(HD 6450) and radeon driver.Surprisingly i can run the command using Alt + F2 in the KDE session(i'm typing this from the KDE session) and run any commands plus Alt + TAB is also working so i can switch to other task.

    What is not working: Alt + F1 and right click.No panels (or) widgets.

    I'm wondering whether this is something to do with the plasma-workspace.i tried disabling compositor to see if it is bringing back the panels and the menus without any luck.

    Thanks,
    Dharani

  5. #5

    Default Re: KDE & Plasma5

    Quote Originally Posted by dhara_chn View Post
    Thanks Both.I should have mentioned in post that i used a ati card(HD 6450) and radeon driver.
    Ok, you might try to install fglrx then, but normally radeon should work.

    You could still try "nomodeset" to see whether the problem is related to the graphics driver.

    What is not working: Alt + F1 and right click.No panels (or) widgets.
    Do you have a wallpaper, or just a black screen?

    If it's the latter, Plasma5 (which manages the "desktop") crashed or was not started.
    Does it work if you run "plasmashell" in the Alt+F2 dialog?
    Maybe run it in a konsole to get some output that might indicate the problem.

    I'm wondering whether this is something to do with the plasma-workspace.i tried disabling compositor to see if it is bringing back the panels and the menus without any luck.
    Did you logout and in again (or reboot) afterwards?
    Plasma is not restarted if you change the compositor settings.

    It might also be helpful to post your /var/log/Xorg.0.log and/or the output of "glxinfo|grep render". This should show whether there's a problem with the radeon driver maybe.

  6. #6

    Default Re: KDE & Plasma5

    Quote Originally Posted by wolfi323 View Post
    Do you have a wallpaper, or just a black screen?
    Oh, sorry.
    I overlooked that you mentioned in your original post that you "could see only the wallpaper".
    So plasmashell seems to be running.

    But please verify this in the "system monitor" (Ctrl+ESC), the "wallpaper" might be a left-over from the login screen too.
    And if it runs, try to kill it and start it again as I wrote. Maybe it's hanging.
    Last edited by wolfi323; 15-Jan-2016 at 06:48.

  7. #7

    Default Re: KDE & Plasma5

    Quote Originally Posted by dhara_chn View Post
    I'm able to login to KDE/Plasma5 but after login i could see only the wallpaper and nothing else.
    Panels are not appearing and right click is not working.i can come out by Ctrl + Alt + Backspace
    Quote Originally Posted by dhara_chn View Post
    Surprisingly i can run the command using Alt + F2 in the KDE session(i'm typing this from the KDE session) and run any commands plus Alt + TAB is also working so i can switch to other task.

    What is not working: Alt + F1 and right click.No panels (or) widgets.
    I'm wondering whether this is something to do with the plasma-workspace.
    Sure reads like it.

    Try renaming ~/.config/plasma-org.kde.plasma.desktop-appletsrc and then rebooting (plasma will regenerate a new file with default settings) to see if that restores to a proper desktop

    PS - I have a system with the same graphics card as you and it is well served via the oss radeon graphics stack. Disclosure: running Tumbleweed with all the latest available (i.e. X, mesa, plasma, kernel, ... ). Don't believe this has anything to do with graphics drivers, nor that fglrx would bring anything of value to the table for your device.

  8. #8

    Default Re: KDE & Plasma5

    Quote Originally Posted by Tyler_K View Post
    Sure reads like it.

    Try renaming ~/.config/plasma-org.kde.plasma.desktop-appletsrc and then rebooting (plasma will regenerate a new file with default settings) to see if that restores to a proper desktop

    PS - I have a system with the same graphics card as you and it is well served via the oss radeon graphics stack. Disclosure: running Tumbleweed with all the latest available (i.e. X, mesa, plasma, kernel, ... ). Don't believe this has anything to do with graphics drivers, nor that fglrx would bring anything of value to the table for your device.

    Thanks all.I'm able to view the panels and menus and use the KDE normally now by trying the below options.

    Note:However, i have to run the plasmashell manually after each reboot and logging into KDE again.

    1) Renaming the plasma-desktop-appletsrc and rebooting created a new file with default settings as suggested by Tyler_K.
    2) After logging into Plasma press ALT + F2 and run plasmashell.Before doing so . i pressed CTRL + ESC and killed the previous instance of
    plasmashell shell as suggested by wolfi323.

    I've no clue on why I’ve to kill the previous instance of plasmashell and run manually run after logging into KDE.

  9. #9

    Default Re: KDE & Plasma5

    Quote Originally Posted by dhara_chn View Post
    I've no clue on why I’ve to kill the previous instance of plasmashell and run manually run after logging into KDE.
    Never seen something like that either.
    Sounds like a timing issue... (e.g. some system service not ready yet when you are logging in, but working when you restart plasmashell afterwards)

    Do you use Auto-Login?
    Maybe try to disable it (YaST->Security and Users->User and Group Management->Expert Options->Login Settings, or by manually editing /etc/sysconfig/displaymanager), does that help? Does it work if you login a second time after logging out?

    Another thing I'd try is whether it works on a newly created user account.

    One further question: are you maybe using autofs? This is known to cause such a timing issue on some systems.

    A possible hack to not have to restart plasmashell manually would maybe be to *delay* its automatic start, by changing the Exec line in /etc/xdg/autostart/plasmashell.desktop to something like:
    Code:
    Exec=sleep 10; plasmashell --shutup
    You might replace "10" with different values, that's the time in seconds to wait.

    I'd rather do that only as a last resort though, or for a test.

    And note that this change will be overwritten if there is an update to plasma5-desktop, so it might be a better idea to copy the file to ~/.config/autostart/ (this contains user-specific overrides for /etc/xdg/autostart/) and modify it there.

  10. #10

    Default Re: KDE & Plasma5

    It does seems to be a timing issue as i get the below error when i execute plasmashell from konsole.

    "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

    Also i checked kinfocenter and under graphical information ( X-Server) there seems to be a error as mentioned below




    Cannot load library /usr/lib64//qt5/plugins/kcm_info.so


    Possible reasons:
    An error occured during yout last KDE upgrade leaving an orphaned contol module
    you have old third party modules lying around




Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •