Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

  1. #11
    Join Date
    Oct 2013
    Location
    Switzerland
    Posts
    152

    Default AW: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

    Guten Tag und vielen Dank.

    Jetzt bin ich mit Leap42.1 und Konqueror hier (soweit friert noch nichts ein, starte ich den Anwendungsmenü-Editor > so vermute ich, dass PC wieder einfrieren wird und zwar unabhängig von Plasma5 oder KDE-Plasma-Workspace, war nur kurz anscheinend i.O., wie du schreibst beide gleich und deswegen friert auch ab und wann bei beiden das DesktopEnvironm ein)

    KDE-Infozentrum > Grafik: OpenGL > Renderer "Mesa DRI Intel Hswell", Vers. "3.0 Mesa 11.0.8", Kernel Modul "unbekannt" (ist ein i3 mit HD-Grafik 4400 onboard)
    X-Server > "Vers. 11.0"

    Abfragen liefern:
    > /sbin/lspci -nnk | grep -i -A3 vga 00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller [8086:041e] (rev 06) Subsystem: ASRock Incorporation Device [1849:041e]
    Kernel driver in use: i915
    Kernel modules: i915

    > lsmod | grep video video 36864 1 i915

    und im log sieht es auch nicht so unstimmig aus:
    verwendet "VT 7", LoadModule "glx", AIGLX enabled, LoadModule "intel"
    DRI-driver: i965
    VDPAU-driver: i965
    rendering: DRI enabled

    und am Schluss backt Xorg auch noch eine robuste, für meinen Schirm richtige Auflösung
    AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    AIGLX: enabled GLX_ARB_create_context_robustness
    AIGLX: Loaded and initialized i965
    GLX: Initialized DRI2 GL provider for screen 0
    intel(0): switch to mode 1280x1024@60.0 on VGA1 using pipe 0, position (0, 0), rotation normal, reflection none

    ich vermute, dass grafisch kein grundlegendes Problem vorliegt

  2. #12

    Default Re: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

    Quote Originally Posted by Alexander_Search View Post
    ich vermute, dass grafisch kein grundlegendes Problem vorliegt
    Der Intel-Treiber ist in Verwendung, ja.
    Allerdings hat (bzw. hatte) der einen argen Bug, der auf bestimmten Systemen unter anderem Abstürze von Plasma5 und anderen Anwendungen die OpenGL verwenden verursachen konnte.

    Es wäre vielleicht einen Versuch wert auf die ältere (aber stabile) UXA-Beschleunigung zurückzuschalten. Dazu einfach eine Datei /etc/X11/xorg.conf.d/20-intel.conf anlegen, mit folgendem Inhalt:
    Code:
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "uxa"
    EndSection
    Danach neu starten.
    Falls es nicht hilft, lösche die Datei besser wieder, normalerweise läuft die neue SNA Beschleunigung besser, und vor allem schneller.

    Ich weiß aber nicht sicher, ob die Version in Leap 42.1 davon betroffen ist oder nicht.
    Und wenn ich dich richtig verstehe, hast du das Problem nur mit dem Menüeditor, richtig? Wär dann eher unwahrscheinlich dass es mit dem Grafiktreiber zusammenhängt.

    Wie schonmal geschrieben, könnte es aber mit KDE's "Systemkonfigurations-Cache" zusammenhängen, der eben u.a. die Menüeinträge enthält, und neu aufgebaut wird wenn du diese änderst.
    Deswegen wäre es interessant zu wissen, ob das Problem auch mit einem frischen Benutzeraccount auftritt.
    Und/oder lösche mal wie gesagt testweise den Ordner ~/.cache/, bzw. im speziellen die Dateien ~/.cache/ksycoca*.

  3. #13
    Join Date
    Oct 2013
    Location
    Switzerland
    Posts
    152

    Default AW: Re: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

    auf eine UXA-Beschleunigung, oder generell an der Grafik möchte ich (vorerst) nicht rumfimmeln, mir scheint dies i.O. Trotzdem lieben Dank für den Tipp.
    Und wenn ich dich richtig verstehe, hast du das Problem nur mit dem Menüeditor, richtig?
    Nein, wollte den User-Cache mit Dolphin (as user) löschen > PC eingefroren (wobei dort gibts wohl auch Dateirechte only for root). Ich werde das nachholen aus der root-Konsole (inkl. ~/.cache/ksycoca* sofern vorhanden) sämtlichen user-Cache löschen.
    Kwrite z.B. über das Anwendungsmenü (as user) gestartet, friert ebenso ein, sobald ich z.B. "Bearbeiten > einfügen/speichern/usw." möchte. Starte ich hingegen kwrite aus der root-Konsole so meine ich dass es funktioniert. (Berechtigungsgeschichte? komisch)

    danach setze ich mal sämtliche Einstellungen > KDE > Systemeinstellungen soweit möglich (dies habe/konnte ich im Leap weitgehenst noch nicht gemacht, Systemschrift, Design, usw.) plus Neustart.

    Deswegen wäre es interessant zu wissen, ob das Problem auch mit einem frischen Benutzeraccount auftritt.
    danach (falls erforderlich), werde ich einen zusätzlichen User anlegen

  4. #14

    Default Re: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

    Quote Originally Posted by Alexander_Search View Post
    Nein, wollte den User-Cache mit Dolphin (as user) löschen > PC eingefroren (wobei dort gibts wohl auch Dateirechte only for root).
    Sollte nicht so sein. Obwohl, wenn du Dateien da drin hast die root gehören, kann genau das deine Probleme verursachen.
    Das ist ein *Benutzer*-Cache.

    Ich werde das nachholen aus der root-Konsole (inkl. ~/.cache/ksycoca* sofern vorhanden) sämtlichen user-Cache löschen.
    Wenn du als root angemeldet bist, ist ~/.cache/ natürlich der Cache für root, nicht des normalen Benutzers.
    In dem Fall lösche /home/username/.cache/.

    Kwrite z.B. über das Anwendungsmenü (as user) gestartet, friert ebenso ein, sobald ich z.B. "Bearbeiten > einfügen/speichern/usw." möchte. Starte ich hingegen kwrite aus der root-Konsole so meine ich dass es funktioniert. (Berechtigungsgeschichte? komisch)
    Vermutlich. Könnte auf ein Berechtigungsproblem in ~/.cache/ (des Benutzers) hindeuten.

  5. #15
    Join Date
    Oct 2013
    Location
    Switzerland
    Posts
    152

    Default AW: Re: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

    Sollte nicht so sein. Obwohl, wenn du Dateien da drin hast die root gehören, kann genau das deine Probleme verursachen.
    Das ist ein *Benutzer*-Cache.
    Ist auch nicht so > dort gehört alles dem "user1"
    Wenn du als root angemeldet bist, ist ~/.cache/ natürlich der Cache für root
    das weiss ich ausnahmsweise
    Vermutlich. Könnte auf ein Berechtigungsproblem in ~/.cache/ (des Benutzers) hindeuten.
    Nein, damit gibts kein Problem

    ein Zwischenbericht:
    ~/.cache/ksycoca* (des "user1") habe ich gelöscht
    "user1" besitzt in ~/.config/session/ eine Datei "Kwin_1011acc9ede000....402732" (ist irgend eine Kwin-Fensterverhalten-Datei)
    "user1" besitzt in ~/.config/ eine Datei "plasma-locale-settings.sh" (sollte wohl kein Problem darstellen)

    Inzwischen habe ich ein "user2" (neuer Nutzer) angelegt (aufgrund des Einfrierens, jeweils mit YaST)
    die beiden "user" besitzen verschiedene UID (was doch sein muss, user1 ca. 1417 und user2 ca. 1000) und beide sind Mitglied der Gruppe users

    im ~/ des "user1" (der mal bei dieser mal bei der anderen Anwendung einfriert) gibt es:
    ~/.java (sollte soweit noch kein Problem darstellen, jedoch im ~/ des "user2" gibt es noch kein .java-Ordner, liegt wohl daran, dass ich als "user2" noch kein libreOffice/Calligra gestartet habe, resp. noch keine Office-Einrichtung-Optionen angewählt habe)
    ~/.recently-used (was wohl auch normal ist)
    ~/.hugin (diese SW-Pakete habe ich deinst. und somit kann ich diesen Ordner getrost löschen, denn dies kommt noch vor der Deinst. der Hugin-Pakete)
    beim "user1" hatte ich die Ordner Öffentlich, public_html und Vorlagen gelöscht (sind keine Speicherorte in > KDE > Systemeinstellungen, somit kein Problem)
    interessanter ist wohl folgendes
    ~/.ptbt0 (eine Datei, geöffnet mit Kwrite > steht eine 1 und sonst nix > werde ich löschen)
    ~/.xdg_menu_cache (könnte dies ein Blocker-Einfrierer sein?)

    "user2" besitzt all die vorab erwähnten Dateien/Ordner nicht (dafür Folgende)
    die Ordner Öffentlich, public_html, Vorlage (=standard)
    und eine Datei ~/.gnu-emacs ("user1" besitzt die nicht, hingegen besitzen beide ~/.emacs)

    Inzwischen funktioniert das Anwendungs-Menü-Editieren bei beiden usern relativ stabil (meist i.O.) und erfreulicherweise funktioniert YaST2 bei "user2" 100% und bei "user1" inzwischen glaub auch, bin mir jedoch nicht sicher.
    Dolphin als Super-User fror auch beim "user2" ein!
    beim Einrichten von Konqueror als "user2" fror der PC ebenfalls ein!
    > KDE > Systemeinstellungen sind inzwischen bei beiden sehr ähnlich (Oxygen-Design, Plastik-Fenster, Systemschrift/Schriften Nimbus Sans L, Standardanwendungen für Dateiverwaltung/Mail/Browsen/ usw.)

    ich habe noch keine Desktop-Oberfläche für root eingerichtet und auch nicht im Anmeldemanager gelistet, Anmeldemanager funktioniert ganz gut.
    ich muss bei "user2" zuerst noch weiter einrichten. z.B. Konqueror-Profile, Unterordner und Einträge für das Anwendungsstartmenü angleichen (Symbolsatz-Zeug ist kein Problem)

    interessant ist noch dies:
    im /tmp sind immer noch diese Dateien
    > sddm-i0-jkhpuB
    > sddm-auth.... (davon ca. 18 Stk., heute und gestern generiert)
    die kann ich obwohl der Anmeldemanager inzwische funktioniert noch nicht löschen, oder doch?

    und im / sind noch
    > klauncherXMxxxxxx.1.slave-socket (0 Byte Dateien, 4 Stk. von heute und 2 vom 14.1.2016, davon sollte es pro user und root doch max. eine geben, wenn überhaupt?)

    und last bot not least
    im Startprotokoll läuft ein "a job-stop is running" dauert ca. 2-3 sec. > das ist nicht koscher.

    ich werds hinkriegen, vielen Dank.

  6. #16

    Default Re: default-vga-Wert "" in /etc/sysconfig/ UND Menü mutieren in Leap 42.1

    Quote Originally Posted by Alexander_Search View Post
    Ist auch nicht so > dort gehört alles dem "user1"
    Also doch nicht?
    Oder hast du inzwischen alles gelöscht?

    "user1" besitzt in ~/.config/session/ eine Datei "Kwin_1011acc9ede000....402732" (ist irgend eine Kwin-Fensterverhalten-Datei)
    Kannst du löschen, sollte aber auch kein Problem darstellen.
    Das sind die Dateien von der Sitzungsverwaltung, wo die Anwendungen beim Logout ihren aktuellen Status speichern.

    "user1" besitzt in ~/.config/ eine Datei "plasma-locale-settings.sh" (sollte wohl kein Problem darstellen)
    Nein, das setzt die Benutzersprache.

    im ~/ des "user1" (der mal bei dieser mal bei der anderen Anwendung einfriert) gibt es:
    ~/.java (sollte soweit noch kein Problem darstellen, jedoch im ~/ des "user2" gibt es noch kein .java-Ordner, liegt wohl daran, dass ich als "user2" noch kein libreOffice/Calligra gestartet habe, resp. noch keine Office-Einrichtung-Optionen angewählt habe)
    Ja. Oder irgendeine andere Java-Anwendung.

    ~/.recently-used (was wohl auch normal ist)
    Beinhaltet zuletzt geöffnete Dokumente/Programme, wird aber von KDE nicht verwendet soweit ich weiß.

    ~/.hugin (diese SW-Pakete habe ich deinst. und somit kann ich diesen Ordner getrost löschen, denn dies kommt noch vor der Deinst. der Hugin-Pakete)
    Richtig. Aber sollte auch keine Probleme in KDE verursachen.

    beim "user1" hatte ich die Ordner Öffentlich, public_html und Vorlagen gelöscht (sind keine Speicherorte in > KDE > Systemeinstellungen, somit kein Problem)
    Sollten auch keine Probleme verursachen.
    Übrigens, sie würden sowieso automatisch angelegt wenn sie in KDE's Systemeinstellungen als Speicherorte festgelegt wurden...

    interessanter ist wohl folgendes
    ~/.ptbt0 (eine Datei, geöffnet mit Kwrite > steht eine 1 und sonst nix > werde ich löschen)
    Keine Ahnung was das sein könnte, wird aber sicher nicht von KDE verwendet. Ich hab sie auf meinem System jedenfalls nicht.

    ~/.xdg_menu_cache (könnte dies ein Blocker-Einfrierer sein?)
    Theoretisch könnte das sein. Da es nur ein Cache des Anwendungsmenü ist, kannst du den Ordner bedenkenlos löschen.
    Bin mir nicht sicher, aber ich glaube dass das von KDE eher auch nicht verwendet wird (KDE hat ja sowieso seinen eigenen Cache).

    "user2" besitzt all die vorab erwähnten Dateien/Ordner nicht (dafür Folgende)
    die Ordner Öffentlich, public_html, Vorlage (=standard)
    und eine Datei ~/.gnu-emacs ("user1" besitzt die nicht, hingegen besitzen beide ~/.emacs)
    Ist aber auch nur eine Einstellungsdatei für Emacs, irrelevant für KDE.

    Inzwischen funktioniert das Anwendungs-Menü-Editieren bei beiden usern relativ stabil (meist i.O.) und erfreulicherweise funktioniert YaST2 bei "user2" 100% und bei "user1" inzwischen glaub auch, bin mir jedoch nicht sicher.
    Ist ja zumindest ein Fortschritt.
    YaST läuft als root, sollte also egal sein unter welchem Benutzer du es ausführst.

    Dolphin als Super-User fror auch beim "user2" ein!
    Machst du irgendwas bestimmtes?
    Z.B. ists ein bekanntes Problem dass dolphin (Super-User) einfriert wenn du /dev/ öffnest, sh. https://bugzilla.opensuse.org/show_bug.cgi?id=957006. Das ist ein Fehler in Qt5 der in 5.6 behoben sein wird, wir werden aber wohl ein Update für Leap 42.1 auch veröffentlichen.

    beim Einrichten von Konqueror als "user2" fror der PC ebenfalls ein!
    Hm. Konqueror ist eine KDE4 Anwendung, die Caches sind in /var/tmp/kde-user1 oder ähnlich.
    Lösche die auch mal, eigtl. kannst du alles in /tmp/ oder /var/tmp/ löschen.

    Aber so ein Problem in KDE4 wär mir neu.

    > KDE > Systemeinstellungen sind inzwischen bei beiden sehr ähnlich (Oxygen-Design, Plastik-Fenster, Systemschrift/Schriften Nimbus Sans L, Standardanwendungen für Dateiverwaltung/Mail/Browsen/ usw.)
    Ich habe davon gehört das gewisse Leute mit der Plastik Dekoration Probleme hatten (Abstürze).
    Probier mal was anders (Breeze oder Oxygen), vielleicht hilfts.

    interessant ist noch dies:
    im /tmp sind immer noch diese Dateien
    > sddm-i0-jkhpuB
    > sddm-auth.... (davon ca. 18 Stk., heute und gestern generiert)
    die kann ich obwohl der Anmeldemanager inzwische funktioniert noch nicht löschen, oder doch?
    Sind temporäre Dateien, und werden vom Anmeldemanager angelegt.

    und im / sind noch
    > klauncherXMxxxxxx.1.slave-socket (0 Byte Dateien, 4 Stk. von heute und 2 vom 14.1.2016, davon sollte es pro user und root doch max. eine geben, wenn überhaupt?)
    Nein, die werden immer angelegt wenn du ein KDE5 Programm als root startest. Ist ein Bug, würde ich sagen, aber ein harmloser.

    und last bot not least
    im Startprotokoll läuft ein "a job-stop is running" dauert ca. 2-3 sec. > das ist nicht koscher.
    2-3 Sekunden ist ja nicht so viel.
    Ob das koscher ist oder nicht, hängt davon ab was für ein Dienst das ist.

    Die Startzeiten bei mir:
    Code:
    wolfi@amiga:~> systemd-analyze blame
         1min 9.384s apache2.service
         1min 7.418s mysql.service
             50.826s ModemManager.service
             48.071s vmware.service
             47.220s nmb.service
             44.781s NetworkManager.service
             37.952s lirc.service
             23.080s hddtemp.service
             18.630s vmamqpd.service
             15.261s rsyslog.service
             15.135s dev-sda1.device
             12.270s lm_sensors.service
             11.581s vmware-USBArbitrator.service
             10.849s avahi-daemon.service
             10.431s wpa_supplicant.service
             10.379s vboxdrv.service
              8.606s smb.service
              7.751s systemd-tmpfiles-setup.service
              7.575s polkit.service
              4.619s sshd.service
              4.524s systemd-random-seed.service
              4.236s dev-hugepages.mount
              4.234s sys-kernel-debug.mount
              4.227s dev-mqueue.mount
              3.970s systemd-fsck-root.service
              3.800s nscd.service
              3.533s alsa-restore.service
              3.473s systemd-user-sessions.service
              3.465s systemd-udev-trigger.service
              3.450s rc-local.service
              3.190s postfix.service
              3.066s display-manager.service
              2.969s systemd-tmpfiles-setup-dev.service
              2.906s systemd-udev-settle.service
              1.720s iscsi.service
              1.655s isapnp.service
              1.541s lvm2-activation-early.service
    Du siehst also, 2-3 Sekunden ist nicht wirklich ungewöhnlich, hängt eben vom Dienst ab und natürlich auch von deinem System.
    Die Dienste werden sowieso parallel gestartet, also verzögert das auch nicht unbedingt den Bootvorgang.

    ich werds hinkriegen, vielen Dank.
    Ich hoffe doch...

    Da fällt mir ein: lösche auch mal ~/.kde4/share/apps/kbookmarks/, ~/.local/share/kbookmarks/ und ~/.local/share/user-places.xbel, die enthalten die Benutzer-"Orte" für dolphin und dem Dateidialog.
    Es gab Fälle wo die immer größer wurden (Gigabytes), und Dolphin/Konqueror oder sogar Plasma zum Absturz bzw. Einfrieren brachten.
    Last edited by wolfi323; 19-Jan-2016 at 06:32.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •