Results 1 to 6 of 6

Thread: Zypper: the following application is going to be REMOVED: "Search and Indexing"

  1. #1

    Default Zypper: the following application is going to be REMOVED: "Search and Indexing"

    Hi,
    every time I run "zypper dup" I get this message:
    Code:
    The following application is going to be REMOVED:
      "Search and Indexing"
    Everytime.
    I'm thinking that it doesn't really want to remove it.
    Ideas?

    Many thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,850
    Blog Entries
    15

    Default Re: Zypper: the following application is going to be REMOVED: "Search and Indexing"

    Quote Originally Posted by horizonbrave View Post
    Hi,
    every time I run "zypper dup" I get this message:
    Code:
    The following application is going to be REMOVED:
      "Search and Indexing"
    Everytime.
    I'm thinking that it doesn't really want to remove it.
    Ideas?

    Many thanks
    Hi
    That's part of tracker, what if you just run zypper up instead?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Mar 2015
    Location
    Copenhagen Denmark
    Posts
    115

    Default Re: Zypper: the following application is going to be REMOVED: "Search and Indexing"

    I tested GNOME with Tumbleweed recently and got the same message. I seems quite impossible to get rid of, I spend at least an
    hour on it with no such luck.

    Bo

  4. #4

    Default Re: Zypper: the following application is going to be REMOVED: "Search and Indexing"

    That's (likely) a bug in libzypp/libsolv's appstream metadata handling.
    Apparently this is a regression, caused by a fix for similar "error" messages about real applications in the past.

    See similar bug reports:
    http://bugzilla.opensuse.org/show_bug.cgi?id=961738
    http://bugzilla.opensuse.org/show_bug.cgi?id=961865

    Earlier, before the last fix, this happened with things like Firefox, Thunderbird, a lot of KDE applications (like Ark, digikam, dolphin), even freeciv...
    See https://bugzilla.novell.com/show_bug.cgi?id=952324 and its duplicates, https://bugzilla.opensuse.org/show_bug.cgi?id=926865 in particular.
    Now this only seems to happen with plugins/extensions for other programs (which didn't have this problem before).

    You can just ignore that message though, zypper won't remove anything.
    It just doesn't recognize that the updates that are going to be installed do actually contain this "application" (note that it says "application", not package) as well and therefore thinks it's going to be removed.

  5. #5

    Default Re: Zypper: the following application is going to be REMOVED: "Search and Indexing"

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That's part of tracker, what if you just run zypper up instead?
    same same

  6. #6

    Default AW: Re: Zypper: the following application is going to be REMOVED: "Search and Indexing"

    Quote Originally Posted by horizonbrave View Post
    same same
    The latest comment (in the bug report I mentioned) suggests that in that case it's a "packaging mistake" in digikam (it shouldn't specify the plugins/extensions if they are in the main package).

    So you should probably file a new bug report about tracker.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •