Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Dolphin kf5 / Select Login Screen Buggy as..

  1. #1

    Default Dolphin kf5 / Select Login Screen Buggy as..

    Can not select 'Login Screen' (SDDM) cleanly at all (never have been able to on 5.5.x). Every time I click the (left side) button it does nothing (default stays at Auto Start panel)

    I have to either 1) hit the expand window icon in the top right or 2) click the button above (Desktop Session) then re-click the Login Screen button - to get the right side panel to appear properly, which it does after the right panel freeze.

    It's all very glitch-y and the entire window can go transparent (like I'm out of memory) until I hit max / min window button which refocuses things.

    If I want to do a simple login theme change it can take up to 5 minutes messing about - it does work (well there is one other problem but I'll mention that last) but it's not a smooth operation. I can select Auto Start / Background Services / Desktop Session no trouble and they work fine, and if I toggle between this 'button switching' and the contents of 'Login Screen' I can get there, but it's not right.

    The last issue is with the change of theme, Breeze. If I log out and back in quickly, I get the opensuse branding lightbulb and not KDE branding. If I look in yast under SDDM it seems that opensuse branding is tied to it.

    Known bugs, thanks?
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  2. #2

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Quote Originally Posted by david_banner View Post
    Can not select 'Login Screen' (SDDM) cleanly at all (never have been able to on 5.5.x). Every time I click the (left side) button it does nothing (default stays at Auto Start panel)
    Known problem, see here e.g.:
    https://forums.opensuse.org/showthre...-sddm-settings
    A workaround is to click on any of the buttons (e.g. Help or Defaults, move the mouse away again before releasing the mouse button to not actually trigger the action), that should refresh the window content.

    This only happens with the breeze widget style though, so switching to e.g. Oxygen fixes it. (you might have to install oxygen5-style first though)

    I think I saw a patch to fix a similar problem, so this might be fixed soon (in Breeze) as well.

    Btw, this only happens since Plasma 5.5 AFAIR. But Leap only has 5.4.3 and shouldn't be affected.
    Are you using additional repos?

    The last issue is with the change of theme, Breeze. If I log out and back in quickly, I get the opensuse branding lightbulb and not KDE branding. If I look in yast under SDDM it seems that opensuse branding is tied to it.
    If I understand you correctly, this is not related to sddm or its settings.
    When logging in, you see Plasma5's splash screen, and the openSUSE one is the default.
    You can choose it in "Configure Desktop"->"Workspace Theme"->"Splash Screen".
    Or do you mean the desktop's wallpaper? Well, that can be configured as well of course, actually in the same way as in KDE4 (right-click on the desktop or left-click on the toolbox icon in the upper-left corner and select "Desktop Settings", or just drag and drop an image file onto your desktop).

    Btw, you specify "Dolphin" in the subject, how is anything you posted related to dolphin?
    Last edited by wolfi323; 14-Jan-2016 at 06:59.

  3. #3

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    It doesn't, I was just testing you.

    (and I can't seem to edit the title after a short period).

    Yeah, I figured the workaround, provided it's known it's ok. I'm on the 5.5 repo (Frameworks 5 & Plasma 5) btw.

    If I understand you correctly, this is not related to sddm or its settings.
    When logging in, you see Plasma5's splash screen, and the openSUSE one is the default.
    You can choose it in "Configure Desktop"->"Workspace Theme"->"Splash Screen".
    I do actually mean that. It is set to Breeze but I get the opensuse light bulb first, then get the KDE splash directly after login. So pre-login = bulb splash. After login = KDE breeze.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  4. #4

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Quote Originally Posted by david_banner View Post
    It doesn't, I was just testing you.
    Works fine here. And actually you don't mention at all that you tried what I told you, i.e. click on the "Defaults" or "Help" button.

    (and I can't seem to edit the title after a short period).
    You can only edit a post for 10 minutes.
    The reason is that the forum is also accessable via NNTP ("Usenet News"), after 10 minutes the two sides are synchronized.
    Changing a post here afterwards would only create chaos.

    I'm on the 5.5 repo (Frameworks 5 & Plasma 5) btw.
    I thought so.
    That's something that's better mentioned explicitly though...
    In the end you are not using the Plasma/KF5 from Leap 42.1 at all, and this thread doesn't apply to/is not about Leap 42.1, strictly speaking.

    I do actually mean that. It is set to Breeze but I get the opensuse light bulb first, then get the KDE splash directly after login. So pre-login = bulb splash. After login = KDE breeze.
    Maybe it's plymouth's boot splash then. Try to disable plymouth by adding "plymouth.enable=0" to the kernel command line, and see if it still happens.

    PS: regarding "If I look in yast under SDDM it seems that opensuse branding is tied to it. "
    The package sddm-branding-openSUSE does not contain any files nor does it influence the background. It just switches the theme to "breeze" when it's being installed, and requires the packages necessary to actually use the "breeze" theme (the theme itself is part of plasma5-workspace).
    You can install sddm-branding-upstream instead, but it won't change anything really.

  5. #5

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Works fine here. And actually you don't mention at all that you tried what I told you, i.e. click on the "Defaults" or "Help" button.

    I have to either 1) hit the expand window icon in the top right or 2) click the button above (Desktop Session) then re-click the Login Screen button - to get the right side panel to appear properly, which it does after the right panel freeze.
    I can select Auto Start / Background Services / Desktop Session no trouble and they work fine, and if I toggle between this 'button switching' and the contents of 'Login Screen' I can get there.
    I said it there, it does the same thing you said, it refreshes eventually but it can take a (relatively) long time sometimes to complete the whole operation. No biggy now I know it's a bug though.

    I thought so.
    That's something that's better mentioned explicitly though...
    In the end you are not using the Plasma/KF5 from Leap 42.1 at all, and this thread doesn't apply to/is not about Leap 42.1, strictly speaking.
    Get the web admin team to edit that Prefix drop down and insert your repo title as well (or 'wolfi repos'). I can barely remember my own name half the time.

    PS: regarding "If I look in yast under SDDM it seems that opensuse branding is tied to it. "
    The package sddm-branding-openSUSE does not contain any files nor does it influence the background. It just switches the theme to "breeze" when it's being installed, and requires the packages necessary to actually use the "breeze" theme (the theme itself is part of plasma5-workspace).
    You can install sddm-branding-upstream instead, but it won't change anything really.
    Right, that clears that up. That's what kick started all this off, me noticing that and assuming it was all tied up in 'SDDM'

    Maybe it's plymouth's boot splash then. Try to disable plymouth by adding "plymouth.enable=0" to the kernel command line, and see if it still happens.
    Will try in a bit when I reboot. Thanks.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  6. #6

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Quote Originally Posted by david_banner View Post
    I said it there, it does the same thing you said, it refreshes eventually but it can take a (relatively) long time sometimes to complete the whole operation.
    Again, you don't have to switch to a different module and back, and I don't think that even helps.
    It refreshes immediately here as soon as I click on "Help" or "Defaults".
    But resizing/maximizing the window might work as well, never tried that yet.

    Get the web admin team to edit that Prefix drop down and insert your repo title as well (or 'wolfi repos'). I can barely remember my own name half the time.
    Sorry, that's not maintainable.
    Should it offer all possible repos that are available? And what if you use more than one additional repo?

    Just mention such things in your post(s) in the future. You did mention that you are using 5.5.x though, just not where you installed it from.
    That's just a suggestion to avoid misunderstandings, and replies like "I don't have the problem here"...

  7. #7

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Sorry, that's not maintainable.
    Should it offer all possible repos that are available? And what if you use more than one additional repo?
    You are the only person offering a current KDE that the majority of people use on here? The bulk of people who are regular KDE users will be using your repo at some point, even if it is only to try out. Can't see the big deal.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  8. #8

    Default AW: Re: Dolphin kf5 / Select Login Screen Buggy as..

    Quote Originally Posted by david_banner View Post
    You are the only person offering a current KDE that the majority of people use on here?
    No, I'm not the only one.

    The latest KF5 is available from the "official" KDE:Frameworks5 too (that is *not* "my" repo).
    And actually I don't supply neither breeze nor systemsettings5 nor kcm_sddm in my repo...

    But the main point was that it's not a problem with the versions included in Leap. You did specify using 5.5.x, so sorry for even writing that.
    Last edited by wolfi323; 14-Jan-2016 at 09:22.

  9. #9

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Maybe it's plymouth's boot splash then. Try to disable plymouth by adding "plymouth.enable=0" to the kernel command line, and see if it still happens.
    Nah, still happens, I get text display right up until the login screen with the dark background and light bulb, then login and get the breeze 5.5 splash animation.

    Looks like you have to point it to the right image in /usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/splash/Splash.qml then specify the image you want

    Code:
    source: "../components/artwork/background.png"
    I think?
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  10. #10

    Default Re: Dolphin kf5 / Select Login Screen Buggy as..

    Quote Originally Posted by david_banner View Post
    Nah, still happens, I get text display right up until the login screen with the dark background and light bulb, then login and get the breeze 5.5 splash animation.
    So you are really talking about the background of the login screen?
    Sorry, you weren't really very clear there, I thought that one is the KDE one, and the lightbulb appears after you login.

    Looks like you have to point it to the right image in /usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/splash/Splash.qml then specify the image you want

    Code:
    source: "../components/artwork/background.png"
    I think?
    No, you shouldn't change the installed files, your changes will get lost on updates anyway.
    It is true that the breeze theme uses Plasma's default wallpaper though, which is the lighbulb image in Leap.

    It should work if you specify a different background in the SDDM systemsettings module.

    Or install plasma5-workspace-branding-upstream instead of plasma5-workspace-branding-openSUSE. The latter changes the default KDE wallpaper to the lightbulb. But that will also change other Plasma/KF5 default settings to the upstream defaults.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •