Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

  1. #1
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    The Title says it all.... I just did a software update of the "KDE Frameworks 5 & Plasma 5" Repository which apparently was updating from Plasma 5.5.2 to 5.5.3 and I am now getting a black screen following login. The repo that I am using is:

    http://download.opensuse.org/reposit...USE_Leap_42.1/

    When I arrive at the black screen, I cannot access a shell with <ctlr><alt>-F1 either. I thought that it may have to do with a Plasma 5 user setting in my directory so I rebooted to run level 2 where I renamed ~/.kde4, however, I continued to get the blackscreen after login then as well. Everything acts normally after login including the display of the green gecko, the progress bar and the login sound. Then immediately after the login sound the screen goes black and I cannot do anything to recover except do a forced shutdown by holding my power button down.

    Fortunately, I did an rsync backup immediately prior to the update so I have now recovered to my previous state prior to the update. I have tried updating several times both with YaST and "zypper up" and I get the same crummy result each time.

    I added this repo on Monday of this week with YaST and switched system packages immediately thereafter so I do not believe that I have a conflict between repos.

    Does anybody have any recommendations for me to successfully do the update? Has anybody else running this repo had this problem?

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  2. #2

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    Quote Originally Posted by gldickens3 View Post
    The Title says it all.... I just did a software update of the "KDE Frameworks 5 & Plasma 5" Repository which apparently was updating from Plasma 5.5.2 to 5.5.3 and I am now getting a black screen following login. The repo that I am using is: http://download.opensuse.org/reposit...USE_Leap_42.1/ When I arrive at the black screen, I cannot access a shell with -F1 either. I thought that it may have to do with a Plasma 5 user setting in my directory so I rebooted to run level 2 where I renamed ~/.kde4, however, I continued to get the blackscreen after login then as well. Everything acts normally after login including the display of the green gecko, the progress bar and the login sound. Then immediately after the login sound the screen goes black and I cannot do anything to recover except do a forced shutdown by holding my power button down. Fortunately, I did an rsync backup immediately prior to the update so I have now recovered to my previous state prior to the update. I have tried updating several times both with YaST and "zypper up" and I get the same crummy result each time. I added this repo on Monday of this week with YaST and switched system packages immediately thereafter so I do not believe that I have a conflict between repos. Does anybody have any recommendations for me to successfully do the update? Has anybody else running this repo had this problem? Thanks, Gordon
    What is level 2? Somebody says you can't properly remove .kde with KDE running.

  3. #3
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    When you boot into run level 2 then X-Windows and the Desktop GUI are not loaded. See:

    http://www.tldp.org/LDP/sag/html/run-levels-intro.html
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    I use that repository and had some headaches (which I fixed) did you do a dup with KDE:/Frameworks5 because it sounds you have mixed incompatible packages from both repositories.
    How to fix it, it depends do you have another desktop, Icewm should be there and should work, if you can logon to Icewm and do a full vendor change with KDE:/Frameworks5, execute
    Code:
    zypper lr -d
    zyppre dup --from <put KDE:/Frameworks5 alias or number here> --from <put packman alias or number here>
    (use packman too as to keep your multimedia from braking)
    or post your repo list and we can try to help.
    If Linux goes straught to plasma 5, hit ctrl+alt+backspace 2 times to kill X and return to the logon screen,
    If sddm does not work then
    at grub before booting hit the 'e' key and add the number 3 at the end of the boot command, that will boot you in run level 3 ie text mode, from there you can do zypper lr -d and zypper dup --from

  5. #5
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    Hello I_A,

    Thanks very much for your reply. I am confident that I do not have a problem with mixed up packages from conflicting repos. Nevertheless, I did the zypper dup again but the problem remained with a black screen after login. Also, I had previously created a guest user account which I am able to login to. So, I suspect that the problem may have something to do with some incompatibility with my user settings and Plasma 5.5.3 that was OK with Plasma 5.5.2.

    I looked at "journalctl -b" and posted an abbreviated version of the log here:

    http://dickens.com/download/journalctl.txt

    My login is successful on line 24 of the abbreviated log as follows:

    Jan 10 14:04:46 hippo sddm-greeter[1405]: Message received from daemon: LoginSucceeded

    I am confident that the black screen then occurred by the time stamp of Jan 10 14:03:49.

    I am not very familiar with systemd and I don't see anything suspicious about the log.
    Do you see anything in the log that may give us a clue as to what the problem is? Please
    let me know if you have any other suggestions.

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    unless you have some important data (emails/passwords) you could simply delete the old plasma config files from the 2nd account, hunting down a bad setting might take forever.
    My problem was that I installed newer kde5 apps from KDE:Extra and they wore killing dolphin so I did a dup to the OSS and Update repo's to get everything back and then a 2nd dup to kde:frameworks5 repo to get plasma 5.5

  7. #7
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    Yes, I had already renamed ~/.config and I am now able to log on to my user account which, of course, is now a clean slate without any of my previous configurations, panels, icons, etc. So, I guess that I will have to then rebuild my desktop. What a bummer..... KDE Plasma 5 has been causing me all kinds of headaches and this is just the icing on the cake. I wish that I had never upgraded from 13.2 to Leap 42.1. 13.2 ran fine and did not have all of these bugs that are present in Plasma 5. IMHO, the current versions of Plasma 5 are all a POS.

    I_A, thanks for your help. Please let me know if you or anybody else has any ideas on how to recover my desktop user settings so that I don't have to build every thing all over again. Otherwise, I guess that is what I'm gonna have to do.

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    well if you switch from kde:frameworks5 to wolfi's Frameworks5 repo you can install kde4 and have both plasma 5.5 and kde4 running under leap, I'm thinking about doing just that.
    http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_42.1/

  9. #9
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    How does wolfi's repo work with respect to the home directory? That is, are both KDE4 and Plasma5 settings saved in the same home directory and then the user chooses to either run KDE4 or Plasma5 when they log in?

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Black Screen After Login Following "KDE Frameworks 5 & Plasma 5" Repository Update

    KDE4 in in the ~./kde4 directory and Plasma 5 is now in ~/.config

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •