Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: KDE and plasma5 crashes

  1. #1

    Default KDE and plasma5 crashes

    Reason: libthread_db.so.1 problem

    KDE message:
    "The appropriate fix has been submitted to openSUSE Tumbleweed and Leap: it's not a KDE software bug, but a PulseAudio one. See http://bugzilla.opensuse.org/show_bug.cgi?id=950487 for details."

    If I delete pulseaudio I can not get login screen...
    Any idea?

  2. #2

    Default Re: KDE and plasma5 crashes

    Developer message:


    Application: Plasma (plasmashell), signal: Aborted
    Using host libthread_db library "/lib64/libthread_db.so.1".
    [Current thread is 1 (Thread 0x7fd3f655d900 (LWP 5633))]

    Thread 6 (Thread 0x7fd3d3916700 (LWP 5648)):
    #0 0x00007fd3ef286cfc in __lll_lock_wait () at /lib64/libpthread.so.0
    #1 0x00007fd3ef280bb2 in pthread_mutex_lock () at /lib64/libpthread.so.0
    #2 0x00007fd3eb532fcc in () at /usr/lib64/libGL.so.1
    #3 0x00007fd3eb537b11 in () at /usr/lib64/libGL.so.1
    #4 0x00007fd3eb537fbb in () at /usr/lib64/libGL.so.1
    #5 0x00007fd3e7160ff0 in () at /usr/lib64/tls/libnvidia-tls.so.352.63
    #6 0x00007fd3ec155210 in () at /usr/lib64/libglib-2.0.so.0
    #7 0x00007fd3ec112d94 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
    #8 0x00007fd3ec113208 in () at /usr/lib64/libglib-2.0.so.0
    #9 0x00007fd3ec11336c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
    #10 0x00007fd3f039d52b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #11 0x00007fd3f034763a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #12 0x00007fd3f0173b1c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
    #13 0x00007fd3f34749a5 in () at /usr/lib64/libQt5Qml.so.5
    #14 0x00007fd3f017894f in () at /usr/lib64/libQt5Core.so.5
    #15 0x00007fd3ef27e4a4 in start_thread () at /lib64/libpthread.so.0
    #16 0x00007fd3efa88bdd in clone () at /lib64/libc.so.6

    Thread 5 (Thread 0x7fd3c7cae700 (LWP 5649)):
    #0 0x00007fd3ef286d9a in __lll_unlock_wake () at /lib64/libpthread.so.0
    #1 0x00007fd3ef282121 in __pthread_mutex_unlock_usercnt () at /lib64/libpthread.so.0
    #2 0x00007fd3eb532ce5 in () at /usr/lib64/libGL.so.1
    #3 0x00007fd3eb538018 in () at /usr/lib64/libGL.so.1
    #4 0x00007fd3e7161001 in () at /usr/lib64/tls/libnvidia-tls.so.352.63
    #5 0x00007fd3ec155210 in () at /usr/lib64/libglib-2.0.so.0
    #6 0x00007fd3ec112d94 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
    #7 0x00007fd3ec113208 in () at /usr/lib64/libglib-2.0.so.0
    #8 0x00007fd3ec11336c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
    #9 0x00007fd3f039d52b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #10 0x00007fd3f034763a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #11 0x00007fd3f0173b1c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
    #12 0x00007fd3f34749a5 in () at /usr/lib64/libQt5Qml.so.5
    #13 0x00007fd3f017894f in () at /usr/lib64/libQt5Core.so.5
    #14 0x00007fd3ef27e4a4 in start_thread () at /lib64/libpthread.so.0
    #15 0x00007fd3efa88bdd in clone () at /lib64/libc.so.6

    Thread 4 (Thread 0x7fd3c641e700 (LWP 5650)):
    #0 0x00007fd3ef286cfc in __lll_lock_wait () at /lib64/libpthread.so.0
    #1 0x00007fd3ef280bb2 in pthread_mutex_lock () at /lib64/libpthread.so.0
    #2 0x00007fd3eb532fcc in () at /usr/lib64/libGL.so.1
    #3 0x00007fd3eb537b11 in () at /usr/lib64/libGL.so.1
    #4 0x00007fd3eb537fbb in () at /usr/lib64/libGL.so.1
    #5 0x00007fd3e7160ff0 in () at /usr/lib64/tls/libnvidia-tls.so.352.63
    #6 0x00007fd3ec155210 in () at /usr/lib64/libglib-2.0.so.0
    #7 0x00007fd3ec112d94 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
    #8 0x00007fd3ec113208 in () at /usr/lib64/libglib-2.0.so.0
    #9 0x00007fd3ec11336c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
    #10 0x00007fd3f039d52b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #11 0x00007fd3f034763a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #12 0x00007fd3f0173b1c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
    #13 0x00007fd3f34749a5 in () at /usr/lib64/libQt5Qml.so.5
    #14 0x00007fd3f017894f in () at /usr/lib64/libQt5Core.so.5
    #15 0x00007fd3ef27e4a4 in start_thread () at /lib64/libpthread.so.0
    #16 0x00007fd3efa88bdd in clone () at /lib64/libc.so.6

    Thread 3 (Thread 0x7fd3c4a4e700 (LWP 5658)):
    #0 0x00007fd3ef28407f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
    #1 0x00007fd3f5c4ea84 in () at /usr/lib64/libQt5Script.so.5
    #2 0x00007fd3f5c4eac9 in () at /usr/lib64/libQt5Script.so.5
    #3 0x00007fd3ef27e4a4 in start_thread () at /lib64/libpthread.so.0
    #4 0x00007fd3efa88bdd in clone () at /lib64/libc.so.6

    Thread 2 (Thread 0x7fd335d76700 (LWP 5659)):
    #0 0x00007fd3ec1564d4 in g_mutex_unlock () at /usr/lib64/libglib-2.0.so.0
    #1 0x00007fd3ec113376 in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
    #2 0x00007fd3f039d52b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #3 0x00007fd3f034763a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #4 0x00007fd3f0173b1c in QThread::exec() () at /usr/lib64/libQt5Core.so.5
    #5 0x00007fd3f4009e42 in () at /usr/lib64/libQt5Quick.so.5
    #6 0x00007fd3f017894f in () at /usr/lib64/libQt5Core.so.5
    #7 0x00007fd3ef27e4a4 in start_thread () at /lib64/libpthread.so.0
    #8 0x00007fd3efa88bdd in clone () at /lib64/libc.so.6

    Thread 1 (Thread 0x7fd3f655d900 (LWP 5633)):
    [KCrash Handler]
    #6 0x00007fd3ef9d3d38 in raise () at /lib64/libc.so.6
    #7 0x00007fd3ef9d518a in abort () at /lib64/libc.so.6
    #8 0x00007fd3f016682e in () at /usr/lib64/libQt5Core.so.5
    #9 0x00007fd3f40735c4 in () at /usr/lib64/libQt5Quick.so.5
    #10 0x00007fd3f4074545 in () at /usr/lib64/libQt5Quick.so.5
    #11 0x00007fd3f407544e in () at /usr/lib64/libQt5Quick.so.5
    #12 0x00007fd3f0898c3b in QWindow::event(QEvent*) () at /usr/lib64/libQt5Gui.so.5
    #13 0x00007fd3f40ac621 in QQuickWindow::event(QEvent*) () at /usr/lib64/libQt5Quick.so.5
    #14 0x0000000000442316 in DesktopView::event(QEvent*) ()
    #15 0x00007fd3f16d08cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
    #16 0x00007fd3f16d59d6 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
    #17 0x00007fd3f0349cf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
    #18 0x00007fd3f08916e4 in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () at /usr/lib64/libQt5Gui.so.5
    #19 0x00007fd3f089237d in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib64/libQt5Gui.so.5
    #20 0x00007fd3f08779f8 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Gui.so.5
    #21 0x00007fd3e07d9ed0 in () at /usr/lib64/libQt5XcbQpa.so.5
    #22 0x00007fd3ec113097 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
    #23 0x00007fd3ec1132c8 in () at /usr/lib64/libglib-2.0.so.0
    #24 0x00007fd3ec11336c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
    #25 0x00007fd3f039d50f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #26 0x00007fd3f034763a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #27 0x00007fd3f034f2fd in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
    #28 0x0000000000436571 in main ()

  3. #3

    Default Re: KDE and plasma5 crashes

    Additional information:

    I had a working 13.2 with a working KDE desktop environment.
    I made zypper dup (to Tumbleweed), the system let me to do that by repository change.
    The result: I have a Tumbleweed with non-working KDE environment (neither KDE4 and nor Plasma5), but there are several other working desktops.
    I sent a bug report to the KDE, they said that they sent a fix message to Leap and Tumbleweed developers before.
    I made a sign about this problem in an another opensuse thread also.
    I performed all Tumbleweed upgrades.

    Any idea?

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,926

    Default Re: KDE and plasma5 crashes

    Quote Originally Posted by venember View Post
    Additional information:

    I had a working 13.2 with a working KDE desktop environment.
    I made zypper dup (to Tumbleweed), the system let me to do that by repository change.
    The result: I have a Tumbleweed with non-working KDE environment (neither KDE4 and nor Plasma5), but there are several other working desktops.
    I sent a bug report to the KDE, they said that they sent a fix message to Leap and Tumbleweed developers before.
    I made a sign about this problem in an another opensuse thread also.
    I performed all Tumbleweed upgrades.

    Any idea?
    Wait for the fix and don't perform further Tumbleweed upgrades ?
    Best regards,
    Greg

  5. #5

    Default Re: KDE and plasma5 crashes

    Quote Originally Posted by glistwan View Post
    Wait for the fix and don't perform further Tumbleweed upgrades ?
    Yes...

    But I will like Tumbleweed, I think. Just the errors at the beginning... , and some skeletons in the cupboard.
    And the developer guys re-invented minimum half of the system, as I see.... (system flows and security).

  6. #6

    Default Re: KDE and plasma5 crashes

    Quote Originally Posted by venember View Post
    Reason: libthread_db.so.1 problem
    No.
    libpthread_db is some low-level system library and definitely not the problem.

    KDE message:
    "The appropriate fix has been submitted to openSUSE Tumbleweed and Leap: it's not a KDE software bug, but a PulseAudio one. See http://bugzilla.opensuse.org/show_bug.cgi?id=950487 for details."
    This is fixed since months. It was a problem after a pulseaudio update during the Leap Beta phase in October and got fixed shortly afterwards as you can see in that bug report.

    Your problem is something else.

    If I delete pulseaudio I can not get login screen...
    And how did you do that?
    The login screen should not need pulseaudio. Which one are you actually using?

    As a side-note, I don't have pulseaudio installed here and everything works fine including all login screens I have installed (kdm, gdm, xdm, and sddm). I'm on 13.2 though.

  7. #7

    Default Re: KDE and plasma5 crashes

    Quote Originally Posted by venember View Post
    Developer message:


    Application: Plasma (plasmashell), signal: Aborted
    Using host libthread_db library "/lib64/libthread_db.so.1".
    [Current thread is 1 (Thread 0x7fd3f655d900 (LWP 5633))]
    ...
    Thread 1 (Thread 0x7fd3f655d900 (LWP 5633)):
    [KCrash Handler]
    #6 0x00007fd3ef9d3d38 in raise () at /lib64/libc.so.6
    #7 0x00007fd3ef9d518a in abort () at /lib64/libc.so.6
    #8 0x00007fd3f016682e in () at /usr/lib64/libQt5Core.so.5
    #9 0x00007fd3f40735c4 in () at /usr/lib64/libQt5Quick.so.5
    #10 0x00007fd3f4074545 in () at /usr/lib64/libQt5Quick.so.5
    #11 0x00007fd3f407544e in () at /usr/lib64/libQt5Quick.so.5
    #12 0x00007fd3f0898c3b in QWindow::event(QEvent*) () at /usr/lib64/libQt5Gui.so.5
    #13 0x00007fd3f40ac621 in QQuickWindow::event(QEvent*) () at /usr/lib64/libQt5Quick.so.5
    #14 0x0000000000442316 in DesktopView::event(QEvent*) ()
    #15 0x00007fd3f16d08cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
    #16 0x00007fd3f16d59d6 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
    #17 0x00007fd3f0349cf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
    #18 0x00007fd3f08916e4 in QGuiApplicationPrivate::ProcessExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () at /usr/lib64/libQt5Gui.so.5
    #19 0x00007fd3f089237d in QGuiApplicationPrivate::ProcessWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib64/libQt5Gui.so.5
    #20 0x00007fd3f08779f8 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Gui.so.5
    #21 0x00007fd3e07d9ed0 in () at /usr/lib64/libQt5XcbQpa.so.5
    #22 0x00007fd3ec113097 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
    #23 0x00007fd3ec1132c8 in () at /usr/lib64/libglib-2.0.so.0
    #24 0x00007fd3ec11336c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
    #25 0x00007fd3f039d50f in QEventDispatcherGlib::ProcessEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #26 0x00007fd3f034763a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
    #27 0x00007fd3f034f2fd in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
    #28 0x0000000000436571 in main ()
    This is a crash in QtQuick and likely a graphics driver problem.
    Is your nvidia installation actually working?
    Please install "Mesa-demo-x" and post the output of "glxinfo | grep render".

    There is a known bug in the nvidia driver at the moment:
    https://bugzilla.opensuse.org/show_bug.cgi?id=957061
    Maybe try to install the latest beta version (361.18) that should have a fix.

    PS: you could also try to disable PulseAudio in YaST->Hardware->Audio->Other->PulseAudio Configuration if you cannot uninstall it to rule out that that's causing the problem.
    Last edited by wolfi323; 13-Jan-2016 at 16:27.

  8. #8

    Default Re: KDE and plasma5 crashes

    Quote Originally Posted by wolfi323 View Post
    This is a crash in QtQuick and likely a graphics driver problem.
    Is your nvidia installation actually working?
    Please install "Mesa-demo-x" and post the output of "glxinfo | grep render".

    There is a known bug in the nvidia driver at the moment:
    https://bugzilla.opensuse.org/show_bug.cgi?id=957061
    Maybe try to install the latest beta version (361.18) that should have a fix.

    PS: you could also try to disable PulseAudio in YaST->Hardware->Audio->Other->PulseAudio Configuration if you cannot uninstall it to rule out that that's causing the problem.
    It is a REMOTE machine.
    1. I can not decide CLEARLY what driver is loaded AND working. The Xorg.0.log is error-free. All desktops are working except from the KDE-related others.
    I installed nvidia driver on hard way from 352.63. I will try the newest beta. 352.63 is the latest driver on http://www.nvidia.com/Download/index.aspx?lang=en-us; for Geforce GT610
    Mesa demo already installed, the result:
    ****************
    Xlib: extension "GLX" missing on display "xxxxxx.xxx.xx:2.0"
    repeated
    Could not find RGB GLX Visual or fbconfig
    ***************
    I do not know that the X server has +iglx feature... I would try the KDE with a home script "LIBGL_ALWAYS_ENABLED=1" but crashing already at the start... and I do not know other solution in other desktops to visualize the feature from remote.

    2. A will try the beta version.

    3. I would not disturb the Pulseaudio if it does not contain the problem...

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,023

    Default AW: KDE and plasma5 crashes

    I will try the newest beta. 352.63 is the latest driver on http://www.nvidia.com/Download/index.aspx?lang=en-us; for Geforce GT610
    Klick on "Beta and Older Drivers" and you will get the whole list.

  10. #10

    Default Re: KDE and plasma5 crashes

    Quote Originally Posted by venember View Post
    It is a REMOTE machine.
    Remote in what regard?
    Do you connect via VNC?
    Then Plasma5 cannot work with the nvidia driver is installed. nvidia replaces some system libraries with their own incompatible versions, this breaks Mesa completely and expecially its software OpenGL renderer. NVidia's hardware OpenGL support obviously doesn't work over VNC...

    1. I can not decide CLEARLY what driver is loaded AND working. The Xorg.0.log is error-free. All desktops are working except from the KDE-related others.
    I installed nvidia driver on hard way from 352.63. I will try the newest beta. 352.63 is the latest driver on http://www.nvidia.com/Download/index.aspx?lang=en-us; for Geforce GT610
    Mesa demo already installed, the result:
    ****************
    Xlib: extension "GLX" missing on display "xxxxxx.xxx.xx:2.0"
    repeated
    Could not find RGB GLX Visual or fbconfig
    ***************
    So, there you have your problem.
    OpenGL/GLX is not working, but Plasma5 requires it.
    Other desktops don't need OpenGL, so they do work. GNOME e.g. won't work either though.

    The only way I know of to get Plasma5 (or other OpenGL applications) working, would be to uninstall the nvidia driver and use nouveau.

    It *might* help to force Plasma5 (or Qt5 rather) to use software rendering:
    http://lists.opensuse.org/opensuse-kde/2015-11/msg00037.html
    But I fear the nvidia driver will still be in the way...
    Last edited by wolfi323; 14-Jan-2016 at 03:43.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •