Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: variety

  1. #1

    Default variety

    Hi,


    I use KDE on VERSION="Tumbleweed"
    VERSION_ID="20160105"


    I have been using variety for backgrounds for a month.

    # zypper info variety
    Loading repository data...
    Reading installed packages...




    Information for package variety:
    --------------------------------
    Repository: openSUSE:Factory
    Name: variety
    Version: 0.5.4-1.1
    Arch: noarch
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 2.1 MiB
    Summary: Wallpaper changer


    It no longer starts a week ago and gives this error:


    /usr/lib/python2.7/site-packages/variety/__init__.py:105: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk',
    '3.0') before import to ensure that the right version gets loaded.
    from gi.repository import Gtk, Gdk, GObject # pylint: disable=E0611
    Traceback (most recent call last):
    File "/usr/bin/variety", line 38, in <module>
    import variety
    File "/usr/lib/python2.7/site-packages/variety/__init__.py", line 107, in <module>
    from variety import VarietyWindow
    File "/usr/lib/python2.7/site-packages/variety/VarietyWindow.py", line 22, in <module>
    from variety.FacebookHelper import FacebookHelper
    File "/usr/lib/python2.7/site-packages/variety/FacebookHelper.py", line 55, in <module>
    from variety.Util import Util
    File "/usr/lib/python2.7/site-packages/variety/Util.py", line 28, in <module>
    import pyexiv2
    File "/usr/lib64/python2.7/site-packages/pyexiv2/__init__.py", line 60, in <module>
    import libexiv2python
    ImportError: /usr/lib64/libboost_python.so.1.59.0: undefined symbol: PyUnicode_AsUTF8String

    Ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,841
    Blog Entries
    15

    Default Re: variety

    On Fri 08 Jan 2016 01:26:01 AM CST, nostradomis wrote:

    Hi,


    I use KDE on VERSION="Tumbleweed"
    VERSION_ID="20160105"


    I have been using variety for backgrounds for a month.

    # zypper info variety
    Loading repository data...
    Reading installed packages...




    Information for package variety:
    --------------------------------
    Repository: openSUSE:Factory
    Name: variety
    Version: 0.5.4-1.1
    Arch: noarch
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 2.1 MiB
    Summary: Wallpaper changer


    It no longer starts a week ago and gives this error:


    /usr/lib/python2.7/site-packages/variety/__init__.py:105: PyGIWarning:
    Gtk was imported without specifying a version first. Use
    gi.require_version('Gtk',
    '3.0') before import to ensure that the right version gets loaded.
    from gi.repository import Gtk, Gdk, GObject # pylint: disable=E0611
    Traceback (most recent call last):
    File "/usr/bin/variety", line 38, in <module>
    import variety
    File "/usr/lib/python2.7/site-packages/variety/__init__.py", line 107,
    in <module>
    from variety import VarietyWindow
    File "/usr/lib/python2.7/site-packages/variety/VarietyWindow.py", line
    22, in <module>
    from variety.FacebookHelper import FacebookHelper
    File "/usr/lib/python2.7/site-packages/variety/FacebookHelper.py", line
    55, in <module>
    from variety.Util import Util
    File "/usr/lib/python2.7/site-packages/variety/Util.py", line 28, in
    <module>
    import pyexiv2
    File "/usr/lib64/python2.7/site-packages/pyexiv2/__init__.py", line 60,
    in <module>
    import libexiv2python
    ImportError: /usr/lib64/libboost_python.so.1.59.0: undefined symbol:
    PyUnicode_AsUTF8String

    Ideas?


    Hi
    Would appear to be a common bug at the moment;
    https://bugzilla.opensuse.org/show_bug.cgi?id=960496

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.2|3.12.51-60.20-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,841
    Blog Entries
    15

    Default Re: variety

    On Fri 08 Jan 2016 01:26:01 AM CST, nostradomis wrote:

    Hi,


    I use KDE on VERSION="Tumbleweed"
    VERSION_ID="20160105"


    I have been using variety for backgrounds for a month.

    # zypper info variety
    Loading repository data...
    Reading installed packages...




    Information for package variety:
    --------------------------------
    Repository: openSUSE:Factory
    Name: variety
    Version: 0.5.4-1.1
    Arch: noarch
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 2.1 MiB
    Summary: Wallpaper changer


    It no longer starts a week ago and gives this error:


    /usr/lib/python2.7/site-packages/variety/__init__.py:105: PyGIWarning:
    Gtk was imported without specifying a version first. Use
    gi.require_version('Gtk',
    '3.0') before import to ensure that the right version gets loaded.
    from gi.repository import Gtk, Gdk, GObject # pylint: disable=E0611
    Traceback (most recent call last):
    File "/usr/bin/variety", line 38, in <module>
    import variety
    File "/usr/lib/python2.7/site-packages/variety/__init__.py", line 107,
    in <module>
    from variety import VarietyWindow
    File "/usr/lib/python2.7/site-packages/variety/VarietyWindow.py", line
    22, in <module>
    from variety.FacebookHelper import FacebookHelper
    File "/usr/lib/python2.7/site-packages/variety/FacebookHelper.py", line
    55, in <module>
    from variety.Util import Util
    File "/usr/lib/python2.7/site-packages/variety/Util.py", line 28, in
    <module>
    import pyexiv2
    File "/usr/lib64/python2.7/site-packages/pyexiv2/__init__.py", line 60,
    in <module>
    import libexiv2python
    ImportError: /usr/lib64/libboost_python.so.1.59.0: undefined symbol:
    PyUnicode_AsUTF8String

    Ideas?


    Hi
    Would appear to be a common bug at the moment;
    https://bugzilla.opensuse.org/show_bug.cgi?id=960496

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.2|3.12.51-60.20-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #4
    Join Date
    Feb 2016
    Location
    Louisiana
    Posts
    8

    Default Re: variety

    Malcom, thanks for making this available in OpenSuse.
    I checked the bugzilla report and it says this is fixed in the latest Tumbleweed update, but for me it's not.


    Repository: @System
    Name: variety
    Version: 0.5.5-18.1
    Arch: noarch
    Vendor: obs://build.opensuse.org/home:simotek
    Installed: Yes
    Status: up-to-date
    Installed Size: 2.1 MiB
    Summary: Wallpaper changer
    Description:
    Variety changes the desktop wallpaper on a regular basis, using user-specified
    or automatically downloaded images.

    Variety sits conveniently as an indicator in the panel and can be easily
    paused
    and resumed. The mouse wheel can be used to scroll wallpapers back and forth
    until you find the perfect one for your current mood.

    Apart from displaying images from local folders, several different online
    sources
    can be used to fetch wallpapers according to user-specified criteria.

    beameup@linux-1wyf:~> variety
    /usr/lib/python2.7/site-packages/variety/__init__.py:105: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
    from gi.repository import Gtk, Gdk, GObject # pylint: disable=E0611
    Traceback (most recent call last):
    File "/usr/bin/variety", line 38, in <module>
    import variety
    File "/usr/lib/python2.7/site-packages/variety/__init__.py", line 107, in <module>
    from variety import VarietyWindow
    File "/usr/lib/python2.7/site-packages/variety/VarietyWindow.py", line 22, in <module>
    from variety.FacebookHelper import FacebookHelper
    File "/usr/lib/python2.7/site-packages/variety/FacebookHelper.py", line 55, in <module>
    from variety.Util import Util
    File "/usr/lib/python2.7/site-packages/variety/Util.py", line 28, in <module>
    import pyexiv2
    File "/usr/lib64/python2.7/site-packages/pyexiv2/__init__.py", line 60, in <module>
    import libexiv2python
    ImportError: /usr/lib64/python2.7/site-packages/libexiv2python.so: undefined symbol: _ZNK5Exiv27ExifKey8tagLabelEv
    I've installed python-pillow as I found in a blog post but after I had installed Variety.
    So I did sudo aptitude install variety and it recommended an updated version 0.5.5-18.1 which I installed.

    Any ideas on what I'm missing? I know it requires Imagemagic on Ubuntu and I think the X11 screensaver package on Fedora.
    Not too swift on Python editing but I can follow directions


    I'm using Gnome desktop
    Last edited by beameup; 15-Feb-2016 at 13:52. Reason: add Desktop

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,841
    Blog Entries
    15

    Default Re: variety

    Quote Originally Posted by beameup View Post
    Malcom, thanks for making this available in OpenSuse.
    I checked the bugzilla report and it says this is fixed in the latest Tumbleweed update, but for me it's not.




    I've installed python-pillow as I found in a blog post but after I had installed Variety.
    So I did sudo aptitude install variety and it recommended an updated version 0.5.5-18.1 which I installed.

    Any ideas on what I'm missing? I know it requires Imagemagic on Ubuntu and I think the X11 screensaver package on Fedora.
    Not too swift on Python editing but I can follow directions


    I'm using Gnome desktop
    Hi
    I only built the initial package, it's not maintained by me anymore

    I would recommend switch back to the tumbleweed released version, rather than the current maintainers home directory.

    These are the required packages, also make sure these are from Tumbleweed repos;
    Code:
    Requires:       ImageMagick
    Requires:       dbus-1-python
    Requires:       libnotify4
    Requires:       python-beautifulsoup4
    Requires:       python-configobj
    Requires:       python-httplib2
    Requires:       python-lxml
    Requires:       python-Pillow
    Requires:       python-pycurl
    Requires:       python-pyexiv2
    Requires:       python-webkitgtk
    Requires:       yelp
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Feb 2016
    Location
    Louisiana
    Posts
    8

    Default Re: variety

    ok thanks. I'll give that a shot and let y'all know how it goes.

  7. #7
    Join Date
    Feb 2016
    Location
    Louisiana
    Posts
    8

    Default Re: variety

    I removed my version, then removed the 2 extra repositories that were added when I did that 1 click install from the website.
    Then I rebooted and used Yast to install the Tumbleweed version.
    That didn't change the error. The developer is only issuing Debian releases so I guess I'll have to wait and try to sort this out.
    Really not anything else similar at the moment.

    Thanks.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,841
    Blog Entries
    15

    Default Re: variety

    On Mon 15 Feb 2016 11:06:02 PM CST, beameup wrote:

    I removed my version, then removed the 2 extra repositories that were
    added when I did that 1 click install from the website.
    Then I rebooted and used Yast to install the Tumbleweed version.
    That didn't change the error. The developer is only issuing Debian
    releases so I guess I'll have to wait and try to sort this out.
    Really not anything else similar at the moment.

    Thanks.


    Hi
    One wonders if the bug has crept back in?

    If you duplicating it, then I would suggest re-opening it indicating
    the error.....

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,841
    Blog Entries
    15

    Default Re: variety

    On Mon 15 Feb 2016 11:06:02 PM CST, beameup wrote:

    I removed my version, then removed the 2 extra repositories that were
    added when I did that 1 click install from the website.
    Then I rebooted and used Yast to install the Tumbleweed version.
    That didn't change the error. The developer is only issuing Debian
    releases so I guess I'll have to wait and try to sort this out.
    Really not anything else similar at the moment.

    Thanks.


    Hi
    One wonders if the bug has crept back in?

    If you duplicating it, then I would suggest re-opening it indicating
    the error.....

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10
    Join Date
    Feb 2016
    Location
    Louisiana
    Posts
    8

    Default Re: variety

    I added a comment to the bug.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •